PHP5.6 Installation legt Server Lahm

Ja würde mich ja gerne freuen wenn es dauerhaft wäre,aber irgendwas stimmt immer noch nicht es ging eben alles Perfekt ca eine halbe std lang und nun mit einemal das selbe ist wider da nichts an Webseiten ist mehr erreichbar.
 
Ich habe in Plesk ein Server Monitoring für den Serverzustand dort sind überall Grüne Haken davor un dahinter OK.
 
Last edited:
Ich bin mir leider nicht sicher aber wäre der Pfad /var/log/php7.0-fpm.log und Datei richtig?

Das Problem tritt erst auf wenn ich einen Kunden in Plesk anlege und php-5.6 anwende.
 
Ich bin nun schon seit std auf der suche nach der Passenden logfile ohne erfolg und habe dann Folgende Variante versucht.
Code:
cd /usr/local/src/

wget http://de1.php.net/get/php-5.6.40.tar.gz/from/this/mirror -O php-5.6.40.tar.gz

tar xf php-5.6.40.tar.gz

apt-get install make gcc libxml2-dev

cd php-5.6.40/
mkdir -p /usr/local/php-5.6.40
./configure 
'--with-libdir=lib64' '--cache-file=../config.cache' '--prefix=/usr/local/php-5.6.40' '--with-config-file-path=/usr/local/php-5.6.40/etc' '--disable-debug' '--with-pic' '--disable-rpath' '--enable-fastcgi' '--with-bz2' '--with-curl' '--with-freetype-dir=/usr/local/php-5.6.40' '--with-png-dir=/usr/local/php-5.6.40' '--enable-gd-native-ttf' '--without-gdbm' '--with-gettext' '--with-gmp' '--with-iconv' '--with-jpeg-dir=/usr/local/php-5.6.40' '--with-openssl' '--with-pspell' '--with-pcre-regex' '--with-zlib' '--enable-exif' '--enable-ftp' '--enable-sockets' '--enable-sysvsem' '--enable-sysvshm' '--enable-sysvmsg' '--enable-wddx' '--with-kerberos' '--with-unixODBC=/usr' '--enable-shmop' '--enable-calendar' '--without-sqlite3' '--with-libxml-dir=/usr/local/php-5.6.40' '--enable-pcntl' '--enable-mbstring' '--enable-mbregex' '--with-gd' '--enable-bcmath' '--with-xmlrpc' '--with-mysql=/usr' '--with-mysqli' '--with-snmp' '--enable-soap' '--with-xsl' '--enable-xmlreader' '--enable-xmlwriter' '--enable-pdo' '--with-pdo-mysql' '--with-pdo-pgsql' '--with-pear=/usr/local/php-5.6.40/pear' '--with-mcrypt' '--enable-intl' '--without-pdo-sqlite' '--with-config-file-scan-dir=/usr/local/php-5.6.40/php.d'

make
make install

plesk bin php_handler --add -displayname "5.6.40" -path /usr/bin/php-cgi -clipath /usr/bin/php -phpini /opt/plesk/php/5.6.40/etc/php.ini -type cgi
plesk bin php_handler --add -displayname "5.6.40" -path /usr/bin/php-cgi -clipath /usr/bin/php -phpini /opt/plesk/php/5.6.40/etc/php.ini -type fastcgi
plesk bin php_handler --add -displayname "5.6.40" -path /usr/bin/php -clipath /usr/bin/php -phpini /opt/plesk/php/5.6.40/etc/php.ini -type fpm -service php5-fpm -poold /etc/php5-fpm/pool.d
Aber leider nach einer std ging das selbe wider los,das die Webseiten nicht mehr erreichbar waren.
Ich komme daher nur zu dem schluss das Debian9,Plesk und PHP5 nicht Kompatibel sein können.
 
Nach dem make install wurden mir diese Pfade angezeigt?

Wen ich die Pfade vergleiche und auf dem FTP nach schaue stimmt keiner wie kann ich die Pfade die ich benötige ermitteln das sie stimmen?
 
Last edited:

GwenDragon

Registered User
Plesk ein Server Monitoring für den Serverzustand
Mit so einem kurzen Plesk-Schnickschnack kannst du doch nichts sehen.
Ich meinte ein Monitoring für alle möglichen Ressourcen wie Ladezeit voon Domains, Datenbank, CPU, RAM, Netzwerk, etc. – kann mit Munin, Icinga o.ä. gemacht werden.
 

GwenDragon

Registered User
@netzreiter Ich hatte doch schon mal in einem anderen Thread dich gebeten, für die Handler Pfade auf die PHP-Binary/Configs richtig zu setzen.
Warum du die Pfade für die Handler trotzdem immer noch falsch setzt, weiß ich auch nicht.
Warum du /usr/local/ als Zielverzeichnis wolltest, erschließt sich mir auch nicht. Plesk legt selbst die installierten PHP unter /opt/plesk/php/ ab.

Beschäftige dich doch bitte mal ein bisschen mehr mit deinem System und Plesk-Interna bevor du mit Schnellschüssen PHP selbst kompilierst.

Wen ich die Pfade vergleiche und auf dem FTP
Bitte was?
Auf FTP wird niemals der korrekt Pfade angezeigt.
Logge dich bitte per SSH ein und schau da nach!

Ich komme daher nur zu dem schluss das Debian9,Plesk und PHP5 nicht Kompatibel sein können.
Wenn man das System falsch konfiguriert (oder soll ich sagen aus Ignoranz/Lernresistenz verhunzt) ist das auch nicht kompatibel.

Ich schüttel den Kopf wie mann mit so wenig Hintergrundwissen am System arbeiten will. Und ich denke gerade: Lass den Mann mal machen… er soll ruhig lernen.
 
Last edited:
Ich habe den Pfad /usr/local/ und /usr/local/scr geändert in /opt/plesk/php/ ,ich würde mir die passenden Pfade gerne über SSH anzeigen lassen kenne aber leider den befehl dazu nicht.

Gibt es eine Dokumentation über die Befehle die man so benötigt?

Ja ich lerne so dazu klar ich mache schon lange damit rum,aber habe noch nicht jede sache kennen gelernt oder benötigt und daher fehlt mir hier und da noch wissen.
 

GwenDragon

Registered User
Gibt es eine Dokumentation über die Befehle die man so benötigt?
Welche Befehle wofür?

Ich habe den Pfad /usr/local/ und /usr/local/scr geändert in /opt/plesk/php/
Wieso willst du src dort hin schieben?

Erklär lieber genauer was du nicht verstehst.
Ich kann dich doch nicht Schritt für Schritt an die Hand nehmen, damit du lernst wie man selbst PHP für Plesk kompiliert und richtig konfiguriert. Dazu fehlt mir auch gerade Zeit und Geduld dir Nachhilfe zu geben.
Du kannst gern auch auf https://talk.plesk.com/forums/plesk-onyx-for-linux.744/ die Leute löchern ob sie dich an die Hand nehmen.
 
Last edited:

nexus

Well-Known Member
ich würde mir die passenden Pfade gerne über SSH anzeigen lassen kenne aber leider den befehl dazu nicht.

Gibt es eine Dokumentation über die Befehle die man so benötigt?
So langsam kommt in mir das Gefühl hoch, daß du uns hier verarschen willst...

Sollten deine Fragen aber tatsächlich ernst gemeint sein, dann kann ich nur darauf verweisen:
Normalerweise erwähne ich die Option eines Umzugs auf einen Webspace nur als mögliche Alternative...Dir aber muß man dringend dazu raten, den Server zu kündigen und auf Webspaceangebote zu wechseln!
 
@GwenDragon
Ich möchte src nicht dort hin verschieben,das ist dann eventuell Falsch rüber gebracht worden von mir sorry.

Wenn ich wüsste wie genau ich die Pfade finde um sie im Folgenden richtig angeben zu können,wäre ich schon fertig.
Code:
plesk bin php_handler --add -displayname "5.6.40" -path /usr/bin/php-cgi -clipath /usr/bin/php -phpini /opt/plesk/php/5.6.40/etc/php.ini -type cgi
plesk bin php_handler --add -displayname "5.6.40" -path /usr/bin/php-cgi -clipath /usr/bin/php -phpini /opt/plesk/php/5.6.40/etc/php.ini -type fastcgi
plesk bin php_handler --add -displayname "5.6.40" -path /usr/bin/php -clipath /usr/bin/php -phpini /opt/plesk/php/5.6.40/etc/php.ini -type fpm -service php5-fpm -poold /etc/php5-fpm/pool.d
@nexus
ich möchte mit sicherheit niemanden verarschen ich habe zwar schon länger mit der sache zutun mit Unterbrechungen,aber ich habe ohne irgendwelche erfahrungen angefangen und bin mit der ganzen Materie völlig allein und mein Verständniss von der sache zu einem Profi ist noch weit entfernt.
 

GwenDragon

Registered User
Ungetested aus Zeitmangel.
Kann nicht gehen: -path /usr/bin/php-cgi -clipath /usr/bin/php
Wenn schon, dann die Pfade in /opt/plesk/...../bin!
bspw.: /opt/plesk/php/5.6.40/bin/php-cgi
bei php-cli nimmst du das php in bin (weil es kein php-cli gibt),
und die php-fpm liegt in sbin/.

Anzupassen für die anderen auch.

So, ich muss auch noch arbeiten.
 
Last edited:
Vielen dank ich komme irgendwie mit den Pfaden nicht klar,ich habe nun versucht es wie folgt in Plesk als Handler an zu geben.
Code:
plesk bin php_handler --add -displayname "5.6.40" -path /opt/plesk/php/5.6.40/bin/php-cgi -clipath /usr/bin/php -phpini /opt/plesk/php/5.6.40/etc/php.ini -type cgi
und ssh/putty gibt dazu.
Code:
[2019-09-16 07:36:50.692] ERR [util_exec] proc_close() failed ['/opt/psa/admin/bin/php_handlers_control' '--add' '--path' '/opt/plesk/php/5.6.40/bin/php-cgi' '--phpini' '/opt/plesk/php/5.6.40/etc/php.ini' '--type' 'cgi' '--displayname' '5.6.40' '--clipath' '/usr/bin/php'] with exit code [1]
Unable to register the PHP handler: Binary /opt/plesk/php/5.6.40/bin/php-cgi doesn't exists
Wen ich es so angebe
Code:
plesk bin php_handler --add -displayname "MyHandler 5.4" -path /usr/bin/php-cgi -clipath /usr/bin/php -phpini /opt/plesk/php/5.4/etc/php.ini -type fastcgi
Wird es eingetragen
 

marce

Well-Known Member
Steht doch da:
Code:
Binary /opt/plesk/php/5.6.40/bin/php-cgi doesn't exists
... und nochmals: Schau Dir die Doku zu php an, was --prefix denn so macht beim configure und dann schau Dir mal an, was ggf. nach dem Build in evtl. aus der zugehörigen Doku zu ermittelnden Pfaden so gelandet ist und überleg dann nochmal, was Du evtl. Plesk mitteilen willst und welche Pfade wo wie anzupassen wären.

... oder besorg' Dir Manged Hosting.
 

danton

Debian User
Beim Compiler-Lauf von PHP gibst du durch Parameter an, wohin PHP am Ende mit make install installiert wird. Entsprechend musst du dann auch die Pfade angeben, wenn du den Plesk-Handler erstellst.
Per SSH einfach mal im Dateisystem nachschauen, welche Pfade und Dateien existieren (und ob z.b. php und php-cgi vorhanden sind) kannst du aber schon, oder? Hint: Ein Programm wie der Midnight Commander (ggfl. per Paketverwaltung installieren, Aufruf mit mc) mach das ganze einfacher.
Außerdem verstehe ich nicht, warum du es nun mit einem Eigenkompilat versuchst. Die Pakete von deb.sury.org trennen die einzelnen PHP-Versionen sauber und der Maintainer weiss auf Grund seiner langen Erfahrung mit der Paketierung von PHP sicherlich besser, was er da tut.
Auch wenn es jetzt hart klingt: Du scheinst überhaupt nicht zu wissen, was du da machst, hast kein Ahnung, wo deine Logdateien liegen oder was deren Inhalt dir sagt usw. - daher habe ich den Eindruck, dass für dich Webspace oder ein Managed Server die eindeutig besser Wahl ist.
BTW: In der Zeit, die du hier bereits investierst, hättest du vermutlich schon einen Großteil deiner Seite fit für PHP 7 machen können.
 
Ich danke euch allen,aber ich gebe es auf ich finde weder die Ursache was die Webseiten nach der php5.6 Installation lahm legt noch bekomme ich die Installation mit den Pfaden hin.

Meine erfahrung reicht dazu einfach leider nicht.
 
Top