Probleme beim Clan-Point webinterface

michael-08

Blog Benutzer
Habe jetzt mal alle Rückgabewerte hier aufgeschrieben. Hoffe das hilft dir mehr

nein, da ich kein Ubuntu nutze.

Ob das nun die richtige sources.list fuer lenny/sid ist kann ich Dir leider nicht sagen.

ehrlich gesagt wundert mich das

Code:
cat /etc/debian_version

bei Ubuntu funktioniert
 
Last edited by a moderator:

NeoFromBerlin

New Member
Code:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Building tag database... Done
The following packages will be REMOVED:
  at{p}
0 packages upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
Need to get 0B of archives. After unpacking 213kB will be freed.
Do you want to continue? [Y/n/?] Y
Writing extended state information... Done
(Reading database ... 64846 files and directories currently installed.)
Removing at ...
 * Stopping deferred execution scheduler atd
[COLOR="Red"]invoke-rc.d: initscript atd, action "stop" failed.[/COLOR]
Purging configuration files for at ...
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Writing extended state information... Done
Building tag database... Done
 

NeoFromBerlin

New Member
Ah apt-get geht nun wieder nach dem:
Code:
aptitude purge at
Aber bei der installation komm immernoch:

Code:
             check user (root):                                                 OK
             detect distri:                                                     OK (debian)
             checking which:                                                    OK
             checking make:                                                     OK
             checking automake:                                                 OK
             checking autoconf:                                                 OK
             checking screen:                                                   OK
             checking libtool:                                                  OK
             checking m4:                                                       OK
             checking flex:                                                     OK
             checking rrdtool:                                                  OK
             checking zlib:                                                     OK
             checking libjpeg:                                                  OK
             checking libpng:                                                   OK
             checking libssl-dev:                                               OK
             checking libmcrypt-dev:                                            OK
             checking locate:                                                   OK
             checking wget:                                                     OK
             checking sudo:                                                     OK
             checking mysql-client:                                             OK
             checking libxml2 dev:                                              OK

             Apache erkennen
             Es wird der Pfad aus der Konfigurationsdatei übernommen (/usr/sbin/apache2)
             Es konnte keine apxs Programm gefunden werden !
             Eventuell fehlen in ihrem System die "devel" Packete des Apache
             PHP wurde in der httpd.conf als Modul Version entdeckt, die APXS benötigt um sie zu installieren
             Wird die PHP Version falsch entdeckt, muss es in der config eingestellt werden

apache2-prefork-dev ist auch installiert und php5 auch.

Es gibt auch eine update.sh, damit sollte man die Hauptsoftware anpassen können. Aber diese sagt das:
Code:
     Updateskript Gameserver Control-Panel


     Unterstützung für einen Packet-Manager gibt es für SuSE und Debian.
     Die Nutzung erfolgt auf eigene Gefahr und Clan-Point übernimmt keine Haftung für Schäden am System.

     Update jetzt starten? [y/n]         y


             check user (root):                                                 OK
             detect distri:                                                     OK (debian)
             PHP updaten (php-4.4.7) [y/n]                   y
             htmldoc updaten (htmldoc-1.8.23) [y/n]          y
             qstat updaten (qstat-2.11) [y/n]                y

             Apache erkennen
             Es wird der Pfad aus der Konfigurationsdatei übernommen (/usr/sbin/apache2)
             Es konnte keine Apache Konfigurations Datei gefunden werden !
             Sollte ein Apache Installiert sein geben sie die Pfade in der Datei config an !
             Ansonsten muss ein Apache Webserver installiert sein um das Webinterface zu installieren
 
Last edited by a moderator:

voodoo44

Registered User
Es steht doch alles da!

Code:
             Apache erkennen
             Es wird der Pfad aus der Konfigurationsdatei übernommen (/usr/sbin/apache2)
             Es konnte keine Apache Konfigurations Datei gefunden werden !
             Sollte ein Apache Installiert sein geben sie die Pfade in der Datei config an !
             Ansonsten muss ein Apache Webserver installiert sein um das Webinterface zu installieren
Wo liegt denn deine Apache-Konfigurationsdatei? Diesen Pfad sollst du in der config-Datei deines Admin-Interfaces anpassen.

Ist das so schwer? :/
 

voodoo44

Registered User
Ich kenne dein Admin-Interface nicht ...

Dennoch ist die Meldung doch recht eindeutig - du musst das Apache-Konfigurationsfile im Webinterface deines Server-Admin-Dingsda angeben.
 

Drugsii

New Member
So habe es Nocheinmal probiert das in die config einzutragen ..

da ich aber nicht alle Pfade ausfüllen kann da ich nicht weiß wo sie sind klappt es immer noch nicht

httpd_bin=; ?
httpd_conf=; ich glaube /etc/apache2/apache2.conf
httpd_apxs=; ?

Ich habe die config mal eingefügt im anhang

Hoffe ihr könnt mir helfen
 

Attachments

  • config.txt
    2.1 KB · Views: 160
Last edited by a moderator:

voodoo44

Registered User
## Angaben zum Apache Server falls die automatische erkennung fehlschlägt
httpd_bin=;
httpd_conf=;
httpd_apxs=;

httpd_user=;
httpd_group=;
Da ist ja nun auch garnichts eingetragen ... wie wäre es, wenn man das mal tut? ^^"
 

voodoo44

Registered User
find / -iname "apache2.conf" für die config,
/usr/sbin/apache2 sollte die apache2 binary sein
find / -iname "apxs" sollte bei der Suche nach dem APXS-Eintrag helfen.

Gruppe und User für den Apache wirst du wohl am einfachsten mittels htop, bzw. /etc/passwd rausfinden.
 

NeoFromBerlin

New Member
Code:
## Angaben zum Apache Server falls die automatische erkennung fehlschlägt
httpd_bin=/usr/sbin/apache2;
httpd_conf=/etc/apache2/httpd.conf;
httpd_apxs=;

httpd_user=;
httpd_group=;

So weit komme ich, aber wo der Rest sein soll, weiß ich nicht. Auch nicht mit
Code:
locate httpd
 

Drugsii

New Member
apxs probleme neo postet das nochmal genau ...



Neues Porblem aber trozdem :
PHP:
Ich glaube damit sollten wir das schaffen ich danke schon mal allen die geholfen haben :D 

und ganz besonders dir voodoo44

wen wir es probiert haben melde ich mich nocheinmal :D:D;);)
 
Last edited by a moderator:

voodoo44

Registered User
/usr/sbin/apxs2 - liegt da evtl. apxs drin?

Irgendwo muss es ja liegen - und mit einem find sollte das doch eigentlich aufzutreiben sein - sofern es denn bei euch überhaupt installiert ist.
 

Drugsii

New Member
da liegt glaube auch das problem es ist gar net drauf :rolleyes::rolleyes:
wir instalieren es mal schnell und kucken ob es geht und sagen den bescheid
 

NeoFromBerlin

New Member
Mh... ich habe jetzt mal die PHP-Version Installiert, die der Installation bei liegt und auch soweit die config Datei des Installers angepasst:
Code:
## Angaben zum Apache Server falls die automatische erkennung fehlschlägt
httpd_bin=/usr/sbin/apache2;
httpd_conf=/etc/apache2/apache2.conf;
httpd_apxs=;

httpd_user=root;
httpd_group=root;

Und nein ich finde kein APXS auf dem Server. Auch nicht unter deinem Pfad und auch nicht wenn ich danach suche. Also bleibt der Fehler bestehen:
Code:
             Apache erkennen
             Es wird der Pfad aus der Konfigurationsdatei übernommen (/usr/sbin/apache2)
             Es konnte keine apxs Programm gefunden werden !
             Eventuell fehlen in ihrem System die "devel" Packete des Apache
             PHP wurde in der httpd.conf als Modul Version entdeckt, die APXS benötigt um sie zu installieren
             Wird die PHP Version falsch entdeckt, muss es in der config eingestellt werden
 

NeoFromBerlin

New Member
Wenn es so leicht wäre...

Laut allen Anleitungen und "apt-cache search apsx2" gibt es 2 Pakete die es gibt:
Code:
apache2-prefork-dev - development headers for apache2
apache2-threaded-dev - development headers for apache2
So ich habe eben das prefork installiert, aber es gibt immer noch kein apxs...
 

NeoFromBerlin

New Member
OK irgendwie geht es jetzt habe nochmal alles durchsuchen lassen mit "locate apxs" und er hatte nun etwas gefunden -> /usr/share/man/man8/apxs2.8.gz
Das habe ich dann entpackt und ausgeführt beim nächsten durchsuchen mit "locate apxs2" fand er dann usr/bin/apxs2 und nun installiert er bin mal gespannt wie weit.

Danke für alle Antworten ich editiere dann den Beitrag wenn es geht!
 
Top