Probleme beim Clan-Point webinterface

Drugsii

New Member
Hallo Liebe Community,

Ich habe ein Problem ich will mir von Clan-point das Webinterface für Gameserver
Installieren und da muss ich am Anfang die Install.sh ausführen da checkt er den erstmal ob alles vorhanden ist da steht auch überall ok aber danach kommt der fehler

PHP:
Apache erkennen                                                     
             Es wird der Pfad aus der Konfigurationsdatei übernommen (/usr/sbin/ 
apache2)     Es konnte keine apxs Programm gefunden werden !                     
             Eventuell fehlen in ihrem System die "devel" Packete des Apache     
             PHP wurde in der httpd.conf als Modul Version entdeckt, die APXS be 
nötigt um sie zu installieren                                                    
             Wird die PHP Version falsch entdeckt, muss es in der config eingest 
ellt werden

Ich hoffe einer kann mir helfen
Gruß Drugsii
 

Drugsii

New Member
Danke für den Tipp,

und nein habe ich noch nicht ich bin mehr oder weniger neu in dem Gebiet,
aber vll. kannst du mir ja sagen wie ich das mache würde mich sehr freuen :D
 

bibabu

Registered User
Je nach Betriebssystem (Linux ist kein Betriebssystem) kannst du die Paketverwaltung durchsuchen. Unter Debian heißt das Paket apache2-${MPM}-dev. ${MPM} natürlich durch das genutzte MPM ersetzen.
 

Drugsii

New Member
hmm okay wie gesagt bin neu in diesem Gebiet :eek:
weiß jetzt nicht genau wie du das meinst
also ich habe auch nicht debian ich habe ubuntu
was soll ich da genau machen via putty oder ftp ?
 

bad_brain

Registered User
@bibabu
Kleine Korrektur: Für Prefork heisst das Paket, wie du sagtest, apache2-prefork-dev, für Worker jedoch apache2-threaded-dev (nicht worker-dev).

@Drugsii
Die Paketnamen unter Ubuntu sind üblicherweise die Selben wie für Debian.
Installiert werden diese unter Benutzung von apt:
Code:
apt-get install <paketname>
Da du jedoch apt anscheinend nicht kennst ist anzunehmen dass du noch nie ein Systemupdate ausgeführt hast? Oder läuft das automatisch bei dir?
Also auf jeden Fall zuerst einmal:
Code:
apt-get update
apt-get upgrade
Danach das passende Apache dev Paket installieren:
http://wiki.ubuntuusers.de/apt-get
 
Last edited by a moderator:

Drugsii

New Member
ich habe schon was von apt-get gehört aber leider bin ich einfach ratlos was ich machen soll den das webinterface raubt mir schon seit ein paar tagen jeden nerv
und ich werde es mit dem / update und upgrade mal testen

Edit#1:

so das ist passiert:
PHP:
hier rüber kamm noch was das habe ich leider nicht mehr durch putty einfangen können 

Hit http://archive.ubuntu.com hardy/universe Packages                           
Hit http://archive.ubuntu.com hardy-updates/main Packages                       
Hit http://archive.ubuntu.com hardy-updates/restricted Packages                 
Hit http://archive.ubuntu.com hardy-updates/universe Packages                   
Hit http://archive.ubuntu.com hardy-security/main Packages                      
Hit http://archive.ubuntu.com hardy-security/restricted Packages                
Hit http://archive.ubuntu.com hardy-security/universe Packages                  
Reading package lists... Done                                                   
root@21-01:~# apt-get upgrade                                                   
Reading package lists... Done                                                   
Building dependency tree                                                        
Reading state information... Done                                               
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.                  
1 not fully installed or removed.                                               
After this operation, 0B of additional disk space will be used.                 
Do you want to continue [Y/n]? y                                                
Setting up at (3.1.10ubuntu4) ...                                               
 * Starting deferred execution scheduler atd                                    
invoke-rc.d: initscript atd, action "start" failed.                             
dpkg: error processing at (--configure):                                        
 subprocess post-installation script returned error exit status 1               
Errors were encountered while processing:                                       
 at                                                                             
E: Sub-process /usr/bin/dpkg returned an error code (1)

hoffe da kann mir einer helfen
 
Last edited by a moderator:

voodoo44

Registered User
ich persönlich bevorzuge im übrigen folgende Zeile:
Code:
aptitude update && aptitude safe-upgrade

Aber das ist wohl Geschmackssache :)
 

Drugsii

New Member
aber das hilft mir ja jetzt nicht bei meinem Problem er zeigt mir ja bei dem
upgrade irgend welche Fehler an ...
 

bad_brain

Registered User
Naja, da hats wohl ein Paket nicht richtig installiert, dazu aber besser einen eigenen Thread aufmachen....hat ja mit dem Apache erstmal nix zu tun, soweit ist das System ja auch up to date.

Ok, zuerst einmal herausfinden was für eine MPM dein Apache denn benutzt:
Code:
apache2 -V
Die benötigte Info findest du dann unter:
Code:
Server MPM:     xxxxx

Falls Prefork:
Code:
apt-get install apache2-prefork-dev
Falls Worker:
Code:
apt-get install apache2-threaded-dev

Das sollte erst einmal dein Script Installations-Problem lösen.
 

Drugsii

New Member
unten zeigt er wieder ein error :confused:

Code:
Do you want to continue [Y/n]? y                                                
(Reading database ... 64746 files and directories currently installed.)         
Removing libdb4.2-dev ...                                                       
Selecting previously deselected package libdb4.6-dev.                           
(Reading database ... 64738 files and directories currently installed.)         
Unpacking libdb4.6-dev (from .../libdb4.6-dev_4.6.21-6ubuntu1_i386.deb) ...     
Selecting previously deselected package libaprutil1-dev.                        
Unpacking libaprutil1-dev (from .../libaprutil1-dev_1.2.12+dfsg-3ubuntu0.2_i386.
deb) ...                                                                        
Selecting previously deselected package apache2-prefork-dev.                    
Unpacking apache2-prefork-dev (from .../apache2-prefork-dev_2.2.8-1ubuntu0.15_i3
86.deb) ...                                                                     
Setting up at (3.1.10ubuntu4) ...                                               
 * Starting deferred execution scheduler atd                                    
[COLOR="Red"]invoke-rc.d: initscript atd, action "start" failed.  [/COLOR]                           
dpkg: error processing at (--configure):                                        
 subprocess post-installation script returned error exit status 1               
Setting up libdb4.6-dev (4.6.21-6ubuntu1) ...                                   
Setting up libaprutil1-dev (1.2.12+dfsg-3ubuntu0.2) ...                         
Setting up apache2-prefork-dev (2.2.8-1ubuntu0.15) ...                          
Errors were encountered while processing:                                       
 at                                                                             
[COLOR="Red"]E: Sub-process /usr/bin/dpkg returned an error code (1) [/COLOR]
 
Last edited by a moderator:

Drugsii

New Member
edit: moment mal was cleant der den eig. alles oder wie nicht das den alles weg iss....



mom ich probiere des mal
 
Last edited by a moderator:

michael-08

Blog Benutzer
wenn ihr schon einem komplett Ahnungslosen helfen wollt dann fangt doch mal mit der Ubuntu Version an

unter Debian waere das

Code:
cat /etc/debian_version

da ich kein Ubuntu nutze kann ich da nur raten.

als naechstes


Code:
cat /etc/apt/sources.list

wenn das passt ein


Code:
aptitude update && aptitude safe-upgrade

Ausserdem wuerde ich dir noch empfehlen entweder

aptitude

oder

apt-get

zu benutzen. Nicht beides. Zudem wuerde ich dir empfehlen nur aptitude zu benutzen und apt-get sein lassen.
 
Last edited by a moderator:

NeoFromBerlin

New Member
@ Michael-08:
Code:
Writing extended state information... Done
Setting up at (3.1.10ubuntu4) ...
 * Starting deferred execution scheduler atd
invoke-rc.d: initscript atd, action "start" failed.
dpkg: error processing at (--configure):
 subprocess post-installation script returned error exit status 1
Errors were encountered while processing:
 at
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install.  Trying to recover:
Setting up at (3.1.10ubuntu4) ...
 * Starting deferred execution scheduler atd
invoke-rc.d: initscript atd, action "start" failed.
dpkg: error processing at (--configure):
 subprocess post-installation script returned error exit status 1
Errors were encountered while processing:
 at
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Building tag database... Done
Bin der für die Technik ;)

Und zu dem apt-get autoremove, da passiert genau das gleiche (der dpkg Fehler).

Mit freundlichen Grüßen,
Neo
 

michael-08

Blog Benutzer
da hier generell kein Sie verwendet wird:

warum sprichst Du mich an? Ich habe keinerlei lösungsvorschläge gepostet.

Aber man sollte von vorn beginnen, nicht mittendrin. Also überprüfe erstmal deine sources.list bevor du updatest.
 
Last edited by a moderator:

NeoFromBerlin

New Member
cat /etc/debian_version
Code:
lenny/sid
cat /etc/apt/sources.list
Code:
deb http://archive.ubuntu.com/ubuntu hardy main restricted universe
deb http://archive.ubuntu.com/ubuntu hardy-updates main restricted universe
deb http://archive.ubuntu.com/ubuntu hardy-security main restricted universe
aptitude update && aptitude safe-upgrade
Code:
Hit http://archive.ubuntu.com hardy Release.gpg
Hit http://archive.ubuntu.com hardy-updates Release.gpg
Hit http://archive.ubuntu.com hardy-security Release.gpg
Hit http://archive.ubuntu.com hardy Release
Hit http://archive.ubuntu.com hardy-updates Release
Hit http://archive.ubuntu.com hardy-security Release
Hit http://archive.ubuntu.com hardy/main Packages
Hit http://archive.ubuntu.com hardy/restricted Packages
Hit http://archive.ubuntu.com hardy/universe Packages
Hit http://archive.ubuntu.com hardy-updates/main Packages
Hit http://archive.ubuntu.com hardy-updates/restricted Packages
Hit http://archive.ubuntu.com hardy-updates/universe Packages
Hit http://archive.ubuntu.com hardy-security/main Packages
Hit http://archive.ubuntu.com hardy-security/restricted Packages
Hit http://archive.ubuntu.com hardy-security/universe Packages
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Building tag database... Done
The following partially installed packages will be configured:
  at
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B of archives. After unpacking 0B will be used.
Setting up at (3.1.10ubuntu4) ...
/bin/sh: Illegal option -
dpkg: error processing at (--configure):
 subprocess post-installation script returned error exit status 2
Errors were encountered while processing:
 at
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install.  Trying to recover:
Setting up at (3.1.10ubuntu4) ...
/bin/sh: Illegal option -
dpkg: error processing at (--configure):
 subprocess post-installation script returned error exit status 2
Errors were encountered while processing:
 at
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Building tag database... Done

Habe jetzt mal alle Rückgabewerte hier aufgeschrieben. Hoffe das hilft dir mehr.
 
Top