Diskussion zur neuen Forensoftware

marce

Active Member
#22
"nur" so lange bis ich meine Bookmarks angepasst hatte.

Wenn's über 'ne hartnäckige Weiterleitung kommt - Browsercache leeren, ggf. Proxies prüfen.
 

Thorsten

SSF Facilitymanagement
Staff member
#23
Hallo!

Ich konnte dieses Problem reproduzieren. Passierte bei mir ausschließlich bei Google Chrome. Geholfen hat letztendlich das Löschen von Cache & Cookies. Eventuell nicht für jeden Praktikabel.

mfG
Thorsten
 

Thorsten

SSF Facilitymanagement
Staff member
#24
Hallo!
Die URLs unterscheiden sich ja nur geringfüg und die Zahlen dürften wohl fortlaufende Numerierungen sein. Kann man da nicht mit einem Script die Datenbank durcharbeiten und die Links automatisiert umschreiben? Genügend Profis für's Script coden sind ja hier sicher unterwegs;)
Es gibt für xF fertige Scripte, die diesen Job erledigen. Allerdings sind die Voraussetzungen dafür zu beachten. Ich werde hier noch einige Tests machen. Leider reicht die Zeit dafür Heute nicht aus.

mfG
Thorsten
 

nexus

Active Member
#26
Hier sieht man übrigens noch 1:1 das alte vBulletin:
Code:
 https://serversupportforum.de/forum/search.php?do=getdaily
Könnte darin begründet sein, daß Thorsten beim Umschreiben der internen Verlinkungen direkt auf die Threads in der alten Forensoftware zugreifen kann...
 
Last edited by a moderator:

DeaD_EyE

Blog Benutzer
#28
Ihr habt euch damit keinen Gefallen getan. Ich habe so eine doofe Umstellung der Forensoftware 3 mal mitgemacht und möchte das nie wieder selbst machen müssen. Wenn man denkt, man hätte alle Probleme gelöst, tauchen neue auf. Wenn ich zurück in Deutschland bin, werde ich mal meinen Browsercache leeren und nochmal prüfen. Das Design gefällt mir aber.

BTW: Internet in Singapur ist sowas von günstig. Traumhaft....
PS: Office365 geht nicht. Die müssen das jetzt in Office355 umbenennen xD
 
Last edited:

Thorsten

SSF Facilitymanagement
Staff member
#29
Na ja, eventuell kennst du nicht alle Hintergründe. Aber ich sage mal so: Das Forum ist ja schon etwas älter (2003?).

Vom Software Versionsverlauf phpBB, vBulletin 1,2,3 und jetzt xF. vBulletin ist mausetot und für die IMO sehr stabilen 3.x Versionen gibt es keinerlei Support mehr. Abgesehen davon hat vBulletin 3.x ein echtes Problem mit PHP 7.2 / PHP 7.3. Das alles in Kombination mit etlichen vBulletin Add Ons (vBSEO [ebenfalls tot] / Dragonbyte SEO) hat zum Ergebnis, dass die URL Struktur komplett über den Haufen geworfen wurde.

Ja, das ist insbesondere ein Google Problem! Keine Frage. Aber ich habe die Entscheidung getroffen, Inhalt vor Komfort und eine aktuelle Codebasis vor technischen Krücken.

Das mögen einige eventuell komplett anders sehen.

mfG
Thorsten
 

nexus

Active Member
#30
Aber ich habe die Entscheidung getroffen, Inhalt vor Komfort und eine aktuelle Codebasis vor technischen Krücken.

Das mögen einige eventuell komplett anders sehen.
Ich finde diese Entscheidung konsequent und richtig.
Man darf ja auch nicht außer acht lassen, daß es sich beim SSF nicht um irgendein unbedeutendes Wald- und Wiesenforum handelt. Vielmehr ist es das Aushängeschild der deutschen Adminszene und mit über 15 Jahren Bestand schon ein Urgestein.
Und gerade das SSF als IT-Forum sollte immer mit gutem Beispiel vorangehen und nicht auf toter Codebasis und Flickschusterei basieren. ;)
 

killerbees19

★ ①③ ④ⓑ ✛ ␀
#33
Weiß jemand, wieso sich alle IDs von Beiträgen und Themen durch den Wechsel geändert haben? Das macht eine automatische Weiterleitung von alten Links ja irgendwie unmöglich. Kann man die bei einer Migration von vB zu xF nicht beibehalten? Ich kenne das von anderen Forenumstellungen nur so, dass wenigstens dieses Detail unverändert bleibt.

Beispiel: t61481 (p390726) » t59226 (p388377)

Könnte darin begründet sein, daß Thorsten beim Umschreiben der internen Verlinkungen direkt auf die Threads in der alten Forensoftware zugreifen kann...
Ich war nur irritiert, weil man so als Besucher bei Nutzung des wichtigsten Bookmarks von der Umstellung nichts mitbekommt und glaubt, dass alles offline ist. Mittlerweile wird dort ein 404er ausgeliefert. Gut, der zwingt einen User wenigstens dazu, mal die Startseite händisch aufzurufen… :D
 

Thorsten

SSF Facilitymanagement
Staff member
#36
Hallo!
Weiß jemand, wieso sich alle IDs von Beiträgen und Themen durch den Wechsel geändert haben?
Diese Option wurde bei der Migration nicht gewählt. Bewusst und aus verschiedensten Gründen. U.a. weil hier im Laufe der Zeit verschiedene URL Schemata aktiv waren. Das gibt am Ende immer ein heilloses Durcheinander.

Ich bin allerdings aktuell noch dabei, mir die alte Konfiguration im Detail anzusehen. Denn es gibt nach der Migration zumindest eine Hilfstabelle von xF, mit der diese Weiterleitungen aktiviert werden können.

mfG
Thorsten
 

Thorsten

SSF Facilitymanagement
Staff member
#37
Hallo!
Vielleicht interessiert es den ein oder anderen - anderenfalls ignorieren.

Ich habe mir mittels Google Analytics (läuft mit annomize IP) mal zwei Filter zusammengebaut. Zum einen für interne Links, die zu einem HTTP 404 führen, zum anderen für externe Links. Hiermit kann ich die internen Links mit der neuen URL versehen (also im Beitrag editieren) und externe Links Mittels Redirect auf die korrekte URL umleiten.

Hier geht es nicht um Google Links (diese werden sauber mit einem 404 beantwortet); es geht um händische, externe Links, bei denen die Korrektur nicht so ohne Weiteres möglich ist.

Ich hoffe, ich habe das alles richtig verstanden und mir nicht ins Knie geschossen :oops:.

mfG
Thorsten
 

Attachments

Thorsten

SSF Facilitymanagement
Staff member
#39
Hallo!
Ich möchte ein paar offene Fragen beantworten:

Deutsche Menüs wird es vorerst nicht geben. Anders als bei vBulletin, gibt es vom Hersteller keine offiziellen Sprachpakete. Diese sind nach meinen Informationen alle Community driven. Das ist insbesondere unter dem Gesichtspunkt Upgrade xenforo aktuell ein No-Go.

Die Version 2.1 von Xenforo ist offiziell als Stable freigegeben worden. Bedeutet, dass ich diese Version einmal intensiv testen werde und bei Erfolg - im Sinne von "läuft ohne Komplikationen" hier aktivieren werde. Hier bin ich noch unschlüssig, ob ein weiterer Test- bzw. Staging-Server zum Einsatz kommt.

Die weiteren Punkte wie Optik, Zeitformat usw. sehe ich aktuell wie @nexus - nice to have, aber im Moment nicht kriegsentscheidend.

URLs: Die Geschichte mit den URLs funktioniert soweit ganz gut. Google reindiziert das Forum aktuell fleißig. Externe Links die aktuell "in's Leere" führen, passe ich manuell an (sofern ein Referrer mitgeliefert wird). Interne Links werden manuell editiert. Funktioniert in beiden Fällen nur, wenn ein betroffener Links auch angeklickt wird.

Summa summarum habe ich hier keine Meldungen zu größeren Katastrophen wahrgenommen. Sollten Probleme auftreten, bitte ich diese zu melden. Vielen Dank!

mfG
Thorsten
 
#40
Unter Xenforo 1 war es so das die Sprachpakete einfache XML Dateien mit den deutschen Phrasen waren. Das schlimmste das bei einem Upgrade passiert ist, ist das manche Phrasen nicht übersetzt waren. Ich vermute das wird unter XF2 ähnlich sein. Ein Upgrade sollte trotz Sprachpaket ohne Probleme jederzeit möglich sein.
 
Top