Plesk 9.5.2 sowie 9.5.3 Sicherheits Problem FTP

uhu

New Member
habt ihr nach der Server-Kompromittierung alles neu installiert oder nur den PROFTPD geupdatet?
Kann es nicht sein, dass Schadscripte o.ä. eingespielt wurden während der Komprimittierung?
 

siradlib

Blog Benutzer
Funktioniert das Microupdate denn jetzt auch für die Plesk-Version 9.5.1 ? Ich werde da nicht so ganz schlau draus.
Die FAQs von HE, die genau über Deiner Frage verlinkt sind, sagen: Es gibt kein Microupdate für 9.5.1! Daher mach bitte sofort ein Update auf Plesk 9.5.3.
 

PapaBaer

Registered User
Server-Haftung

habt ihr nach der Server-Kompromittierung alles neu installiert oder nur den PROFTPD geupdatet?
Kann es nicht sein, dass Schadscripte o.ä. eingespielt wurden während der Komprimittierung?
Stand jetzt schon mehrmals im Thread und auch bereits erklärt: ProFTPd updaten beseitigt nur das Einfallstor. Ist der Server bereits angegriffen, sind definitiv Schadscripte nachgeladen wurden. Also neu aufsetzen! Unbedingt!

Einzige Ausnahme, ihr habt ein Vollbackup, welches garantiert und zweifelsfrei sauber ist. Dann reicht zurück zum Stand vom Backup und Plesk-Updates einspielen.

Ganz wichtig: Verarscht euch nicht selbst! Ja, es ist natürlich jetzt einfacher nur ein wenig zu flicken. Oder nicht so genau hinzusehen. Wird schon passen ... Nein! Was ihr jetzt schlampt, kann euch einen Mega-Ärger einhandeln. Habt ihr auch nur eine Kleinigkeit übersehen und jemand baut Mist mit eurem Server, dann haftet ihr in vollem Umfang (!!!!) als Server-Betreiber. Also, wenn ihr auch nur den Verdacht habt, dass etwas nicht koscher ist, dann ist sofortiges Handeln angesagt.
 
Last edited by a moderator:

sTaN

Blog Benutzer
Meine md5sum des proFTP auf einem Debian mit Plesk 9.5.3 lautet:

Code:
1a04460a3316c479ef648cd33f672951  /usr/sbin/proftpd
Nach dem Update auf 9.5.3 und zusätzlichem Ausführen von:

Code:
/usr/local/psa/admin/sbin/autoinstaller --select-product-id plesk --select-release-current --reinstall-patch --install-component base
ergibt die Ausgabe:

Code:
proftpd -vv
- mod_delay/0.6: error opening DelayTable '/var/run/proftpd/proftpd.delay': No such file or directory
ProFTPD Version: 1.3.2e (maint)
  Scoreboard Version: 01040002
  Built: Tue Nov 9 12:17:23 NOVT 2010
Laut Plesk und der Prüfung der Datei /root/.autoinstaller/microupdates.xml scheint es aber zu passen und das Microupdate zu beinhalten. Habe hier nur gelesen, dass die Built Zeit vom 11.11 sein muss. Bei mir siehe oben nicht der Fall.

Code:
# cat /root/.autoinstaller/microupdates.xml
<?xml version="1.0" encoding="UTF-8" standalone="yes" ?>
<patches>
    <product id="plesk" version="9.5.3">
        <patch version="1" timestamp="" />
    </product>
</patches>
Gruß,
sTaN
 

flusenpower

Registered User
Hi.

Ich habe gerade versucht meinem System ein Update zu verpassen um die ProFTP Lücke zu schliessen.
Allerdings bricht der Autoinstaller immer wieder ab.

Egal ob ich per

Code:
/usr/local/psa/admin/sbin/autoinstaller --select-product-id plesk --select-release-current --reinstall-patch --install-component base
oder per

Code:
/usr/local/psa/admin/sbin/autoinstaller --select-release-current --upgrade-installed-component
versuche.

Ich bekomme immer folgende Fehlermeldung:

Code:
Installing the package psa-vpn-2.0.1-suse11.1.build95101022.03.x86_64
===> Checking kernel support for TUN/TAP
FATAL: Could not load /lib/modules/2.6.27.45-0.1-default/modules.dep: No such file or directory
The tun kernel module seems to be missing on your system.
Plesk VPN requires the tun module.
The installation cannot continue.
error: %pre(psa-vpn-2.0.1-suse11.1.build95101022.03.x86_64) scriptlet failed, exit status 1
error:   install: %pre scriptlet failed (2), skipping psa-vpn-2.0.1-suse11.1.build95101022.03
ERROR: An error occurred during installation of packages.
Mein System ist openSuse 11.1 mit Plesk 9.5.3

Jemand ne Idee?
 

Huschi

Moderator
Staff member
Ich tippe darauf, dass Du einen Vserver hast. ;)
Deinstalliere mit dem autoinstaller vorher das Paket psa-vpn.
Dann versucht er erst gar nicht, das Paket zu updaten.

huschi.
 

flusenpower

Registered User
Hallo Huschi.

Es ist kein Vserver, sondern ein ganz normaler bei Strato.

Die deinstallation per Autoinstaller von VPN hatte ich auch schon versucht. Das lässt sich das Paket nicht rausnehmen, da es mit dem Base Paket verknüpft ist.

Code:
Unable to exclude the component plesk/base:
it is required component.
Edit: Habs selbst gelöst. Der Trick lag im deaktivieren aller Pakete. Wer lesen kann... Vorteil und so.... Danke Huschi!
 
Last edited by a moderator:

ONDevil

Registered User
S4Y Debian 4 - Plesk 8.4 (ist jetzt Version 9.5.3)

Hier die Quick&Dirty Methode um ProFTPD zu aktualisieren (Ubuntu/Debian).
MOD: Full-Quote gekürzt!
Hallo,
ich hab ein dickes Problem mit der Quick&Dirty Methode bekommen..

als erstes bin ich bei ./configure hängen geblieben, da kein c-compiler installiert war.
Nach installieren von "apt-get install gcc" hat es dann geklappt und er hat gearbeitet..
Jedoch konnte ich kein "make" durchführen ..da es nicht vorhanden ist :confused:

root@serverxyz:/proftpd-1.3.3c# dir
acconfig.h config.log COPYING lib Makefile.in README README.DSO README.PAM src
aclocal.m4 config.status CREDITS libtool Make.rules README.AIX README.facl README.ports stamp-h
ChangeLog config.sub doc locale Make.rules.in README.capabilities README.FreeBSD README.Solaris2.5x stamp-h.in
config.guess configure include ltmain.sh modules README.classes README.IPv6 README.Unixware tests
config.h configure.in INSTALL m4 NEWS README.controls README.LDAP RELEASE_NOTES utils
config.h.in contrib install-sh Makefile proftpd.spec README.cygwin README.modules sample-configurations
root@my:/proftpd-1.3.3c#
Nun habe ich das Problem das immer noch proftpd v1.3.2e installiert ist und ich den proftpd nicht mal mehr stoppen kann da es unter /etc/init.d/ kein proftpd mehr gibt.

ein whereis proftpd sagt:
whereis proftpd
proftpd: /usr/sbin/proftpd /etc/proftpd.include /etc/proftpd.conf /usr/lib/proftpd /usr/include/proftpd /usr/share/man/man8/proftpd.8.gz
Was nun? - brauche wirklich Hilfe!
Bin noch in der Lernphase und kenne mich leider nicht so gut aus :(

Gruß Alex
 
Last edited by a moderator:

voodoo44

Registered User
protftp findet man imho unter /etc/xinet.d/ftp_psa
Da drinnen kann man's deaktivieren.

ansonsten füge noch ein aptitude install automake in deine Konsole ein - danach sollte auch make vorhanden sein.
 

JaEgErmEistEr

Registered User
Es reicht mittlerweile auch einfach ein Update von Plesk durchzuführen da es seit einigen Tagen bereits ein Microupdate für die Geschichte gibt dann brauchst du auch nicht zu frickeln!!
 

ONDevil

Registered User
protftp findet man imho unter /etc/xinet.d/ftp_psa
Da drinnen kann man's deaktivieren.
Dankeschön, das hat jetzt endlich geklappt :)
ansonsten füge noch ein aptitude install automake in deine Konsole ein - danach sollte auch make vorhanden sein.
trotzdem passiert bei dem Aufruf "make" nichts :confused:

Es reicht mittlerweile auch einfach ein Update von Plesk durchzuführen da es seit einigen Tagen bereits ein Microupdate für die Geschichte gibt dann brauchst du auch nicht zu frickeln!!
Hatte ich mir auch schon überlegt ..nur ein Supporter bei S4Y meinte ich soll da mal schön die finger davon lassen, sonst könnte ich das System gerade neu installieren.
 

voodoo44

Registered User
Und dennoch beinhaltet bei mir (unter Debian 5) automake gleichzeitig den Befehl "make".

Das einzige was ich imho immer installiere ist:
aptitude install gcc automake
Dann läuft "make" bei mir problemlos. Dass es was anderes ist, ist mir klar.
 

voodoo44

Registered User
Nun gut, ich habe bei meinem Serverprovider ein paar Einträge drin, die er selbst in die Source-Liste eingetragen hat.
 

Joe User

Zentrum der Macht
Auch dort wird mit 99,9999%er Wahrscheinlichkeit make nicht im automake-Paket enthalten sein. make steckt in http://packages.debian.org/lenny/make
Inwiefern diese Pakete voneinander abhängig sind, ist ein anderes Thema.

Eines zeigt diese kurze Subdiskussion aber sehr deutlich: Du hast Dich noch nie mit den Grundlagen Deiner Distribution beschäftigt, glaubst aber gleichzeitig Server administrieren zu können. Das passt nicht zusammen...

Du kannst mir gerne per PN antworten, in diesem Thread wäre Deine Antwort Off-Topic.
 

voodoo44

Registered User
Bevor du versuchst andere Leute dumm dastehen zu lassen:
Ich habe nicht geschrieben, dass das "automake"-Paket das Programm "make" mit installiert.

Und das hat komischerweise bisher immer funktioniert. Bevor du also irgendwelche Sachen vorwirfst und andere sinnlos denunzierst lies erstmal richtig.
 

Huschi

Moderator
Staff member
Und dennoch beinhaltet bei mir (unter Debian 5) automake gleichzeitig den Befehl "make".
Hier steht "beinhaltet" nicht "installiert mit".

Dennoch:
<Moderation>
Bitte die Paket-Diskussion auf anderer Ebene durchführen.
</Moderation>

Zum Thema:
@ONDevil:
Joe User said:
Definiere bitte "nichts", danke.
huschi.
 
Top