PHP 5.1.x RPMS fuer Suse 9.3 und MYSQL 4.1.x

D

dereine

Guest
Negative ich habe php5 am Laufen :) und bei beiden ist das Paket PHP?-Debug nicht Installiert.
 

society

Registered User
Du hast dieses Paket mit installiert: php5-debuginfo-5.1.6-1.i586.rpm
Das musst du wieder löschen bzw deinstallieren.

Sprich:

rpm -e php5-debuginfo-5.1.6-1
 

Uri

Registered User
Fast geschafft

dank der vielen Tips :) habe ich nun php 5.1.6 laufen. Danke nochmal.

Folgendes Problem noch
- beim installieren von php5-tidy-5.1.6-1.i586.rpm:
Failed dependencies:
libtidy-0.99.so.0 is needed by php5-tidy-5.1.6-1
ich habe das Paket erst mal wegelassen.
 

society

Registered User
@Uri: Du musst einfach libtidy über Yast installieren. Also Yast starten -> Software dingends -> Suche -> tidy eingeben -> Pakete auswählen -> freuen.

@dereine: Denke mal nach, dann mach nen "rpm -qa | grep debug" und poste die Ausgabe bitte hier!
 

society

Registered User
Hmmm andere Sache welche RPMs nutze nochmal die bei Suse dabei sind?
Glaube sogar das ich das gleiche Problem hatte..... wenn ich sogar überlege war das definitiv so.

Also am besten Upgraden mit meiner 5.1.6 Version! Dort läuft das PHP Modul definitiv nicht im Debug Modus. Sondern nur wenn das debug Paket mit installiert wird.
 
D

dereine

Guest
gibt es auch noch ein Yastinstall Paket ?
über Schell installieren ist es mir noch bissel gefährlich da ich nicht wes was ich nachem Befehl noch machen müsste.
 

society

Registered User
Also dereine: Für dich nochmal ausführlicher (mehr geht nun echt nicht mehr, und wiederholen tue ich mich auch nicht mehr)

Am besten so wenn du wirklich Suse 9.3 hast (als root):

MySQL 4.1.20

Code:
cd /root
mkdir mysql4update
cd mysql4update

#Alles Downloaden
wget -r -np -nH -l1 http://rpms.serversupportforum.de/suse93/mysql-4.1.20/

#Div Pakete Löschen
rm mysql-4.1.20-1.src.rpm
#Installieren bzw. Updaten
rpm -Uvh *.rpm
PHP 5.1.6:

Code:
cd /root
mkdir php5update
cd php5update

#Alles Downloaden
wget -r -np -nH -l1 http://rpms.serversupportforum.de/suse93/php-5.1.6/

#Div Pakete Löschen
rm php5-debuginfo-5.1.6-1.i586.rpm 
rm php5-5.1.6-1.src.rpm

# Nur Ausfuehren wenn bereits PHP 5.0.3 Original von Suse installiert ist
#  rpm -e php5-dbx-5.0.3-14 php5-dio-5.0.3-14 php5-readline-5.0.3-14 php5-yp-5.0.3-14 php5-fam-5.0.3-14

#Installieren bzw. Updaten
rpm -Uvh *.rpm
Libtidy

Code:
cd /root
mkdir tidy
cd tidy

#Alles Downloaden
wget -r -np -nH -l1 http://rpms.serversupportforum.de/suse93/libtidy/

#Installieren bzw. Updaten
rpm -Uvh *.rpm
Restarten:

Code:
/etc/init.d/mysql restart
/etc/init.d/apache2 restart

Kleiner Tipp:
Ev. zeigt er dir beim rpm -Uvh fehlende Pakete an. Diese musst du via Yast suchen und installieren
z.B. libtidy-haumichblau0123 suchste via tidy und installierst es
 
Last edited by a moderator:
D

dereine

Guest
Vielen Dank fürs kleine Howto :)

Jetze habe ich folgendes Problem:

error: Failed dependencies:
libtidy-0.99.so.0 is needed by php5-tidy-5.1.6-1
php5 = 5.0.3 is needed by (installed) php5-dbx-5.0.3-14
php5 = 5.0.3 is needed by (installed) php5-dio-5.0.3-14
php5 = 5.0.3 is needed by (installed) php5-readline-5.0.3-14
php5 = 5.0.3 is needed by (installed) php5-yp-5.0.3-14
php5 = 5.0.3 is needed by (installed) php5-fam-5.0.3-14

ich habe über Yast tidy Installiert, jedoch lässt sich dort über die Suche kein libtidy finden.
Mysql Update lief Fehlerfrei durch.
 

society

Registered User
Mach mal ein:

rpm -e php5-dbx-5.0.3-14 php5-dio-5.0.3-14 php5-readline-5.0.3-14 php5-yp-5.0.3-14 php5-fam-5.0.3-14

Und bitte danach noch die Installation von Tidy (siehe oben)

 
D

dereine

Guest
Bevor noch meine Ohren abfallen :D
wie gewünscht (im chat) die Ausgabe der Installation:

Preparing... ########################################### [100%]
file /usr/share/man/man1/php-config.1.gz from install of php5-5.1.6-1 conflicts with file from package php4-4.4.2-1
file /usr/share/man/man1/phpize.1.gz from install of php5-5.1.6-1 conflicts with file from package php4-4.4.2-1
Meldung beim Entfernen von PHP4:

php4 = 4.3.10 is needed by (installed) php4-shmop-4.3.10-14.1.swsoft
php4 = 4.3.10 is needed by (installed) php4-snmp-4.3.10-14.1.swsoft
.......
 
Last edited by a moderator:
D

dereine

Guest
So es GEHT, nachdem society die Nerven bei mir verloren hat lüpft es jetze einwandfrei :)
 

stophl

Blog Benutzer
1blu Suse 9.3 Update...

Hallo,

habe einen 1blu VServer mit Suse 9.3, php4.3.10, plesk 7.5.4 installiert bekommen. Natürlich ist das System jetzt nicht mehr das aktuellste und ich würde gerne ein Update vornehmen und jetzt meine Frage:
Von 1blu Service habe ich gesagt bekommen, dass ich Plesk 8 installieren kann und sie mir auch einen Schlüssel anschließend geben, aber das Update funktioniert nicht. Es bricht ständig mit einer Error-Meldung ab.

Download file versions.inf3: 47%..100% done
Download file PSA_8.0.0/plesk-8.0.0-suse9.3-x86_64.inf3: 100% done
Checking for system installed packages...done.
Check for components installation status
Reading system installed packages...done.
Download file plesk-8.0.0-suse9.3-x86_64.hdr.gz: 14%..69%..100% done
Download file plesk-8.0.0-suse9.3-x86_64.hdr.gz: 17%..27%..60%..100% done
Resolve components
ERROR: Impossible do installation while package php4-snmp-4.3.10-14.1.swsoft.i586 is installed in system

Was kann ich da jetzt machen. Ich habe mir hier schon alles durchgelesen und auch schon sehr viel ausprobiert, aber ich kann Plesk nicht auf 8 updaten und php5 bekomme ich auch nicht zum Laufen. Außerdem fehlt mir in meinem Yast die Versionsnummer und der Name des Betriebssystems (Suse 9.3). Somit kann ich Yast gar nicht verwenden. Habe nur apt zur Verfügung.

Bitte um Hilfe, danke!

Gruß Stophl
 

society

Registered User
Ist zwar nen Falschen Thread für dieses Problem aber mach mal ein:
rpm -e php4-snmp-4.3.10-14.1.swsoft.i586

Danach erstelle bitte für das Problem einen neuen Thread was nicht mit meinen Pakete zu tun hat.
 

Viruz

Registered User
geht das mitlerweile schon mit confixx premium edition?

und ich habe es versucht allerdings taucht bei mir ein problem auf!

wie ich sehe hast du viel ahnung davon könntest du auf den thread ein auge werfen?


schon mal vielen dank!

MfG
Viruz
 

Uri

Registered User
Suse 9.3 mit PHP 5.1.6, eAccelerator, Zend Optimizer

Hallo,

ich habe jetzt meinen Server mit Suse 9.3 mit PHP 5.1.6, eAccelerator, Zend Optimizer :) am laufen. Besteht Bedarf für ein Howto für das Installieren von eAccelerator und Zend Optimizer.

@society: Wenn ja ist das hier OK oder besser im Howto Forum
 

Freel@ncer14

Registered User
Hallo Uri,

selbstverständlich werden HowTos IMMER gerne gesehn bei uns, denn schaden können sie ja nicht ;D

Wenn du dir die Mühe machen möchtest: sehr gerne!

Ich denke du solltest dann besser den HowTo Bereich nehmen, damit es übersichtlicher bleibt!

Vielen Dank für deine Mühe schonmal im Vorraus

Lieben Gruß
Free
 
Top