Domain auf Confixx

fanfarian

Registered User
Huschihusch said:
Webmin kannst Du auch unter xinetd fahren lassen. (google: "webmin xinetd" auf Deutsch) Dann frist es nicht dauerhaft Resourcen.
Was macht das xinetd genau.
Reicht es wenn ich einfach das rpm Paket installiere?
Brauche ich das normale webmin + das webmin-xinetd ?
unter http://www.usermin.de/faq.php bei Punkt 21 gibt es eine anleitung für webmin unter xinetd.
 

Huschi

Moderator
Staff member
fanfarian said:
Was macht das xinetd genau.
inetd ist ein ein Port-Wrapper. (xinetd nur eine extended Version.)
Es ist ein Daemon der ständig läuft, und laut seiner Konfiguration bei bestimmten Ports definierte Programme startet.
Typische Beispiele die über inetd laufen sind z.B. telnet, ftp und pop3.
Manchmal sieht man auch die Verbindung eines tcpwrappers. Dieser bietet noch eine Art Zugriffsschutz, da er die /etc/hosts.(allow|deny) Dateien ab arbeitet.

Vorteil:
es läuft nur ein Daemon für viele Dienste durchgängig => mehr freier Speicher, mehr Prozessorleistung

Nachteil:
Die Dienste müssen sich bei jeden Connect neu initialisieren => Laufzeitverzögerung.
Gerade bei Webmin, der mit relativ vielen Requests arbeiten muß (wenn man denn mal mit ihm arbeitet) spürt man das eventuell.

huschi the husch
 

fanfarian

Registered User
Das File im /var/log/httpd/confixx/stdlog_access gibt es nicht.
Da hab ich nur 2 ordner: domains und kunden und die sind bis auf kopien der dateien /var/log/httpd error_log, access_log für die einzelnen Domains leer.

In den Confixx Meldungen findet sich auch nix, die sind leer.
 

fanfarian

Registered User
Anonymous said:
Oh oh :shock:
Wenn das access bzw. error log keinerlei Erklärung gibt - gibt's da nur noch eines. Einmal frisch installieren. Am besten ohne Confixx.
Wie installiere ich ohne Confixx ?
oder muss ich des nur deaktivieren, so wie es in der tollen vServer FAQ steht?
 

luke

Registered User
Hallo,

ich hatte ein ähnliches Problem, allerdings auf einem "echten" Server4Free Server. Der Kundensupport konnte mir (wie so oft) nciht wirklich weiterhelfen, also habe ich mich weiter auf die Suche nach dem Fehler gemacht. Wie gesagt, ich habe keinen vServer, gehe aber davon aus, dass sich dieser ähnlich verhält.

Die Fehlerseite die bei meiner Domain erschien sah ca. so aus: http://web11.wt-web.com/fehler.html Ich erhalte diesen Fehler wenn ich http://domain.tld aufrufe, jedoch nicht wenn ich selbige mit www. aufrufe. In einem anderen Forum bekam ich die Frage ob ich die Domain in Confixx mit "www.domain.tld" oder mit "domain.tld"konfiguriert habe (es war domain.tld), allerdings habe ich diese verschiedenen Einstellungen (noch) nicht ausprobiert. Vielmehr habe ich manuell die Dateien /etc/httpd/httpd.conf und /etc/httpd/confixx_vhost.conf angesehen und bearbeitet. Die confixx_vhost.conf wird von httpd.conf bei den VirtualHosts per include eingefügt, ändert man manuell etwas an dieser Datei (bei der enstprechend fehlerhaften Domain) funktioniert es kurz, allerdings überschreibt Confixx diese Einstellung wieder. Also habe ich den Eintrag direkt in die httpd.conf geschrieben und dort funktioniert alles so wie es soll. Hier ein Beispiel eines VirtualHosts:

[code:1]
<VirtualHost DEINEIP:80>
ServerName DEINEDOMAIN.TLD
ServerAlias www.DEINEDOMAIN:TLD
DocumentRoot /srv/www/htdocs/web1/html
User web1
Group ftponly
php_admin_value open_basedir /srv/www/htdocs/web1/
php_admin_value upload_tmp_dir /srv/www/htdocs/wb1/phptmp/
ScriptAlias /cgi-bin/ /srv/www/htdocs/web1/html/cgi-bin/
</VirtualHost>
[/code:1]

Einziges Problem: Der Eintrag steht praktisch doppelt in der httpd.conf. Einmal in der Datei selbst und einmal per include aus der confixx_vhost.conf. Allerdings hatte ich mit dieser Einstellung noch keine Probleme und alles funktioniert tadellos.


So far!
#
Luke
 
Top