Domain auf Confixx

fanfarian

Registered User
Nach eineigen Seitenaufrufen oder FTP-Traffic
sehe ich statt meiner Domain nur die Confixxoberfläche, die eigentlich nur unter der IP zu sehen sein sollte.

Was kann da schief laufen?
 

Huschi

Moderator
Staff member
kurze Antwort:
confixx

lange Antwort:
Du hast wirklich Deine Domain im Browser getippt und nicht xxxxxx.vserver.de?
Schau mal unter /etc/httpd/conf/ die Dateien httpd.conf und confixx_vhost.conf an.
Insbesondere die Abschnitte rund um die VirtualHost.
Irgendwas auffälliges in dem Abschnitt mit Deiner Domain?
Versuch alle Error-Logfiles einzusehen (normalerweise utner /var/log/httpd/). Gerade error_log sobald Du mal /etc/init.d/apache restart ausgeführt hast.

huschi the husch
 

fanfarian

Registered User
Huschihusch said:
kurze Antwort:
confixx
Klingt plausibel :D
Huschihusch said:
lange Antwort:
Du hast wirklich Deine Domain im Browser getippt und nicht xxxxxx.vserver.de?
ja hab ich
Huschihusch said:
Schau mal unter /etc/httpd/conf/ die Dateien httpd.conf und confixx_vhost.conf an.
was soll da genau sein?
in der httpd.conf steht genau 1VirtualServer + das include zum confixx_vhost.conf

und in der stehen ein paar komische virtualServer:
NameVirtualHost 62.75....:80
php_admin_flag safe_mode On
php_admin_value safe_mode_exec_dir /var/www/empty

UseCanonicalName Off
LogFormat "%V:#:%h %l %u %t \"%r\" %s %b \"%{Referer}i\" \"%{User-agent}i\"" confixx
LogFormat "%h %l %u %t \"%r\" %s %b \"%{Referer}i\" \"%{User-agent}i\"" confixx2
CustomLog |/root/confixx/pipelog.pl confixx
<Directory "/var/www">
<Files ~ "^\.ht">
deny from all
</Files>
AllowOverride None
AllowOverride Indexes AuthConfig Limit FileInfo
Options None
Options -FollowSymLinks -SymLinksIfOwnerMatch +Includes
</Directory>

<Directory "/var/www/web1/html">
DirectoryIndex index.html index.htm index.php index.php3 index.php4 index.shtml index.shtm index.sht
<Files ~ "\.(wml.*|wbmp)$">
deny from all
</Files>
</Directory>
<Directory "/var/www/web2/html">
DirectoryIndex index.html index.htm index.php index.php3 index.php4 index.shtml index.shtm index.sht
<Files ~ "\.(wml.*|wbmp)$">
deny from all
</Files>
</Directory>

<VirtualHost 62.75....:80>
DocumentRoot /var/www/confixx/html/gesperrt
</VirtualHost>
<VirtualHost 62.75.....:80>
ServerName minis.stefan-reichert.com
ServerAlias www.minis.stefan-reichert.com web2.159154.vserver.de
DocumentRoot /var/www/web2/html
User web2
Group ftponly
ScriptAlias /cgi-bin/ /var/www/web2/html/cgi-bin/
php_admin_value open_basedir /var/www/web2/
php_admin_value upload_tmp_dir /var/www/web2/phptmp/
</VirtualHost>
<VirtualHost 62.75....:80>
ServerName stefan-reichert.de
ServerAlias www.stefan-reichert.de web1.159154.vserver.de stefan-reichert.com www.stefan-reichert.com
DocumentRoot /var/www/web1/html
User web1
Group ftponly
ScriptAlias /cgi-bin/ /var/www/web1/html/cgi-bin/
php_admin_value open_basedir /var/www/web1/
php_admin_value upload_tmp_dir /var/www/web1/phptmp/
</VirtualHost>

Huschihusch said:
Insbesondere die Abschnitte rund um die VirtualHost.
Irgendwas auffälliges in dem Abschnitt mit Deiner Domain?

Versuch alle Error-Logfiles einzusehen (normalerweise utner /var/log/httpd/). Gerade error_log sobald Du mal /etc/init.d/apache restart ausgeführt hast.
da steht : [warn] NameVirtualHost 62.75....:80 has no VirtualHosts
 

Huschi

Moderator
Staff member
Scheint sich wohl erledigt zu haben.
Deine Website ist ja im vollen Umfang erreichbar.

Vieleicht fehlte dem Apache einfach mal ein Neustart...

(Auf Confixx ist eben nicht immer verlass...)

huschi the husch
 

Thorsten

SSF Facilitymanagement
Staff member
Also ich bekomme beim Aufruf seiner URL auch nur den Confixx Login.
Was passiert wenn du das Confixx include deaktivierst?

mfG
Thorsten
 

Huschi

Moderator
Staff member
Das ist ja echt witzig:
Jetzt erhalte ich auch Confixx.

Da würden mich jetzt ein Auszug aus /var/log/httpd/access_log interessieren.
Dort müsste evtl. stehen, wann der Wechsel geschehen ist, da ich ein paar Seitenaufrufe über die korrekte Domain hatte.

Interessant ist, daß web1.159154.vserver.de jetzt sogar eine ganz andere Seite anzeigt.

huschi the husch
 
G

Guest

Guest
Oh oh :shock:
Wenn das access bzw. error log keinerlei Erklärung gibt - gibt's da nur noch eines. Einmal frisch installieren. Am besten ohne Confixx.
 

Huschi

Moderator
Staff member
@fanfarian
Hab mich jetzt wieder reingeklickt:
Es funktioniert wieder alles auf Deinem Server.

Was treibst Du nur mein Deinem vServer... ? :)

huschi the husch
 

Thorsten

SSF Facilitymanagement
Staff member
Du solltest unter dem Menüpunkt dsa die E-Mail Adressen lieber entfernen. Da laufen einige bots über die IPs von Server4Free die Adressen sammeln.
 

fanfarian

Registered User
hey ich mach gar nix damit
nicht mal nen reboot
die access_log und error_log schiebe ich noch nach.
ich kann mich dann nämlich auch nicht mehr per ssh einloggen und habe grad ne mail an den Support geschickt mit der Uhrzeit des Crashs
Zeit war 18:05
 

fanfarian

Registered User
und jetzt gehts wieder
Zeit 18:49

Ich krieg hier gleich die Krise

Schnell noch den ssh zugang gecheckt: der geht auch

hat das was damit zu tun, dass ich keine Firewall hab
und irgendjemand überlastet meinen vServer
 

Huschi

Moderator
Staff member
fanfarian said:
hat das was damit zu tun, dass ich keine Firewall hab
und irgendjemand überlastet meinen vServer
Keine Firewall kann kein Grund für fehlverhalten sein. :D
Die vServer sind immer 'überlastet'. Aber das ist eigendlich auch egal.
Das schlimste ist eigendlich nur der wenige RAM.
Aber daran sollte es bei Dir nicht hängen...

(außer Du hast Apache mit 100 und mysql mit 10 Instanzen gestartet...)

huschi the husch
 

fanfarian

Registered User
Der Apache ist mit 2 instanzen gestartet und Mysql mit 5
Kann es ein dass Confixx einiges an Ressourcen verbraucht?
Webmin läuft auch schon nicht mehr, da es da auch schon Performance Probleme gab.
Ich Check jetzt nochmal die Logfiles vom Apache und schreib die relevanten sachen hier rein.
 

fanfarian

Registered User
Also hier noch die error_log

[Wed Oct 1 10:55:28 2003] [warn] NameVirtualHost 62.75.159.154:80 has no VirtualHosts
[Wed Oct 1 10:55:29 2003] [notice] Apache/1.3.23 (Unix) (Red-Hat/Linux) configured -- resuming normal operations
[Wed Oct 1 10:55:29 2003] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Wed Oct 1 10:55:29 2003] [notice] Accept mutex: sysvsem (Default: sysvsem)
[Wed Oct 1 11:25:06 2003] [error] [client 80.132.113.69] File does not exist: /var/www/web1/html/stefan.css
[Wed Oct 1 11:25:37 2003] [error] [client 80.132.113.69] File does not exist: /var/www/web1/html/inhalte/\\www.kontent.de
[Wed Oct 1 11:28:35 2003] [error] [client 80.132.113.69] File does not exist: /var/www/web1/html/stefan.css
[Wed Oct 1 13:10:49 2003] [error] [client 80.131.253.174] File does not exist: /var/www/web2/html/forum/index.php
[Wed Oct 1 13:14:42 2003] [error] [client 80.131.224.22] File does not exist: /var/www/web2/html/forum/index.php
[Wed Oct 1 13:28:14 2003] [error] [client 80.139.66.125] File does not exist: /var/www/web2/html/forum/index.php
[Wed Oct 1 13:28:31 2003] [error] [client 80.139.66.125] File does not exist: /var/www/web2/html/forum/index.php
[Wed Oct 1 15:46:27 2003] [error] [client 80.136.47.102] File does not exist: /var/www/web1/html/stefan.css
[Wed Oct 1 15:46:51 2003] [error] [client 80.136.47.102] File does not exist: /var/www/web1/html/stefan.css
[Wed Oct 1 16:45:05 2003] [notice] caught SIGTERM, shutting down
[Wed Oct 1 16:45:40 2003] [warn] NameVirtualHost 62.75.159.154:80 has no VirtualHosts
[Wed Oct 1 16:45:40 2003] [notice] Apache/1.3.23 (Unix) (Red-Hat/Linux) configured -- resuming normal operations
[Wed Oct 1 16:45:40 2003] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Wed Oct 1 16:45:40 2003] [notice] Accept mutex: sysvsem (Default: sysvsem)
[Wed Oct 1 20:45:41 2003] [error] [client 80.129.120.120] File does not exist: /var/www/web2/html/forum/index.php
[Wed Oct 1 20:46:20 2003] [error] [client 80.129.120.120] File does not exist: /var/www/web2/html/alt/subsites/aktionen/css/Styles.css
[Wed Oct 1 20:46:42 2003] [error] [client 80.129.120.120] File does not exist: /var/www/web2/html/blue/subsites/einteilung/sommer.pdf
[Wed Oct 1 21:11:20 2003] [error] [client 62.104.221.64] File does not exist: /var/www/web2/html/blue/subsites/leiter/img/benni.jpg
[Wed Oct 1 21:23:17 2003] [error] [client 80.132.113.69] File does not exist: /var/www/web1/html/stefan.css
[Wed Oct 1 21:23:29 2003] [error] [client 80.132.113.69] File does not exist: /var/www/web2/html/user/allgemein_start.php
[Wed Oct 1 21:23:41 2003] [error] [client 80.132.113.69] File does not exist: /var/www/web1/html/stefan.css
[Wed Oct 1 21:34:45 2003] [error] [client 217.85.15.37] File does not exist: /var/www/web1/html/stefan.css
[Wed Oct 1 21:35:58 2003] [error] [client 217.85.15.37] File does not exist: /var/www/web1/html/stefan.css
[Wed Oct 1 21:36:04 2003] [error] [client 217.85.15.37] File does not exist: /var/www/web1/html/stefan.css
[Wed Oct 1 23:56:52 2003] [error] [client 80.132.113.69] File does not exist: /var/www/web1/html/user/allgemein_start.php
[Wed Oct 1 23:56:58 2003] [error] [client 80.132.113.69] File does not exist: /var/www/web1/html/stefan.css
[Wed Oct 1 23:57:01 2003] [error] [client 80.132.113.69] File does not exist: /var/www/web1/html/stefan.css
[Wed Oct 1 23:57:05 2003] [error] [client 80.132.113.69] File does not exist: /var/www/web1/html/stefan.css
[Thu Oct 2 10:27:19 2003] [error] [client 80.132.124.116] File does not exist: /var/www/web1/html/stefan.css
[Thu Oct 2 12:29:42 2003] [error] [client 80.131.252.41] File does not exist: /var/www/web2/html/forum/index.php
[Thu Oct 2 12:46:39 2003] [error] [client 80.132.124.116] File does not exist: /var/www/web1/html/stefan.css
[Thu Oct 2 15:41:14 2003] [error] [client 195.93.72.11] File does not exist: /var/www/web2/html/blue/subsites/gaestebuch/gaestebuch/admin/index.html
[Thu Oct 2 17:24:17 2003] [error] [client 62.157.44.13] File does not exist: /var/www/web2/html/forum/index.php
[Thu Oct 2 18:02:32 2003] [error] [client 80.139.92.117] File does not exist: /var/www/web1/html/stefan.css
[Thu Oct 2 18:02:38 2003] [error] [client 80.139.92.117] File does not exist: /var/www/web1/html/stefan.css
[Thu Oct 2 18:48:50 2003] [error] [client 80.139.127.33] File does not exist: /var/www/web1/html/stefan.css
[Thu Oct 2 18:54:10 2003] [error] [client 80.139.127.33] File does not exist: /var/www/web1/html/stefan.css
[Thu Oct 2 18:54:14 2003] [error] [client 80.139.127.33] File does not exist: /var/www/web1/html/stefan.css
[Thu Oct 2 18:54:27 2003] [error] [client 80.139.127.33] Directory index forbidden by rule: /var/www/web2/html/forum/
 

Huschi

Moderator
Staff member
fanfarian said:
Der Apache ist mit 2 instanzen gestartet und Mysql mit 5
MySQL könnte man auf 3 runterfahren, muß man aber nicht. Die brauchen erst dann Speicher, wenn ein Connect ausgeführt wird.

Kann es ein dass Confixx einiges an Ressourcen verbraucht?
Jaein! Confixx (genauer confixx_update.pl) läuft ja nur alle paar Minuten. Bei mir sogar nur jede Stunde, da ich eh kaum Änderungen mache. Confixx ist mit Perl2Exe compiliert und braucht daher von Hause aus mehr Speicher.
(Perl2Exe-Eigenschaft: alle benutzten Perl-Module werden jeweils mit Compiliert und alles dann in eine ausführbare Datei gepackt. Entspricht also einer statischen Library-Bindung und verbraucht daher viel Speicher zur Laufzeit.)

Webmin läuft auch schon nicht mehr, da es da auch schon Performance Probleme gab.
Webmin kannst Du auch unter xinetd fahren lassen. (google: "webmin xinetd" auf Deutsch) Dann frist es nicht dauerhaft Resourcen.

huschi the husch
 

fanfarian

Registered User
Auszug aus der MySQL log-datei:

031004 12:35:20 mysqld started
Cannot initialize InnoDB as 'innodb_data_file_path' is not set.
If you do not want to use transactional InnoDB tables, add a line
skip-innodb
to the [mysqld] section of init parameters in your my.cnf
or my.ini. If you want to use InnoDB tables, add to the [mysqld]
section, for example,
innodb_data_file_path = ibdata1:10M:autoextend
But to get good performance you should adjust for your hardware
the InnoDB startup options listed in section 2 at
http://www.innodb.com/ibman.html
/usr/libexec/mysqld: ready for connections

Soll ich die Anweisung in der Fehlermeldung ausführen oder ist das zu ignorieren?
 

fanfarian

Registered User
und hier die Access_log:

80.132.113.69 - - [01/Oct/2003:11:24:53 +0200] "GET / HTTP/1.1" 200 1318 "http://forum.neckel.com/viewtopic.php?p=186" "Mozilla/5.0 (Windows; U; Windows NT 5.0; de-AT; rv:1.4) Gecko/20030624"
80.132.113.69 - - [01/Oct/2003:11:24:54 +0200] "GET /banner_oben.jpg HTTP/1.1" 200 41408 "http://www.minis.stefan-reichert.com/" "Mozilla/5.0 (Windows; U; Windows NT 5.0; de-AT; rv:1.4) Gecko/20030624"
80.132.113.69 - - [01/Oct/2003:11:24:55 +0200] "GET /Turnier.jpg HTTP/1.1" 200 123520 "http://www.minis.stefan-reichert.com/" "Mozilla/5.0 (Windows; U; Windows NT 5.0; de-AT; rv:1.4) Gecko/20030624"
80.132.113.69 - - [01/Oct/2003:11:25:05 +0200] "GET / HTTP/1.1" 200 573 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.0; de-AT; rv:1.4) Gecko/20030624"
80.132.113.69 - - [01/Oct/2003:11:25:06 +0200] "GET /top.php HTTP/1.1" 200 251 "http://www.stefan-reichert.com/" "Mozilla/5.0 (Windows; U; Windows NT 5.0; de-AT; rv:1.4) Gecko/20030624"
80.132.113.69 - - [01/Oct/2003:11:25:06 +0200] "GET /navi.php HTTP/1.1" 200 1219 "http://www.stefan-reichert.com/" "Mozilla/5.0 (Windows; U; Windows NT 5.0; de-AT; rv:1.4) Gecko/20030624"
80.132.113.69 - - [01/Oct/2003:11:25:06 +0200] "GET /main.php HTTP/1.1" 200 196 "http://www.stefan-reichert.com/" "Mozilla/5.0 (Windows; U; Windows NT 5.0; de-AT; rv:1.4) Gecko/20030624"
80.132.113.69 - - [01/Oct/2003:11:25:06 +0200] "GET /css/stefan.css HTTP/1.1" 200 2157 "http://www.stefan-reichert.com/top.php" "Mozilla/5.0 (Windows; U; Windows NT 5.0; de-AT; rv:1.4) Gecko/20030624"
80.132.113.69 - - [01/Oct/2003:11:25:06 +0200] "GET /stefan.css HTTP/1.1" 404 296 "http://www.stefan-reichert.com/main.php" "Mozilla/5.0 (Windows; U; Windows NT 5.0; de-AT; rv:1.4) Gecko/20030624"
80.132.113.69 - - [01/Oct/2003:11:25:11 +0200] "GET /inhalte/impressum.html HTTP/1.1" 200 1350 "http://www.stefan-reichert.com/navi.php" "Mozilla/5.0 (Windows; U; Windows NT 5.0; de-AT; rv:1.4) Gecko/20030624"
80.132.113.69 - - [01/Oct/2003:11:25:37 +0200] "GET /inhalte/%5C%5Cwww.kontent.de HTTP/1.1" 404 310 "http://www.stefan-reichert.com/inhalte/impressum.html" "Mozilla/5.0 (Windows; U; Windows NT 5.0; de-AT; rv:1.4) Gecko/20030624"
80.132.113.69 - - [01/Oct/2003:11:28:34 +0200] "GET / HTTP/1.1" 200 573 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.0; de-AT; rv:1.4) Gecko/20030624"
80.132.113.69 - - [01/Oct/2003:11:28:35 +0200] "GET /top.php HTTP/1.1" 200 251 "http://www.stefan-reichert.de/" "Mozilla/5.0 (Windows; U; Windows NT 5.0; de-AT; rv:1.4) Gecko/20030624"
80.132.113.69 - - [01/Oct/2003:11:28:35 +0200] "GET /main.php HTTP/1.1" 200 196 "http://www.stefan-reichert.de/" "Mozilla/5.0 (Windows; U; Windows NT 5.0; de-AT; rv:1.4) Gecko/20030624"
80.132.113.69 - - [01/Oct/2003:11:28:35 +0200] "GET /navi.php HTTP/1.1" 200 1219 "http://www.stefan-reichert.de/" "Mozilla/5.0 (Windows; U; Windows NT 5.0; de-AT; rv:1.4) Gecko/20030624"
80.132.113.69 - - [01/Oct/2003:11:28:35 +0200] "GET /css/stefan.css HTTP/1.1" 200 2157 "http://www.stefan-reichert.de/top.php" "Mozilla/5.0 (Windows; U; Windows NT 5.0; de-AT; rv:1.4) Gecko/20030624"
80.132.113.69 - - [01/Oct/2003:11:28:35 +0200] "GET /stefan.css HTTP/1.1" 404 295 "http://www.stefan-reichert.de/main.php" "Mozilla/5.0 (Windows; U; Windows NT 5.0; de-AT; rv:1.4) Gecko/20030624"
80.132.113.69 - - [01/Oct/2003:11:28:37 +0200] "GET /inhalte/guestbook/index.php HTTP/1.1" 200 570 "http://www.stefan-reichert.de/navi.php" "Mozilla/5.0 (Windows; U; Windows NT 5.0; de-AT; rv:1.4) Gecko/20030624"
80.131.253.174 - - [01/Oct/2003:13:10:49 +0200] "GET /forum/index.php HTTP/1.1" 404 303 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4a) Gecko/20030331"
80.131.224.22 - - [01/Oct/2003:13:13:54 +0200] "GET /index.html HTTP/1.1" 200 1318 "http://www.minis-denzlingen.de.vu/" "Mozilla/4.0 (compatible; MSIE 6.0; Windows 98; Win 9x 4.90)"
80.131.224.22 - - [01/Oct/2003:13:13:55 +0200] "GET /banner_oben.jpg HTTP/1.1" 200 41408 "http://minis.stefan-reichert.com/index.html" "Mozilla/4.0 (compatible; MSIE 6.0; Windows 98; Win 9x 4.90)"
80.131.224.22 - - [01/Oct/2003:13:13:55 +0200] "GET /Turnier.jpg HTTP/1.1" 200 123520 "http://minis.stefan-reichert.com/index.html" "Mozilla/4.0 (compatible; MSIE 6.0; Windows 98; Win 9x 4.90)"
80.131.224.22 - - [01/Oct/2003:13:13:57 +0200] "GET /blue/index.html HTTP/1.1" 200 968 "http://minis.stefan-reichert.com/index.html" "Mozilla/4.0 (compatible; MSIE 6.0; Windows 98; Win 9x 4.90)"
80.131.224.22 - - [01/Oct/2003:13:13:57 +0200] "GET /blue/top.html HTTP/1.1" 200 634 "http://minis.stefan-reichert.com/blue/index.html" "Mozilla/4.0 (compatible; MSIE 6.0; Windows 98; Win 9x 4.90)"
 

Huschi

Moderator
Staff member
fanfarian said:
Auszug aus der MySQL log-datei:
[...]
Soll ich die Anweisung in der Fehlermeldung ausführen oder ist das zu ignorieren?
Kannst Du beides machen. Kommt drauf an, ob Du eine Highperformance-DB mit Volltextsuche brauchst oder nicht.
InnoDB frist halt auch mehr Speicher und ist daher auf einem vServer evtl. labil (senil?).

Solange Du z.B. nur ein Forum mit einem Aufkommen wie diesem hier betreibst, brauchst Du noch keine InnoDB. Ein Forum mit ab 100 (aktiven) Usern und einem Aufkommen von entsprechend vielen Posts am Tag, würde ein InnoDB deutlich besser verarbeiten können.

huschi the husch
 

Huschi

Moderator
Staff member
und hier die Access_log:
Auffällig ist hier die Lücke von 11:28 bis 13:10.
Die selbe Lücke findet sich auch im Error_Log

Hast Du schon mal unter Confixx als Admin die die Confixx-Fehlermeldungen, Hinweise und Warnung angesehen? Ist dort etwas in diesem Zeitraum?

Bitte schau den selben Zeitraum in folgendem File nochmal nach:
/var/log/httpd/confixx/stdlog_access

Das entwickelt sich so langsam zu einer echt spannenden Sache. :)

huschi the husch
 
Top