2 Server = 1 großes Problem

achnix

New Member
Ich habe ipv6 deaktiviert ... nun geht es ... auch wenn ich iwie ein ungutes gefühl bei solchen sachen wie deaktiveren habe.

Vielen dank an euch die mir weiter helfen wollten!!
MFG
André
 

Whistler

Blog Benutzer
Sind die All inkl werte jetzt richtig gestellt?
siehe letztes bild von mir...

Nein.

Entweder "*" oder "*.qadmous.de." (mit abschließendem Punkt).
Ohne Punkt ist der Eintrag relativ zur Zone, also "qadmous.de.qadmous.de.".

Aktueller Reverse ist übrigens: 2.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.6.c.2.7.0.3.1.0.8.f.4.0.1.0.a.2.ip6.arpa. 7200 IN PTR srv1.qadmous.de.
 

achnix

New Member
Hallo Whistler,

danke das du mal nachgeschaut hast.

das mit dem Punkt ging nicht (siehe bild anhang)

Ich habe bei Hetzner heute den 2a01:4f8:130:72c6::2 auf srv1.qadmous.de gestellt genauso die ipv4.

Gestern hatte ich da wohl nicht so den durchblick.

Allerdings habe ich ipv6 immer noch abgestellt damit ich nicht mit Freenet und co in konflikt komme...

Ich denke das ich durch den Reverse (ipv6 srv1.qadmous.de) von heute durch diese ca. 24 stunden wartezeit gedulden muss damit ich ipv6 wieder in betrieb nehmen kann und dieser mit freenet funktionert?

MFG
André
 

Attachments

  • all 7.png
    all 7.png
    52.9 KB · Views: 120

achnix

New Member
Das mit freenet und meinem ipv6 hat bis jetzt noch nicht funktioniert. :(:(:(:(

Ich dachte eigendlich ich müsse nur ca 24 stunden warten.

Jemand noch eine idee für mich?

MFG
André
 

nexus

Well-Known Member
Wenn deine DNS-Einstellungen aus dem Screenshot in Post #23 noch aktuell sind, dann kann das mit deiner IPv6 so nicht funktionieren.
Vielleicht hilft dir eine Erläuterung der DNS-Einträge, die im Screenshot zu sehen sind:
1. Eintrag ist ein A-Record für die Domain qadmous.de (und nur für die)
2. Eintrag ist ein A-Record für alle Subdomains, also *.qadmous.de (Wildcard)
3. Eintrag ist ein AAAA-Record für alle Subdomains, die dem Schema *.qadmous.de.quadmous.de entsprechen.
Hier gehört richtigerweise auch nur ein '*' ins Name-Feld, dann würde der Record für alle Subdomains, also *.qadmous.de passen.

In das Name-Feld gehört also nur, was vor '.qadmous.de' stehen soll

Edit: Frage an die Profis: Müßte der Vollständigkeit halber nicht auch noch ein AAAA-Record eingetragen werden, der nur auf die Domain selber zeigt (also Name-Feld wie beim ersten A-Record leer)? Bin mir da grad nicht 100% sicher...
 
Last edited by a moderator:

achnix

New Member
Hallo nexus,

vielen Dank das du mir auf die Sprünge helfen möchtest.

Leider funktioniert das mit nur * nicht

Sprich (* AAAA ipv6nummer) <-- kommt auch fehler meldung.

Ich kann nur *.qadmous.de AAAA Ipv6 nummer

oder nur qadmous.de AAAA ipv6nummer ..

ein leeres namensfeld ginge auch !

So habe ich es gerade auch ... Leer AAAA ipv6nummer und nur 1 eintrag davon. alle anderen wie bisher.


mfg andré
 

nexus

Well-Known Member
Hmm...bei meinem Anbieter hab ich es so eingetragen (also ein AAAA-Record auf domain.tld selber und ein AAAA-Record für *.domain.tld) und es funktioniert. Da scheint es bei deinem Anbieter wohl noch Besonderheiten zu geben.
Sorry, daß ich dich nicht zum Erfolg führen konnte...:(
 

achnix

New Member
ach macht nix nexus .. hab ja trotzdem jetzt was dazu gelernt bei deinem post ;)

ich verstehe nicht wieso der den * nicht annimmt . Zeile 2 :Syntax NICHT KORREKT .. bei #1 ist er automatisch gesetzt...

Danton sagte mir ja auch schon ich solle es soch machen ... mhh

mach ich etwas bei DATA was falsch?
 
Last edited by a moderator:

danton

Debian User
Die Lösung hat Whistler oben schon genannt:
Entweder "*" oder "*.qadmous.de." (mit abschließendem Punkt).
Da die erste Variante nicht geht, nimmst du die zweite - entscheidend ist der Punkt am Ende!
 

achnix

New Member
Hallo danton,

wie nexus es schon am bild gesehen hatte ... es geht nur ohne "."

sprich *.qadmous.de AAAA ipv6nummer


oh je
....
 

danton

Debian User
Das POsting hatte ich übersehen.
Dann bleibt wohl nur die Möglichkeit, entweder alle SUbdomains einzeln anzulegen oder mal bei All-inkl nachzufragen, wie denn ein Wildcard-Eintrag für IPv6 anzulegen ist.
 

achnix

New Member
ok dann ruf ich da gleich mal an...


Aber kannst du mir die alternative mal mit "einzel anlegen von subdomains" erklären?

Also ganz mormal Subdomains like "ipv6.qadmous.de"?
 

danton

Debian User
Halt das, was du brauchst und per IPv6 erreichbar sein soll, also z.B. www, mail und natürlich auch srv1 (das ist ja die Subdomain, die du für den PTR verwendet hast, wie ich oben gelesen habe).
 

nexus

Well-Known Member
Jetzt hab ich doch mal eine Frage zum richtigen Verständnis:
Wenn A-Record und AAAA-Record korrekt auf IPv4 und IPv6 des Servers zeigen, sollte dann nicht schon ein '* IN CNAME qadmous.de' reichen, um Subdomains in beiden Adressbereichen korrekt aufzulösen?
 

achnix

New Member
So hatte ein nettes gespräch mit dem Herrn von All inkl.

Er sagte das es keinen sinn ergibt wenn man dort den wildcard eintrag setzt denn ich kann eh nur eine IP verwenden. Desweiteren müsste es bei 0 also oben eingetragen werden aber ich solle mich nicht wundern wenn 98 % der webseiten nicht mehr abrufbar wären da ipv6 so gut wie gar nicht standart mässig eingestezt wird.

Er hat mir einfach empfohlen ipv6 abgestellt zu lassen (bei hetzner) was ich ja auch tat und seit dem geht das ja auch mit den mails.

Des weiteren da ich es irgendwo gelsene hatte das freenet ipv6 lauscht meinte er auch wenn sie das tun heisst es nicht das sie auch die mails über ipv6 empfangen usw.

Naja ... ich lass erstmal die ganze geschichte mit ipv6 aus und warte einfach wie sich das weiter entwickelt.

Danke an euch allen für eure hilfestellung!

Gruß
André
 

danton

Debian User
Er sagte das es keinen sinn ergibt wenn man dort den wildcard eintrag setzt denn ich kann eh nur eine IP verwenden.

Da hast du ja eine "richtigen Experten" dran gehabt. Unter einer IP können mehrere Webseiten erreichbar sein (im HTTP-Protokoll wird der FQDN mitgeschickt) und da kann ein Wildcard einem die Arbeit vereinfachen, wenn man mehrere Subdomains nutzt.
Bei der aktuellen Knappheit an IPv4-Adressen zu raten, IPv6 besser abzuschalten, ist eher kontraproduktiv. Es gibt wohl schon einige Server die nur per IPv6 erreichbar sind (IIRC derzeit noch primär im asiatischen Raum) und die Zukunft ist nun mal IPv6.
Auch zeigt ja dein Problem mit Freenet, daß dort auf IPv6 sehr wohl Mailserver lauschen. Freenet würde für seine Mailserver auch im DNS keine IPv6-Records anlegen, wenn sie das nicht tun würden.
Wenn All-Inkl dir keinen zusätzlichen Wildcard für IPv6 anbieten will, dann kannst du ja auch immer noch die Subdomains einzeln anlegen, so wie du sie benötigst (schrieb ich ja oben schon).
 

achnix

New Member
hallo danton,

naja .. ich geh doch mal davon aus das man es mit Fachleuten zu tun hat wenn man den support von denen in Anspruch nimmt.

Das komische ... ich bezog mich ja in dem gespräch auf die hilfe von diesem forum und er meinte ich solle solche foren nicht ernst nehmen da es sich meist um studenten handele .. das war seine meinung nicht meine ... ich finde den support hier super!

Das problem ist ...

Das mit freenet ist ja son ganz aktuelles problem hier im forum und sonst wo im netz ... ich bin ja nicht der einzige mit dem problem, habe aber irgendwie nie so richtig das gefühl das es gelöst worden ist. In bezug auf ipv4 gibt es ja auch diesen besagten fehler von freenet, doch diesen habe ich gott sei dank nicht.

Kurz nochmal für mein verständnis...

Ich habe bei hetzner jetzt im kundenmenü aktuell die ipv4 ip und Revers dns srv1.qadmous.de gesetzt ...

Bei der ipv6 ip hatte ich gestern morgen srv1.qadmous.de gesetzt.

Bei all inkl zeigt die ipv4 ip (vom hetzner server) mit dem A eintrag auf den Hetzner server ...

Und das ganze problem mit freemail liegt daran das quasi All inkl nicht noch mit der ipv6 auf mein Hetzner zeigt .. Habe ich das so richtig verstanden ? Das heisst beim Hetzner server ist alles ok nur all inkl spielt da noch nicht richtig mit.

Und dann hab ich doch noch irgendwo bei hetzner gelesen das doch sozusagen beide funktionieren sollten , sowohl ipv4 und ipv6 ist das korrekt ?
 
Last edited by a moderator:

danton

Debian User
sollte dann nicht schon ein '* IN CNAME qadmous.de' reichen

Jein, denn du kannst so keine Subdomain für den MX-Record verwenden. Der MX muß immer auf einen A bzw. AAAA Record zeigen, nie auf einen CNAME. Genauso wie auch ein CNAME nicht auf einen anderen CNAME zeigen darf. Du wärest mit diesem Kontrukt schon ein wenig eingeschränkt und müßtest für bestimmte Subdomains weiterhin einen Eintrag anlegen (u.a. mail.qadmous.de weil dort der MX drauf zeigt).
 

nexus

Well-Known Member
Jein, denn du kannst so keine Subdomain für den MX-Record verwenden. Der MX muß immer auf einen A bzw. AAAA Record zeigen, nie auf einen CNAME. Genauso wie auch ein CNAME nicht auf einen anderen CNAME zeigen darf. Du wärest mit diesem Kontrukt schon ein wenig eingeschränkt und müßtest für bestimmte Subdomains weiterhin einen Eintrag anlegen (u.a. mail.qadmous.de weil dort der MX drauf zeigt).
Jap, ist sicher nicht das optimalste Konstrukt, aber über den Umweg wären zumindest dann 'normale' Subdomains über den Wildcard auflösbar und man bräuchte wirklich nur für die 'speziellen' Subdomains wie zb. mail.domain.tld separate Records.
 
Top