VHCS nach upgrade auf lenny - wie debugge ich?

yavhcsu

Registered User
Nun, wenn ich das so verfolge, wird die Wahrscheinlichkeit eines noch nicht entdeckten Datenbankfehlers IMHO immer deutlicher.

Aber wie @CentY schon vorschlägt, mach eine Neuinstallation (mit dem Installationscript (VHCS Installation script by Armadillo) kannst Du das mit Debian Etch machen, Lenny ist noch nicht fertig) auf einem anderen Rechner bzw. mit VMWare in einer virtuellen Maschine. Sichere die Datenbank zurück und schau was geschieht.

Ah, noch etwas. Wenn man Konfigurationsdateien mit einem ungeeigneten Editor auf einem Windows-PC bearbeitet und hochlädt, sind die falschen Satzendezeichen enthalten. Damit haben einige Programme arge Probleme. Sichtbar wird das ganze im Editor vom mc jeweils als circumflex am Ende einer Zeile. Aber ist nur noch mal so eine Idee, weil bei dieser Geschichte tappt man so richtig im Dunkeln.
 

kleinerdrache

Blog Benutzer
Viel arbeit

Server neu aufsetzen klingt nach sehr viel arbeit, selbst bei wenigen (20) Domains. Da würde ich fast auf den ubuntu server umsteigen, und ev. auch alternativen zu vhcs probieren.

Die Idee wegen Windows editor fällt flach, ich habe nun seit 11 jahren nur noch Linux auf meine Desktops (und server) und habe auch die files immer direkt im vi am server über ssh editiert, dabei allerdings immer nur die apache konfiguration, bei bind habe ich nie herumgewerkt.

Ich werde also eher weiter auf ein workarround spizzeln, da ich nicht neu aufsetzen möchte. Weiters ist das hauptproblem ja, dass vhcs sich 'aufhängt', also der cpu verbrauch auf 100% steht und in irgend einer loop hängt anstatt abzubrechen. Das stört mich am meisten.

lg,
Martin
 

CentY

Registered User
Wie gesagt nimm mal die Datenbank und probier das in einer VM aus um einen Datenbankfehler auszuschließen danach kann man evtl. weiter debuggen.
 

yavhcsu

Registered User
Ja, ich kanns verstehen, dass Du wenig Lust verspürst, den Server neu aufzusetzen. Allerdings kann die Fehlersuche ebenso viel Zeit in Anspruch nehmen.

Was wir Dir aber vorschlagen, ist in einer frischen Umgebung einen neuen Server mit VHCS aufzusetzen, eben ohne die domain. Dann sicherst Du die Datenbank hier zurück und schaust, was VHCS macht. Wenn hier nun kein Fehler mehr auftritt, dann machst Du Dir in einem Deiner Linux-Desktops für die domains, die Testen möchtest, ein paar Einträge in die hosts und prüfts, ob via Webinterface Du neue Einträge hinzufügen kannst. Das dürfte mit dem Script auf Etch in max. 2 Stunden laufen.

Mit dieser Methode kannst Du IMHO klar feststellen, ob die Datenbank Probleme macht oder der Fehler ganz woanders liegt.
 
Top