Rootserver tot nur Recovery Mode geht



larsM

New Member
Hallo zusammen,

Ich hab ein grosses Problem. Mein Root-Server ist nur noch zu erreichen per Recovery Mode. mysql, psa läuft nicht mehr im normalen Modus ebenso Mail etc.
In den Apache Logs steht nichts drin ebenso ist die mysql Log leer...

Wie kann ich das Rootpasswort ändern?

habe versucht mit mount /dev/sda1 /mnt die platte in mnt zu mounten aber kann das passwort via passwd dann nicht ändern? Hab ich da was vergessen?
Bevor der Server sich in der Nacht verabschiedet hat waren die Logins per Key gesichert. Nur nimmt der Server, warum auch immer die Passphrase nicht an.

Will alles sichern an Daten, damit ich den Server platt machen kann.

LG Lars
 
Wenn Du das PW mit "passwd" ändern möchtest, dann musst Du einen Chroot ausführen, ein mount alleine reicht nicht aus, der hängt lediglich die Platte ein.
Einen Tarball kannst Du aber auch so erstellen, ohne Chroot.
 
Ja das hab ich ja gemacht gehabt. Hab chroot auf /mnt (sda1) gemacht aber das ging nicht.
Oder muss das Kommando chroot /dev/sda1 sein?
 
Nimm von diesem Guide NUR den Teil mit "mounting the necessary Filesystems" und "Entering the new Environment".

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=1&chap=6

Wenn das wider Erwarten nicht klappen sollte, bitte den vollständigen Output hier posten, insbesondere die Fehlermeldungen.
Aber, wie gesagt, einen Tarball kannst Du auch so erstellen, einfach die Platte mounten und alles sichern.
 
Danke dir, warte aber eben eine Datensicherung per NCFTP ab. Melde mich dann noch mal.

Edit:

Lese da gerade chroot /mnt/gentoo /bin/bash ist der chroot Befehl also bei mir chroot /mnt /bin/bash
Das mache ich dann nachher mal.
 
Last edited by a moderator:
Hallo,

Also habs nochmal probiert. Kann das passwort nicht ändern

root@h2124583:~# mount /dev/sda3 /mnt
root@h2124583:~# mount /dev/sda1 /mnt/boot/
root@h2124583:~# mount -o rw,remount /mnt
root@h2124583:~# chroot /mnt /bin/bash/
chroot: failed to run command `/bin/bash/': Not a directory
root@h2124583:~# chroot /mnt /bin/bash
root@h2124583:/# passwd serveradmin
Enter new password:
Retype new password:
passwd: Authentication token manipulation error
passwd: password unchanged
root@h2124583:/#
 
Hast du alle Partitionen gemountet?

Wenn ja sollte es problemlos funktionieren:

rescue:~# chroot /mnt
rescue:/# passwd
Changing password for user root.
New password:
Retype new password:
passwd: all authentication tokens updated successfully.
 
so ich denke ich hab einen Fehler entdeckt die Swap Partition ist defekt.

Werde mal den Support anschreiben.
 

Attachments

  • swap_error.jpg
    swap_error.jpg
    18.6 KB · Views: 161
Wenn kein swap da ist und Du ihn willst. Erstelle Dir welchen. Dazu brauchste keinen support. Aber fehlender Swap hat nichts damit zu tun das deine Kiste nicht mehr läuft.
Gruss Sven
 
Für mich liegt der Verdacht nahe, dass Du nicht mehr alleine Herr dieses Servers bist.

Gruss Sven
 
Vorher Tarball erstellen, damit Du hinterher analysieren kannst, wie der Angreifer überhaupt drauf kam.
 
Dann würde ich vorgehen wie von Alderon schon beschrieben wurde. System sichern>>>analysieren und für die Zukunft besser absichern.
 
Ohne, wenn man den das Wissen dazu mitbringt. Ein System mit Plesk kann genauso sicher sein, aber dazu sollte man sich genauso gut auf der Konsole auskennen, wenn nicht sogar noch besser. Ein Panel wie Plesk kann dir die administrative Arbeit zwar erleichtern, macht sie aber nicht überflüssig. Updates am System und diverse Sicherheitseinstellungen mußt du schon über die Konsole machen.
 
Ja das ist klar. Überlege gerade nur wegen PHP update bei Plesk. Ist ja so ne Sache. Ausserdem will ich angreifen so wenig wie möglich Angriffsfläche bieten
 
Back
Top