Raspberry Pi - Display HDMI geht nicht !??

BitCrunsher

New Member
Hallo !

Ich bastel grade an einem Projekt bei dem ein Raspberry Pi Modell B
zum Einsatz kommt, das erste Projekt mit dieser Art von Kleinserver.
Der Rechner läuft soweit ; installiert mit Raspbian Wheezy.

Aber : Kein DISPLAY. :eek:

Habe mir ein Kabel HDMI auf VGA bestellt, was heute geliefert wurde,
doch wenn ich das an einem 19" Targa Visonary Flatscreen anschliesse,
zeigt der Monitor nur "NO SIGNAL" in Form eines Testbildes an, der
Composite-Ausgang dagegen funktionert wohl, ist mir aber bei dem
zur Verfügung stehenden 320x240 pix. Beamer von der Qualität zu
mager. Ich verstehe nicht, warum das Bild am VGA-Monitor nicht
dargestellt wird, das Kabel ist ein neues HDMI zu VGA Kabel und kann
Anschlusstechnisch problemlos angeschlossen werden. KEIN SIGNAL !

:mad:

Kann mir dabei jemand mit Tipps etwas bei Seite stehen ? HDMI ist
für mich Neuland, daher auch etwas frustriert, dass es nicht läuft.

:(

Später soll im Rahmen des Projektes die Himbeere in einen Koffer
verbannt werden und ein Notebook-Display beinhalten, jenes Display
wird allerdings auch nur einen normalen VGA-Eingang haben....

Kennt sich damit jemand aus ? :confused:

Liebe Grüße,
BitCrunsher :rolleyes:
 

Operaiter

New Member
Du betonst hier immer wieder das es ein NEUES Kabel ist!

Gerade diesem würde ich ja nicht vertrauen ;) Vertraue nur einem Kabel, wo du weißt das es funktioniert.

Verifiziere doch erst mal das das Kabel läuft... Vielleicht hast du einen Bekannten der ein Notebook mit HDMI Output hat und es mal testen kann?

Lg OP
 

BitCrunsher

New Member
Du betonst hier immer wieder das es ein NEUES Kabel ist!

Gerade diesem würde ich ja nicht vertrauen ;) Vertraue nur einem Kabel, wo du weißt das es funktioniert.

Prinzipiell haste da recht, nur sollte man davon ausgehen können, wenn man
vom Hersteller Originaleingeschweisste/verpackte/ungeöffnete Ware kauft.

Verifiziere doch erst mal das das Kabel läuft... Vielleicht hast du einen Bekannten der ein Notebook mit HDMI Output hat und es mal testen kann?

Daran dacht ich auch, nur keine Möglichkeit vor Ort.

Weiss nicht mal, ob der RPI überhaupt analoge Videosignale aus dem
HDMI-Anschluss rausschickt, oder nur digital (weil's kabel kein konverter,
sondern nur adapter ist)

Bin am überlegen wie man das testen oder rausfinden könnte, weiss aber
sogut wie gar nix über die hardware-properties der Himbeere....
irgendwie schmeckt die nur mit Display richtig :p :rolleyes:

hm, probier ich gleich nochmal an nem älteren Röhren-VGA aus,
mal sehen was da kommt....

Gruss,
BitCrunsher
 

Firewire2002

Registered User
HDMI schickt niemals analoge Signale raus. DVI kennt noch so eine Mischform. Aber HDMI oder Displayport nicht.
Kannst du uns mal zeigen was du da für ein gutes Stück hast?
 

BitCrunsher

New Member
HDMI schickt niemals analoge Signale raus. DVI kennt noch so eine Mischform. Aber HDMI oder Displayport nicht.
Kannst du uns mal zeigen was du da für ein gutes Stück hast?

Yepp, als Attachment jpeg. (1 = der raspberry model B mit design gehäuse
und 2 = Kabel Eingangs/Ausgangs-Anschluss)

Lass mich raten, hab ich ahnungslos das falsche Equipment gekauft, hm?
:confused: :eek:

LG,
BitCrunsher :rolleyes:
 

Attachments

  • Foto0385.jpg
    Foto0385.jpg
    140.1 KB · Views: 378
  • Foto0386.jpg
    Foto0386.jpg
    97.9 KB · Views: 450

Firewire2002

Registered User
Hast du auch eine Produktbeschreibung von einem Shop dazu? Oder einen Produktnamen?
Solche Adapter haben zwangsweise Logik inbegriffen. "Ältere" Generationen sind aktive Konverter mit eigenem Netzteil: http://www.amazon.de/HDMI-VGA-Konverter-kompatibel-Converter/dp/B004RUBIOG
Neuere Generationen beziehen ihren Strom einfach vom HDMI Port: http://www.amazon.de/Ligawo-®-Konverter-Kabel-Netzteil/dp/B0052ICZGC#productDetails

Ein reines Kabel mit HDMI auf VGA Stecker kann nicht funktionieren. Sicher, dass das nicht nur ein Adapterkabel für eine Konverter-Box ist? Man die eigentliche Logik also noch dahinter hängen müsste?
Oder hängt an dem Kabel noch mehr, was wir auf dem Bild nun nicht sehen?
 

BitCrunsher

New Member
Hast du auch eine Produktbeschreibung von einem Shop dazu? Oder einen Produktnamen?
Solche Adapter haben zwangsweise Logik inbegriffen. "Ältere" Generationen sind aktive Konverter mit eigenem Netzteil: http://www.amazon.de/HDMI-VGA-Konverter-kompatibel-Converter/dp/B004RUBIOG
Neuere Generationen beziehen ihren Strom einfach vom HDMI Port: http://www.amazon.de/Ligawo-®-Konverter-Kabel-Netzteil/dp/B0052ICZGC#productDetails

Ein reines Kabel mit HDMI auf VGA Stecker kann nicht funktionieren. Sicher, dass das nicht nur ein Adapterkabel für eine Konverter-Box ist? Man die eigentliche Logik also noch dahinter hängen müsste?
Oder hängt an dem Kabel noch mehr, was wir auf dem Bild nun nicht sehen?

hmmm, gekauft hab ich das von nem ebay-händler :

http://www.ebay.de/itm/151197824323?ssPageName=STRK:MEWNX:IT&_trksid=p3984.m1439.l2649

(hersteller-marke : GiXa Technology)

Wenn da LOGIC-circuits drin sind, dann in den Stecker-Gehäusen.
hab nochmal etwas deutlichere foto's angefertigt :

LG, Ralf
 

Attachments

  • Foto0389.jpg
    Foto0389.jpg
    70.8 KB · Views: 244
  • Foto0390.jpg
    Foto0390.jpg
    66.2 KB · Views: 268
  • Foto0391.jpg
    Foto0391.jpg
    86.1 KB · Views: 346

wemaflo

New Member
Zitat von der Ebay-Seite:
ACHTUNG WICHTIG :
Dieses Kabel ist kein Konverter, daher prüfen Sie bitte vorher, ob Ihre angeschlossenen Geräte eine Signalumwandlung von VGA auf HDMI bzw. von HDMI auf VGA unterstützen!

Die Produktbeschreibung bzw, der Name lädt aber gerade dazu ein, das Kabel als Konverter zu kaufen, wenn man sich nicht auskennt und nicht bis zum Ende der Seite liest...
 

BitCrunsher

New Member
Zitat von der Ebay-Seite:


Die Produktbeschreibung bzw, der Name lädt aber gerade dazu ein, das Kabel als Konverter zu kaufen, wenn man sich nicht auskennt und nicht bis zum Ende der Seite liest...

dumm gelaufen, mit HDMI und so hatte ich bislang auch nix zu tun.

hm, der Raspberry soll später in einem Koffer ein Notebook-Display
verpasst bekommen, und eine in etwa in Frage kommende
Ansteuerplatine fuer das Panel hat nen VGA eingang, aber auch einen
DVI-I Port. Was genau wuerde ich denn brauchen um überhaupt die
Himbeere an derartige Displays, ob nun VGA oder DVI-I, zum laufen
zu bringen !?

:confused:
 

d4f

Kaffee? Wo?
Was genau wuerde ich denn brauchen um überhaupt die
Himbeere an derartige Displays, ob nun VGA oder DVI-I, zum laufen
zu bringen !?
Die bereits erwähnten Ligawo-Adapter funktionieren am RPI und jedem bislang getesteten Bildschirm/Beamer tadellos. Achte aber darauf dass du eine Version mit optional separatem Strom-Eingang nimmst da einige HDMI-Ports, und zumal der des RPI, nicht wirklich genug Strom liefern für den Betrieb und ansonsten das Bild bei etwas längeren Kabel gestört dargestellt wird oder ausfällt.
Aktuell habe ich dieses Kabel für mein Notebook und RPI im Einsatz:
http://www.amazon.de/gp/product/B00521RY4W/ref=wms_ohs_product?ie=UTF8&psc=1

Falls du direkt auf einen LVDS-Eingang eines LCD gehen willst, kannst du auch ein HDMI->LVDS Kit nehmen, bspw dieses:
http://www.ebay.de/itm/HDMI-DVI-VGA...24120?pt=US_Server_Boards&hash=item19df01deb8

ob nun VGA oder DVI-I,
Mir sind schon DVI-I Anschlüsse untergekommen welche eigentlich DVI-A sind und somit das für HDMI-Umwandlung notwendig DVI-D nicht beherrschen. Bevor du also Hardware kaufst bitte schlau machen oder testen ob er wirklich DVI-D kann!
 
Last edited by a moderator:

Thunderbyte

Moderator
Staff member
Das o.g. Problem scheint ja gelöst.

Ein weiterer Stolperstein beim Raspi: die USB Ports reichen zwar für USB Sticks stromtechnisch aus, externe 2,5" Platten ohne eigene Stromversorgung gehen aber nicht. Daher ist bei dem Wunsch, mehrere USB Geräte (z.B. Keyboard, Maus, Stick, USB Platte ein vernünftiger AKTIVER USB Hub mit eigenem Netzteil anzuraten. Ideal für die Platte ist, wenn dieser Hub noch einen 2A Port (mitunter als "für iPad/Tablet" bezeichnet) mitbringt.

EDIT: ok, hab mir die Bilder gerade erst genauer angesehen. Anscheinend hast Du gepowerte USB Hubs.
 

BitCrunsher

New Member
HDMI schickt niemals analoge Signale raus. DVI kennt noch so eine Mischform. Aber HDMI oder Displayport nicht.
Kannst du uns mal zeigen was du da für ein gutes Stück hast?

Jop, da hattet Ihr auch recht, das Kabel ist etwas für solche mix-dinger
wo man den HDMI-Port vom Geraet aus auf VGA-Modus umschalten kann.
Hat also keinen Konverter, nicht geeignet für mein Projekt. Wenn das jemand
für sich brauchen kann, schenk ich's ihm (+1,90 versand)
 

BitCrunsher

New Member
Das o.g. Problem scheint ja gelöst.

Ein weiterer Stolperstein beim Raspi: die USB Ports reichen zwar für USB Sticks stromtechnisch aus, externe 2,5" Platten ohne eigene Stromversorgung gehen aber nicht. Daher ist bei dem Wunsch, mehrere USB Geräte (z.B. Keyboard, Maus, Stick, USB Platte ein vernünftiger AKTIVER USB Hub mit eigenem Netzteil anzuraten. Ideal für die Platte ist, wenn dieser Hub noch einen 2A Port (mitunter als "für iPad/Tablet" bezeichnet) mitbringt.

EDIT: ok, hab mir die Bilder gerade erst genauer angesehen. Anscheinend hast Du gepowerte USB Hubs.


OH ja, das Problem ist mir nun auch aufgefallen, bei einer simplen
H/W : Konfiguration

20000 mA/h Akku mit 2 USB Ausgaengen, einer 2,5 A/h und einer 1 A/,
Raspberry mit 1 A/h + 1x USB-HUB gepowered mit den 2,5 A/h und
Tastatur am Raspberry, am HUB: Maus, WLAN, Bluetooth.
(display ueber analog-karte cinergy400 composite) sound ueber
PC-verstaerker)

kommt es beim Einschalten sehr oft vor, dass der RPI erst gar nicht
anfaengt zu booten und seine LED's einfach nur rot leuchten aber nix
passiert, daraufhin zum testen alles vom USB abgenommen, gleiches
Problem, 1-Tag spaeter alles angeklemmt und laeuft. !?!??

Also irgendwie ist im RPI etwa drin, was zum startzeitpunkt fuer kurze
Zeit sehr viel Strom zieht, was dazu führt dass die CPU nen Fehlstart
faehrt, und reset ist nicht moeglich weil USB ja noch nicht initialisiert
ist. Falls sich diese Theorie bestaetigen laesst, wuerde ich sagen
hinter dem einschaltbarem akku einen 100uF ELKO hinterzusetzen,
und zum tatsaechlichen einschalten dann noch einen Kippschalter hinter
dem ELKO-gepuffertem Kreis, das muesste dann eigentlich die kurzen
Spannungseinbrüche verhindern. Bei Festplatten duerfte das noch etwas
schwieriger werden, weil dort ja die Anlaufphase mit Spannungseinbruch
weitaus laenger dauert als bei der Main-CPU.

Also nich nur einfach nen Akku-Rechner, sondern auch noch ne
Lektuere in Sachen stabilisierte Energiezufuhr bei hohen Einschaltstroemen,
oder wie !? :rolleyes: ;)

muss mal gucken wann ich mir das Board fuer's LCD-Panel leisten kann,
auch wenn's nur 25 euro sind, die muss man erstmal haben ;-) und dann
die 2te lektuere energyversorgung, weil das display ja nunmal auch noch
leckere Himbeer-taugliche 12 volt haben möchte.... Und allein dass LIPO
Akku's da um 1 nachkommastelle nach unten variiert entmutigt mich etwas,
weil ich von spannungsstabilisierung kaum ne ahnung habe, OK, die
78xx Gruppe kenn ich, es gibt auch aufwerts-regler, nur die ziehen dann
ja noch mehr saft weg... vielleicht gleich doch lieber n' anderes system
fuer die 12V versorgung benutzen !??

PS: Für eure Unterstuetzung bin ich sehr dankbar, deshalb habe ich mich
entschlosse meine Projektunterlagen sowohl von H/W-Seite als auch S/W
seite als Dokumentation / tech. specification und Aufbau-Anleitung zu
schreiben und diese für euch und andere Interessten nach Abschluss meines
Projektes verfügbar zu machen.

:cool::cool:
:p :D ;)

Ach so, bei den Bluetoothdongles (2stck) hatte ich tatsaechlich exakt
identische geliefert bekommen. etwas doof ist dabei, dass dort auch die
MAC-Adresse exakt identisch ist und demnach nur einer innerhalb der
gleichen LocalArea benutzt werden kann. Gibt es S/W mit der man
die MAC-ID aendern kann um beide Dongles gleichzeit im LocalArea
verwenden zu können? hatte in google nur sowas wie bluesmash lesen
koennen, aber nirgend nen downloadlink fuer dieses tool gefunden...

Liebe Gruesse,
Ralf Moeller
 

elias5000

Site Reliability Engineer
Also irgendwie ist im RPI etwa drin, was zum startzeitpunkt fuer kurze Zeit sehr viel Strom zieht,
Du könntest versuchen den RPi über GPIO zu powern und einen 220uF-Kondensator (oder was in ähnlicher Größe) vorschalten.

+5V und Masse liegen auf dem GPIO auf den Pins 2 und 6 (siehe angehangene Grafik)
 

Attachments

  • Raspberry-Pi-GPIO-Layout-Revision-2-e1347664831557.png
    Raspberry-Pi-GPIO-Layout-Revision-2-e1347664831557.png
    76.4 KB · Views: 2,392

Thunderbyte

Moderator
Staff member
@BitCrunsher (das schreibt man übrigens BitCruncher):

Als Mod möchte ich Dich um Beachtung von Rechtschreibung und Zeichensetzung bitten. Bei Nichtbeachtung muss ich leider verwarnen.

Davon abgesehen ist Deine Absatzregelung (neue Zeile nach X Buchstaben) nicht hilfreich (macht die Posts sehr lange und anders als die anderen). Ich bitte Dich, das zu unterlassen.
 

BitCrunsher

New Member
Du könntest versuchen den RPi über GPIO zu powern und einen 220uF-Kondensator (oder was in ähnlicher Größe) vorschalten.

+5V und Masse liegen auf dem GPIO auf den Pins 2 und 6 (siehe angehangene Grafik)

Erstmal Danke für das GPIO-Pinning, werd ich bestimmt irgendwann nochmal
brauchen. Interessant wäre auch zu wissen wie man die Ports ansteuern kann,
allerdings ist es dafür ein schlechter Zeitpunkt, so weit bin ich hier mit dem
Aufbau des Gerätes und dem Sammeln der Grundinformationen noch nicht. Bin
ja schonmal froh darüber, dass sich der xmailserver problemlos compilieren liess
und alle wichtigen Standardtools in einwandfreier Funktion zur Verfügung stehen.
Also der Kernwrapper für Wheezy ist Klasse programmiert. Weiss zwar nicht was
XMBC Mediacenter verwendet, das war auf dem 20 ANSILUMEN-Beamer leider
etwas schwer zu lesen ;) doch auch dort einwandfreie Umsaetzung,
USB-Festplatte wurde sofort erkannt und es liess sich von NTFS problemlos
DivX-Video's und MPegs abspielen. Ist schon tolle Leistung für so ein luetsches
Gerätchen .... :)

Gibt es beim Speisen über den GPIO-Port eine maximale Stomstaerke ? Über
den Standard-Stromeingang wurde das Netzteil auf 1,2A/h ausgelegt und die
Spannung auf 5,25V festgelegt, diese 0,25V zusätzlich hat mein Powerakku
nicht, deswegen warscheinlich auch die Spannungseinbrüche. Ebenfalls läuft
das ganze nicht richtig, bzw. gefolgt durch einen Absturz entweder CPU oder
USB wenn mit 5,0V 2,5A/h am RPI eingespeist wird, jedoch am USB nur 2
extern gepowerte HUB's dran hängen, also ich denke schon dass man in
Sachen Stromversorung: Regelung und Stabilität an dieser Stelle etwas
nachhelfen muss.

LG, Ralf
 

BitCrunsher

New Member
@Thunderbyte: (als Crunsher verstand man vor 20 Jahren Kompressionsverfahren) :eek:

Als Programmierer hab ich meine ganz persönlichen Formatierungs-Stiele was
Textdokumente betrifft, Quelltexte mit 2*char seperator und so weiter.
Bei Dokumentations-Texten etc. ist dies etwas anders, bei Mails solltest du wissen
dass ich damals mit FIDO-Netz und 2400 Baudmodems angefangen habe ...
(Vielleicht sagt dir das auch was: ProBoard, Frontdoor, McMail, TheMin, RA etc..)
In dieser Zeit hat sich vieles geändert, unter anderem auch fixed-fonts wurden
Truetype-schriften, Fontgrößen Maßbezogen statt pixelweiten-orientiert usw.)
Entschuldige bitte, ich werde versuchen mich hier möglichst angepasst zu
verhalten, sollte dennoch mal was in diese richtig sein, bitte PN und ich editiere
das dann nach... ...TurboAssembler 5.0 ... das waren noch Zeiten.. (kicher)

Liebe Grüße,
BitCrunsher :cool:
 
Last edited by a moderator:

elias5000

Site Reliability Engineer
Gibt es beim Speisen über den GPIO-Port eine maximale Stomstaerke?

Der RPi hat am normalen Eingang (micro-USB) eine Input-Fuse, die hochohmig wird, wenn ein bestimmter Strom überschritten wird. Dann fällt die Spannung im RPi ab. Frag mich nicht, wie hoch dieser Strom sein darf - das müsste ich auch googeln.
Auf jeden Fall umgehst du diese Input-Fuse, wenn du den RPi per GPIO versorgst. Dadurch hast du bei Lastspitzen keinen Spannungsabfall. Der Kondensator stützt nochmal zusätzlich.
Wenn du da 2A rein gibst, dann dürftest du an der anderen Seite schon Spielraum haben, was du da wieder raus holen kannst. Für externe Platten (und mehrere starke Verbraucher) empfiehlt es sich trotzdem, diese am RPi vorbei zu versorgen.
 
Last edited by a moderator:
Top