Proxmox IPv6 VM DNS Problem

Dentai

New Member
Hallo zusammen,

ich habe bei Hetzner eine Rootkiste stehen welche mit Proxmox läuft. Da ich die 3 IPv4 Adressen verbraucht habe, wollte ich nun an das IPv6 Subnetz. Die Anleitung auf der Hetzner Seite dazu ist leider so komplett unbrauchbar und hat keine Erfolge gebracht. Nach mehreren Versuchen habe ich nun aber eine IPv6 am Host und eine gerouted auf der VM.

Jetzt kommt es aber zu einem kuriosen Problem. Ich gekommen keinen Internet mit einer IPv6 VM. Egal ob Linux oder Windows, es kann NUR Google.de aufgerufen werden...
So funktioniert weder die Windows Update Funktion noch z.b der Netzwerkspiegel für Apt bei Linux.
Der kompetente Support von Hetzner behauptet steif und fest es liege kein Fehler vor und es würde alles korrekt aufgelöst. Da dies aber nicht stimmt und nichts geht außer Google.de wende ich mich hier an euch.
 
Last edited by a moderator:

Knight22

New Member
Hi,

Das ist sehr komisch kannst du die Adressen alle samt Pingen oder sind die alle tot bis auf Google?

Welchen DNS verwendest du, kannst du allgemein mit nslookup/die die oben genannten Domains auflösen zB. beim apt-get, und was passiert wenn du die IP des Google DNS (2001:4860:4860::8888) mal testweise verwendest?

Btw. Ist der Host extern Pingbar oder reagiert er darauf auch nicht?

Grüße
Knight
 

Dentai

New Member
Der Host ist via IPv6 erreichbar, Ping bar und ich bekomm auch ssh.
Nslookup löst die Seiten auf und der DNS Server von Hetzner ist auch Ping bar.
Der Public DnS Server von Google ändert leider nichts.
 

Knight22

New Member
Das ist komisch...

Kannst du mal versuchen einen Test Download per ipv6 zu laden vllt. hat er beim Übertragen von Daten ein Problem - Nur so als iIee.

Ich hatte das aber mal in einer anderen Form. Er hat beim apt-get versucht die IPs aufzulösen und hat immer die IP meines Main Servers zurückgegeben dann ging es auch nicht. Leider hab ich den Fehler nie gefunden, da es nur bei einem Repo der Fall war.

Viel Erfolg
Knight
 
Top