Probleme mit Abhängigkeiten: libapache2-mod-security2

spookie79

Member
Habe jahrelang (zweistellig) oft Emails bekommen die grösser waren, es war leichter für die Einsender. Es gibt zwar eine praktische Uploadfunktion auf der Seite aber die wird von vielen ignoriert - gewohnter Trott und so.
Naja geht dann halt nicht anders, wundert mich halt. Bei Gmail hat man da auch Freiheiten und bei meiner uralten privaten Email eines bekannten Anbieters sind auch 50MB problemlos.

Mir wars an sich immer egal, wie Material rein kommt. Leider setzen nicht viele auf wetransfer und andere praktische Dienste dafür.
 

danton

Debian User
Googles Gmail ist ein ganz schlechtes Beispiel. Die verwerfen teilweise nämlich angenommene Mails - z.B. bei Mailinglisten wird die Mail, die man hingeschickt hat, bei der Rückkehr zwar angenommen, landet aber nicht im Postfach sondern verschwindet in /dev/null. Da stellt sich natürlich die Frage, was Google evtl. noch so "nach /dev/null wegfiltert", was den Empfänger nie erreicht.
Solange sich große Dateien per Mail verschicken lassen, wird der Absender gar nicht drüber nachdenken, einen anderen Weg zu nehmen - nennt sich Bequemlichkeit. Aus meiner beruflichen Tätigkeit kann ich sagen, dass Firmen auf ihren externen Gateways gerne mit Restriktionen in unteren zweistellingen MB-Bereich arbeiten (firmenintern geht teilweise mehr). Dann werden die angebotenen Wege für größeres auch genutzt, weil es nicht anders geht.
 

spookie79

Member
In der Firma, US lastig mit hoher Sicherheit überall und dem Mutterkonzern, eine sehr grosse deutsche Firma, sind 50 MB Limits bei Emails, da die pdf Dateien teilweise heftig sind. Für grösseres gibts einen anderen sicheren Weg.
 

Przemek69

New Member
Hallo spookie79, wie hast Du das geschafft? Ich habe auch dieses Fehler. Jetzt auch in Plesk Update kommt:
Installation wird nicht fortgesetzt
Die Ausführung von apg-get ist mit folgender Meldung fehlgeschlagen:
Reading package lists...
Building dependency tree...
Reading state information...
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
libapache2-modsecurity-plesk : Conflicts: libapache2-modsecurity
modsecurity-crs : Depends: libapache2-mod-security2 (>= 2.8.0)
Kann mir jemand bitte helfen?
 

danton

Debian User
Du schreibst nicht, welches Betriebssystem du verwendest, ich würde aber vermuten, noch Ubuntu 16.04 oder älter., da dort modsecurity-crs noch eine Abhängigkeit auf libapache2-mod-security2 hat, während die aktuelle LTS 18.04 da nur noch ein Recommends drauf hat und diesen Fehler nicht auslöst. Das Paket aus dem Plesk-Archiv scheint die Abhängigkeiten für libapache2-md-security2 anscheinend nicht korrekt aufzulösen, liefert nur eine Konflikt. Endweder in Plesk auf modsecurity verzichten (in Plesk deaktivieren und dann die modsecurity-Paket mit apt/apt-get deinstallieren oder ein Update auf Ubuntu 18.04 prüfen (wenn du wie spookie79 noch Ubuntu 14.04 einsetzt, ist ein Update auf ein aktuelles Ubuntu sogar Pflicht, da du schon seit einem halben Jahr keine Updates mehr bekommst...
 

Przemek69

New Member
Hallo danton,
Betriebssystem ‪Debian 8.11‬
Plesk Onyx 17.8.11 Update #67, zuletzt aktualisiert: 9. Sept. 2019 05:12:54
Gruß Przemek69
 

danton

Debian User
Für Debian Jessie gibt im Prinzip das gleiche, wobei da noch bis Mitte nächsten Jahres der LTS-Support läuft, so das ein Teil der Pakete von Debian noch Support hat. Ein Update mindestens auf Debian 9 wäre also ratsam, sofern von Plesk unterstützt wäre Debian 10 noch besser (aber soweit ist Plesk wohl noch nicht). Das Update kann auf vServern aber u.U. zu Problemen führen, da abhängig von der Virtualisierung ein gemeinsamer Kernel des Hostsystem genutzt wird, der aktuell genug sein muß. Das hängt aber von der vom Hoster eingesetzten Virtualisierungsumgebung ab.
Ein Dist-Upgrade von Debian ist nicht so das Problem (habe ich schon mehrfach durchgeführt), aber was man da im Zusammenspiel mit Plesk beachten muß, kann ich nicht sagen (nutze kein Plesk).
 

spookie79

Member
Darf ich noch eine Frage stellen?
Habe nun Ubuntu 18 drauf mit einer frischen Installation und richte gerade alles mögliche ein.
Hatte bisher immer .htaccess Dateien 1x in jedem Verzeichnis drin. Nun aber bringen diese immer eine 500 Fehlermeldung. Ist die Datei weg, läuft die Seite. Hat sich da etwas geändert durch das neue Ubuntu? Plesk Onyx ist dasselbe wie vorher auch und auch auf dem neuesten Stand.
 

PHP-Friends

Blog Benutzer
verifizierter Anbieter
Ja, manche Direktiven sind leicht abweichend in neuen Apache-Versionen. Schau ins Error-Log des Webservers, der verrät dir normalerweise recht spezifisch, was das Problem ist. Wenn du dann "<Direktive> <Apache-Version>" googelst, solltest du die korrekte (neue) Syntax schnell finden :)
 

GwenDragon

Registered User
mod_access_compat zu aktivieren hilft manchmal auch bis die neuen Direktiven gelernt wurden. Sinnvoller wäre allerdings sich mit den neuen Konfigurationsdirektiven vertraut zu machen. Es kommt halt auch auf den Umfang der Konfigurationen an, die zu migrieren wären, inwieweit umgeschrieben werden sollte.
 

marce

Well-Known Member
Naja, Apache 2.2 ist seit 1.1.2018 EOL - wenn sich da jetzt immer noch nicht angepasste Konfigurationen irgendwo finden darf man nun gerne mal die Arbeit angehen und sich nicht auf irgendwelche Krücken für Kompatiblitätsgewürge verlassen...
 

marce

Well-Known Member
keine Ahnung, ob der TE noch Apache 2.2 verwendet (denke nicht) - aber es scheinen ja in der Config noch alte Direktiven drin zu sein (lt. Thread hier)

... und wenn man schon mal am basteln ist sollte man die gleich umsetzen - und nicht altes Zeugs mit irgendwelchen Kompatibilitätsplugins unnötig künstlich am Leben halten.
 

spookie79

Member
Warum kommen solch wichtige Sachen denn eigentlich nicht mit den apt-get updates/upgrades mit? Hat das eine Bewandtnis oder liegt das an Ubuntu selbst, dass die das noch nicht für ihre System freigegeben haben und man da in Probleme geraten könnte?
 

spookie79

Member
Na perfekt, dann passt ja, Danke. Wird doch langsam die Geschichte :)

Hab mal spasseshalber den Plesk Repair laufen lassen, der ja nun auch direkt im Plesk zu sehen ist. Dabei kam was hervor:
File not found: domain.de.conf - was genau vermisst er hier? Das zeigt er für alle Domains an, die als Website angelegt wurden (nicht als Alias oder Subdomain).

Und noch eine Meldung:
errorThe NS configuration file '/var/named/run-root/etc/named.conf' is absent.
failedRestoring the DNS configuration file '/var/named/run-root/etc/named.conf' filemng failed: filemng: Error occurred during /bin/cp command.
 

danton

Debian User
Ubuntu hat kein Rolling-Release-Model sondern hält bei den meisten Paketen die Versionsnummer - so auch bei Apache. Security-Fixes, die als solche deklariert sind, werden zurückportiert. Vorteil ist, dass dadurch bei Updates die Konfiguration ohne Anpassungen weiter verwendet werden kann. Nachteil ist, dass dabei auch Sicherheitslücken in älteren Versionen offen bleiben können, weil sie in neueren Versionen zwar geschlossen wurden, aber im Changelog nicht unbedingt als sicherheitsrelevant gekennzeichnet sind. Hier erfolgt halt kein Backport des jeweiligen Patches. Außerdem kann es passieren, dass ein Backport selber eine Sicherheitslücke erzeugt (recht promient war das vor ein paar Jahren Debian bei einem Backport eines Fixes für OpenSSL, der eine noch größere Lücke aufgerissen hatte).
Bezüglich der fehlenden Dateien: Das sieht nach einem Problem mit dem Nameserver aus. Verwendest du die DNS-Funltionen von Plesk? Falls nicht, dann die DNS-Funktionen im Plesk deaktivieren.
 
Top