Problem mit jails/syslog

Anzeige:
Hallo alle zusammen, ich habe da ein kleines Problemchen^^

Und zwar erstelle ich mir gerade ein freeBSD-System (mit Hilfe des Buches von Ben ;-)).

Ich habe nun mehrere Jails eingerichtet und habe in einer Jail einen Webserver und PHP konfiguriert.
Wenn ich PHP nun aber in der jail starten möchte, bekomme ich folgende Fehlermeldung:
Code:
ERROR: unable to bind listening socket for address 'XX.XX.XX.XX:PPPP': Address already in use (48)
(die X für eine IP, die Ps für den Port)

Ergo scheint noch ein anderer Dienst auf der IP zu lauschen, also mit netstat geschaut und folgenden Eintrag:
Code:
udp4       0      0 XX.XX.XX.XX.syslog        *.*

Demnach lauscht der "globale" Syslog vom Hostsystem weiterhin auch auf der IP Adresse und hat sich an die jail gebunden, richtig?

Das hatte ich eigentlich mit folgendem Wert in der rc.conf des Hostsystems unterbunden:
Code:
syslogd_flags="-ss -a 127.0.0.1 -C"
bzw.
Code:
syslogd_flags="-ss"

oder?

Was habe ich falsch gemacht, sieht jemand vielleicht etwas?^^

Vielen Dank!
 
Last edited by a moderator:

Ben.

Registered User
Welchen Port hast du für den FastCGI-Prozess gewählt?

Syslog krallt sich alle IP-Adressen, aber nicht alle Ports (hast du syslogd neugestartet nach der Änderung?).
 

Joe User

Zentrum der Macht
Nur mal so zum Verständnis für FreeBSD-Newbies wie mich:
Wieso kann sich der auf dem Host laufende syslogd überhaupt an einen Netzwerk-Socket innerhalb des Jail binden?
 

Ben.

Registered User
Der sich in der Jail befindliche syslogd bindet sich an an die lokale IP. Sonst nix.
 
Ja, ich hab sogar den ganzen Server nach der Änderung einfach mal rebootet, hat aber nichts gebracht.

Die Konfigurationsdatei, die an die php-fpm.conf angefügt wird lässt auf port 9000 horchen.
In der /usr/local/etc/php-fpm.conf habe ich den Wert bei listen auf dem default, also 127.0.0.1:9000 gelassen.

Gruß
 

Ben.

Registered User
Falls es möglich und dir recht ist, darfst du mir mal eine Email schicken mit den Zugangsdaten und Angaben zur Jail. Dann schaue ich mir das schnell an.
 

Ben.

Registered User
Zwei Punkte, aber nur einer ist relevant:

1. Du hast die syslogd-Flags nur auf dem Host gesetzt, nicht aber in der Jail. In der Jail ist das eigentlich egal bzw. hat nichts mit deinem Problem zu tun.

2. Du hast in der php-fpm.conf einen Standardpool definiert "[WWW]". Den habe ich jetzt deaktiviert. Dieser war bereits auf Port 9000 eingestellt. Dein "Custom-Pool" verwendete den gleichen Port => PHP-FPM startet den WWW-Pool, der nimmt sich die 9000, dann kommt deiner, der will auch die 9000 *bumm*

Ich habe nur deine php-fpm.conf in der Form abgeändert, dass ich die Parameter für den WWW-Pool deaktiviert habe. Jetzt läuft PHP.
 
Herzlichen Dank für deine schnelle Hilfe!

Dann kann ich mich die nächsten Tage weiter in dein literarisches Werk vertiefen ;-)))

Gruß
 

Ben.

Registered User
Mach das. Ich verrate dir aber nicht wie es ausgeht.

Falls du Fragen / Probleme hast, darfst du sie mir gerne stellen.
 
Anzeige:
Top