PHP Startup: Unable to load dynamic library



Mr.Check

New Member
Moin moin,

seit den jüngsten CentOS Updates (Centos 6.4) müllt mir mein Server das error-Log mit folgender Meldung zu:

PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib64/php/modules/module.so' - /usr/lib64/php/modules/module.so: cannot open shared object file: No such file or directory in Unknown on line 0

Richtig erkannt hat das System, dass es die Datei /usr/lib64/php/modules/module.so nicht gibt. Ich frage mich allerdings, was es mit dieser Datei auf sich hat und warum überhaupt danach gesucht wird. In der php.ini ist nichts dergleichen verlinkt.

Die Google-Suche hat auch nur einen Leidgenossen zum Vorschein gebracht, aber leider keine Lösung:

http://www.linuxquestions.org/questions/linux-software-2/php-error-after-update-4175455365/

Jemand eine Idee?
 
Das System lädt generell mehr als nur eine php.ini. Insbesonder der conf.d Ordner sowie evtl andere PHP.ini's sind noch vorhanden. Ein rekursiver grep nach dieser Datei im Ordner der php.ini (notfalls über phpinfo() auslesbar) sollte das Modul zutage bringen.

module.so klingt nach einer generischen Beschreibungszeile welche unbeabsichtigt aktiviert wurde.
 
Danke, manchmal sieht man einfach den Wald vor lauter Bäumen nicht.

Offensichtlich gibt es ein Problem mit dem php-mcrypt Paket im EPEL Repository. In der mcrypt.ini wird nämlich eine module.so geladen statt der mcrypt.so :rolleyes:

Kann geschlossen werden.
 
Back
Top