php 4.3.11

Status
Not open for further replies.
...

was mir gerade aufgefallen ist...

mein apache error_log ist 320 mb gross ist das normal???

kann daran die performance leiden?
 
Ich habe ein (kleines??) Problem beim Update auf PHP 4.3.11

Meine aktuell insatllierten Programme:

ii php4-common 4.3.11-0.dotde Common files for packages built from the php
ii php4-gd 4.3.11-0.dotde GD module for php4
ii php4-mysql 4.3.11-0.dotde MySQL module for php4
ii libapache-mod- 4.3.11-0.dotde server-side, HTML-embedded scripting languag
rc libapache2-mod 4.3.10-9 server-side, HTML-embedded scripting languag

libapache2-mod-php4 ist noch auf dem Stand 4.3.10

Der Versuch apt-get install libapache2-mod-php4 bringt aber folgendes Ergebniss:

Sorry, but the following packages have unmet dependencies:
libapache2-mod-php4: Depends: php4-common (= 4:4.3.10-9) but 4:4.3.11-0.dotdeb.0 is to be installed
E: Sorry, broken packages

Kann mir vielleicht jemand einen Tip geben was ich machen kann? Sieht so aus als wenn mein verwendeter Backport
deb http://packages.dotdeb.org ./
deb-src http://sources.dotdeb.org ./

das libapache2-mod-php4 in der Version 4.3.11 nicht zu Verfügung stellt. Oder liege ich da falsch?

edit: Auf http://packages.dotdeb.org/dists/woody/php4/ liegt nur ein libapache-mod-php4_4.3.11-0.dotdeb.0_i386.deb aber das ist ja für den Apache1.3. :confused:
 
Last edited by a moderator:
Wenn du PHP selbst kompilierst brauchst du libapache2-mod-php4 nicht.
 
Und wenn ich PHP nicht selbst kompileren will/kann, bleibt nur eines, darauf zu warten eine Quelle mit libapache2-mod-php4 zu finden oder?
 
...

logrotate ist normalerweise eingerichtet.

weiß nicht wieso das nicht läuft...


ein zwei mehr links zu tutorials wären nett...
 
...

ok das mit der größe des logs hab ich nun da auch die php notices default an sind in der neuen default config von php 4.3.11. also erledigt! *schäm*

eaccelerator habe ich installiert, und auch in der php.ini eingetragen den ganzen sappes der da notwendig ist. erst hat er zwar gemeckert, das er für 4.3.10 compiliert wäre weil ich damals schon tests damit gemacht habe... aber nach nem recompile startet apache nun auch mit den aktivierten sachen in der php.ini durch... aber es werden beim aufrufen von einer php seite keine temps in /tmp/eaccelerator angelegt.

wofür ich mich auch schämen sollte sind mein grundkenntnisse der ordner...

'./configure' '--prefix=/usr/share' '--datadir=/usr/share/php' '--bindir=/usr/bin' '--libdir=/usr/share' '--includedir=/usr/include' '--sysconfdir=/etc' '--with-_lib=lib' '--with-config-file-path=/etc' '--with-exec-dir=/usr/lib/php/bin' '--disable-debug' '--enable-bcmath' '--enable-calendar' '--enable-ctype' '--enable-dbase' '--enable-discard-path' '--enable-exif' '--enable-filepro' '--enable-force-cgi-redirect' '--enable-ftp' '--enable-gd-imgstrttf' '--enable-gd-native-ttf' '--enable-inline-optimization' '--enable-magic-quotes' '--enable-mbstr-enc-trans' '--enable-mbstring' '--enable-mbregex' '--enable-memory-limit' '--enable-safe-mode' '--enable-shmop' '--enable-sigchild' '--enable-sysvsem' '--enable-sysvshm' '--enable-track-vars' '--enable-trans-sid' '--enable-versioning' '--enable-wddx' '--enable-yp' '--with-bz2' '--with-dom=/usr/include/libxml2' '--with-ftp' '--with-gdbm' '--with-gettext' '--with-gmp' '--with-imap=yes' '--with-jpeg-dir=/usr' '--with-ldap=yes' '--with-mcal=/usr' '--with-mcrypt' '--with-mhash' '--with-mysql=/usr' '--with-ndbm' '--with-pgsql=/usr' '--with-png-dir=/usr' '--with-readline' '--with-snmp' '--with-t1lib' '--with-tiff-dir=/usr' '--with-ttf' '--with-freetype-dir=yes' '--with-xml' '--with-xpm-dir=/usr/X11R6' '--with-zlib=yes' '--with-qtdom=/usr/lib/qt3' '--with-qt-includes=/usr/lib/qt3/include' '--with-qt-libraries=/usr/lib/qt3/lib' '--with-gd' '--with-openssl' '--with-curl' '--with-swf=/usr/src/packages/BUILD/swf/dist/' '--with-imap-ssl' '--enable-xslt' '--with-xslt-sablot' '--with-iconv' '--enable-eaccelerator=shared' '--with-php-config=/usr/bin/php-config' '--with-apxs2=/usr/sbin/apxs2-prefork' 'i586-suse-linux'

bei diesem compile string und wenn der php configure aus dem ordner /usr/share/php4.3.11 ausgeführt wird ist dann die einstellung für eaccelerator so richtig:

export PHP_PREFIX="/usr"
$PHP_PREFIX/bin/phpize
./configure --enable-eaccelerator=shared --with-php-config=$PHP_PREFIX/bin/php-config

und vor allem zu welcher .so muß ich verlinken?

:/etc # locate eaccelerator.so
/usr/share/eaccelerator/.libs/eaccelerator.so
/usr/share/eaccelerator/modules/eaccelerator.so
/usr/share/extensions/no-debug-non-zts-20020429/eaccelerator.so

also wie ihr seht bin ich kein held, aber auch nicht allzu doof :)

danke wiedermal :eek:
 
Problem gelöst

jaja so sit das.

habe soeben erfahren das einer der nameserver bei s4y, jener mit xxx.xxx.166.xxx einen fehler hat...

habe darauf hin die reihenfolge getauscht und schwups habe ich wider meine 0.28 sec und so wieder...

fazit: meine kiste erfreut mich wieder :)

so jetzt habe ich nur noch das problem das sich den eaccelerator nicht recompiliert bekomme...

bitte nochmal hier eine anleitung dazu...

make clean und make distclean bracht irgendwie keine hilfe, bekomme ich " This version hast been compiled for php 4.3.10 plz recompile it."

./configure
make clean
./configure
make
make install

brachte es leider nicht...
 
Status
Not open for further replies.
Back
Top