OpenVPN aus OpenVPN repositories installieren funktioniert nicht

3df

Registered User
Hallo zusammen,

ich möchte die aktuelle Version von OpenVPN installieren und habe mich dazu an diese Anleitung gewandt: https://community.openvpn.net/openvpn/wiki/OpenvpnSoftwareRepos

Ich habe alles beachtet und damit der Eintrag der sources.list hinzugefügt wird, habe ich diesen Befehl ausgeführt:
Code:
echo "deb http://build.openvpn.net/debian/openvpn/stable jessie main" > /etc/apt/sources.list.d/openvpn-aptrepo.list
Wenn ich nun "apt-get update && apt-get install openvpn" ausführe, dann kommt es am Ende zu dieser Meldung:
Code:
W: Fehlschlag beim Holen von http://build.openvpn.net/debian/openvpn/stable/dists/jessie/InRelease  Erwarteter Eintrag »main/binary-armhf/Packages« konnte in Release-Datei nicht gefunden werden (falscher Eintrag in sources.list oder missgebildete Datei).

E: Einige Indexdateien konnten nicht heruntergeladen werden. Sie wurden ignoriert oder alte an ihrer Stelle benutzt.
Installiert ist Debian 8.0

Wo ist hier das Problem?

Danke sehr!
 

nexus

Active Member
Poste mal die Ausgaben von:
Code:
dpkg --print-architecture
dpkg --print-foreign-architectures
 

3df

Registered User
Hm, mit "apt-get install openvpn" wir OpenVPN ja auch auf dem Raspi installiert und funktioniert auch, allerdings wird nicht die neuste Version installiert. Und diese benötige ich damit ich diesen "block-outside-dns" Parameter in der .conf nutzen kann. Dies geht aber erst ab Version 2.4.xx

http://www.pivpn.io/ scheint nicht zu funktionieren weil ich damit nicht die config für OpenVPN von meinem VPN-Anbieter nutzen kann. Der Pi soll sich ja mit meinen VPN-Server verbinden. Ich möchte ja keinen VPN-Server mit dem Pi aufbauen.
 
Last edited:

danton

Debian User
Das Repository vom OpenVPN-Projekt hat laut deren Seite nur Pakete für die Prozessor-Architekturen i386 und amd64 (also die normalen PC-Prozessoren in 32 und 64bit). Entsprechend sind natürlich auch keine Einträge für andere Architekturen im Release-File enthalten, was die Fehlermeldung auch exakt beschreibt. Entweder das Paket aus dem Debian-Repo nehmen oder selber kompilieren.
Allerdings verstehe ich auch nicht, was du mit dem Parameter "block-outside-dns" erreichen willst. Der bringt dir auf dem RasPi sowieso nichts, da er eine Eigenart von Windows blockt und auch nur unter Windows-Clients ab Vista verfügbar ist.
 

3df

Registered User
Hallo, das der Parameter block-outside-dns nur für Windows ist, habe ich mittlerweile auch rausgefunden. Aber meine DNS vom ISP wird geleakt wenn ich mich mit meinem VPN Server verbinde.
 

danton

Debian User
Dafür sollte es aber meiner Meinung nach ausreichen, auf der Windows-Seite einen 2.4er OpenVPN-Client einzusetzen und den Parameter in dort in die Client-Config zu packen.
 

danton

Debian User
Aber das DNS-Leaking ist eigentlich ein Windows-Problem. Unter Linux sollte es ausreichen, die resolv.conf entsprechend anzupassen.
 

3df

Registered User
Hast Du einen Tipp was ich da anpassen muss? Mein VPN-Anbieter stellt seinen eigenen DNS zur verfügung
 

danton

Debian User
Ernsthaft? In der resolv.conf sollten, solange die VPN-Verbindung besteht, nur die IPs der DNS-Server deines VPN-Anbieters drin stehen und wenn sie nicht besteht, die deines Internet-Providers oder alternativ die von Google oder Cloudflare. Sofern du noch Systeme hinter deinem RasPi betreibst, die den VPN-Tunnel mitnutzen, wird es natürlich aufwendiger, da diese Systeme auch berücksichtigt werden müssen.
 

3df

Registered User
Was ernsthaft? Es stehen eben nicht die DNS-Server meines VPN-Anbieters in der resolv.conf, sondern die meines ISP.

Die öffentliche IP hingegen ist dann von meinem VPN-Anbieter und nicht die von meinem ISP.

Edit:

Wenn ich das hier aktiviere:
Code:
Sicherer DNS-Server während der Verbindung - am Beispiel Ubuntu
1) aptitude install resolvconf
2) in /etc/openvpn/client.conf folgende Einträge hinzufügen:
up /etc/openvpn/update-resolv-conf
down /etc/openvpn/update-resolv-conf
# das Skript update-resolv-conf ist beim openvpn-paket für ubuntu dabei
3) ggf. Kontrolle der /etc/resolv.conf im laufenden Betrieb ob DNS Server eingetragen sind:
#$ cat /etc/resolv.conf
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
# DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 134.108.34.5
nameserver 134.108.34.6
nameserver 192.168.43.1
search hs-esslingen.de
#$
Ich habe also
Code:
up /etc/openvpn/update-resolv-conf
down /etc/openvpn/update-resolv-conf
Meiner /etc/openvpn/VPN.conf hinzugefügt.

Aber dann startet OpenVPN nicht:
Code:
May  6 09:39:22 raspberrypi ovpn-VPN[987]: WARNING: External program may not be called unless '--script-security 2' or higher is enabled. See --help text or man page for detailed info.
May  6 09:39:22 raspberrypi ovpn-VPN[987]: WARNING: Failed running command (--up/--down): external program fork failed
May  6 09:39:22 raspberrypi ovpn-VPN[987]: Exiting due to fatal error
May  6 09:39:22 raspberrypi systemd[1]: openvpn@VPN.service: Main process exited, code=exited, status=1/FAILURE
May  6 09:39:22 raspberrypi systemd[1]: openvpn@VPN.service: Unit entered failed state.
May  6 09:39:22 raspberrypi systemd[1]: openvpn@VPN.service: Failed with result 'exit-code'.
Edit:
Nun funktioniert es. Ich musste in der VPN.conf noch diesen Eintrag hinzufügen:
Code:
script-security 2
 
Last edited:

DeaD_EyE

Blog Benutzer
Er meint, dass du dich darum kümmern musst, was in der resolv.conf drin steht.
Vielleicht schreibt OpenVPN automatisch den DNS-Server in die resolv.conf und falls das der Fall ist, wird es auch in der Dokumentation drin stehen und wenn das nicht der Fall ist, wird das auch in der Doku stehen.

Nur Vollständigkeitshalber: Du kannst auch auch deine eigenen Pakete aus den Quellen bauen oder halt auf inoffizielle fremde respositories zugreifen und hoffen, dass der Betreiber keinen Mist baut.
 

Top