mod_rewrite läasst sich nicht aktiviren?

Ok das leuschtet ein , hier bitte der inhalt t zu lang , deshalb hänge ich sie mal mit an?

Danke
 

Attachments

  • error_log.zip
    11 KB · Views: 74
Shorty said:
hier bitte der inhalt t zu lang , deshalb hänge ich sie mal mit an?
Bisserl gezielter zu arbeiten bitte.
Ich hab keine Lust mich durch ewig lange Logfiles zu hangeln. Das ist Dein Job.
Diese Zeile reicht bereits:
Code:
[Tue Mar 28 11:59:49 2006] [error] [client 68.142.251.105] Options FollowSymLinks or SymLinksIfOwnerMatch is off which implies that RewriteRule directive is forbidden: /srv/www/web1/html/archive/615
Und die hast Du bestimmt auch selber gesehen.
Und wenn Du das mit o.g. httpd-Spezial vergleichst, siehst Du auch wo der Fehler ist.
Kleiner Tipp: Schau aufs Directory!

huschi.
 
Endschuldigung hätte ich gerne gemacht wenn ich irgendwoher gewusst hätte wonach ich suchen muss?

Ich habe leider nicht soviel ahnung aber mit jedem Teil was ich hier erklärt bekomme werde auch ich schlauer.;)

Ich habe nun das httpd Spezial im Admin Confixx für den Kunden in:
<Directory "/srv/www/web1/html/archive/615">
AllowOverride All
Options +FollowSymlinks
</Directory>
geändert , das hat nichts gebracht , dann habe ich in der error_log das:
/srv/www/web1/html/archive/615
in:
/srv/www/htdocs/##user##/html/
geändert , aber auch ohne erfolg?

Gruss
 
Last edited by a moderator:
Shorty said:
Endschuldigung hätte ich gerne gemacht wenn ich irgendwoher gewusst hätte wonach ich suchen muss?
Nach dem, was oben schon stand und Du es auch schon gemacht hattest: "rewrite"
<Directory "/srv/www/web1/html/archive/615">
Fast richtig. Du hättest lediglich den 'htdocs' Teil rauslöschen müssen.

Hast Du denn danach lang genug gewartet? (prüfe die Datei confixx_vhost.conf)
Was für Fehler kommen jetzt im error_log?

dann habe ich in der error_log das:
Was erhoffst Du Dir von einer Änderung im Logfile?

huschi.
 
Aber woher hätte ich wissen sollen das es genau diese zeile ist , die ich suchen soll?

Ich habe nun in httpd Spezial das:
php_admin_value register_globals 1
php_admin_flag safe_mode Off
<Directory "/srv/www/web1/html/archive/615">
AllowOverride All
Options +FollowSymlinks
</Directory>
eingetragen aber ohne erfolg?

Was mir gerade einfällt , ich habe es beim letzen mal im Admin Confixx bei httpd Spezial unter Domäne eingetragen und diesmal unter Kunde.Weil ich nicht mehr weiss wie ich das damals eingerichtet habe , ich denke das es daran liegt , können sie mir sagen wie ich da eine Domäne zuordnen kann?

Gruss
 
Kurze Wiederholung des Sprachgebrauchs:
Fragezeichen markieren eine Frage.
Auf Fragen sollten Antworten folgen.
Bleiben die Antworten aus, kann ich nicht weiter helfen.

huschi.
 
Huschi said:
Fast richtig. Du hättest lediglich den 'htdocs' Teil rauslöschen müssen.

Hast Du denn danach lang genug gewartet? (prüfe die Datei confixx_vhost.conf)
Was für Fehler kommen jetzt im error_log?


Was erhoffst Du Dir von einer Änderung im Logfile?

huschi.

Ich habe nun im Admin Confixx im http Spezial das :

<Directory "/srv/www/##user##/html/">


In der Confixx_vhost.conf steht nun das:

#### CONFIXX APACHE VHOST FILE ####
### created Tue Mar 28 16:52:02 2006 ###

NameVirtualHost 62.75.219.180:80
php_admin_flag safe_mode On
php_admin_value safe_mode_exec_dir /srv/www/empty

UseCanonicalName Off
LogFormat "%V:#:%h %l %u %t \"%r\" %s %b \"%{Referer}i\" \"%{User-agent}i\"" confixx
LogFormat "%h %l %u %t \"%r\" %s %b \"%{Referer}i\" \"%{User-agent}i\"" confixx2
CustomLog |/usr/local/confixx/pipelog.pl confixx
<Directory "/srv/www">
<Files ~ "^\.ht">
deny from all
</Files>
AllowOverride None
AllowOverride Indexes AuthConfig Limit FileInfo
Options None
Options -FollowSymLinks -SymLinksIfOwnerMatch +Includes
</Directory>


<VirtualHost 62.75.219.180:80>
ServerName 62.75.219.180
DocumentRoot /srv/www/confixx/html/gesperrt
</VirtualHost>
<VirtualHost 62.75.219.180:80>
ServerName wbb-support.de
ServerAlias www.wbb-support.de web1.fulda179.server4you.de
DocumentRoot /srv/www/web1/html
SuexecUserGroup web1 ftponly
ScriptAlias /cgi-bin/ /srv/www/web1/html/cgi-bin/
php_admin_value open_basedir /srv/www/web1/:/srv/www/htdocs/phpMyAdmin/:/srv/www/htdocs/confixx/html/gesperrt/
php_admin_value upload_tmp_dir /srv/www/web1/phptmp/
php_admin_value register_globals 1
php_admin_flag safe_mode Off
<Directory "/srv/www/htdocs/web1/html/">
AllowOverride All
Options +FollowSymlinks
</Directory>
</VirtualHost>


Im error_log kommt jetzt:

/srv/www/web1/html/archive/index.html, referer: http://www.wbb-support.de/hmportal.php
 
Im error_log kommt jetzt:
Was? file not found, oder was steht links davor?

Hast du die rewriteLog analysiert (die du zuvor aktivieren musst, vgl. Direktiven RewritelogLevel und RewriteLog)?

Warum fügst du die (ggf. angepassten) RewriteRules nicht direkt unter httpd spezial ein? .htaccess-Dateien sind ineffizient.

AllowOverride All
Genau das sollte man eigentlich vermeiden, bei Zugriff auf die Serverkonfiguration. When (not) to use .htaccess files
 
Rob said:
Warum fügst du die (ggf. angepassten) RewriteRules nicht direkt unter httpd spezial ein? .htaccess-Dateien sind ineffizient.

Genau das sollte man eigentlich vermeiden, bei Zugriff auf die Serverkonfiguration. When (not) to use .htaccess files

Das verstehe ich nicht , was meinst du genau damit?

Sorry das ist die ganze Zeile aus der error_log:

[Tue Mar 28 00:15:48 2006] [error] [client 84.174.83.183] Options FollowSymLinks or SymLinksIfOwnerMatch is off which implies that RewriteRule directive is forbidden: /srv/www/web1/html/archive/index.html, referer: http://www.wbb-support.de/hmportal.php?sid=
 
Poste mal den Inhalt deiner .htaccess-Datei und wo (in welchem ordner) diese liegt. Dann kann ich dir sagen, was du da ändern musst, um die RewriteRules direkt unter httpd spezial einfügen zu können.
 
Rob said:
Poste mal den Inhalt deiner .htaccess-Datei und wo (in welchem ordner) diese liegt. Dann kann ich dir sagen, was du da ändern musst, um die RewriteRules direkt unter httpd spezial einfügen zu können.


Meinst du die von meinem Archive oder von dem Server?

Wenn die vom Server gemeint ist , weiss ich nicht wo ich suchen soll?
 
Ah ok hier bitte der inhalt der Datei:

RewriteEngine On
RewriteBase /archive
RewriteRule ^index\.html$ index.php [L]
RewriteRule ^([0-9]*)/board\.html$ board.php?boardid=$1 [L]
RewriteRule ^([0-9]*)/([0-9]*)/board\.html$ board.php?boardid=$1&page=$2 [L]
RewriteRule ^([0-9]*)/thread\.html$ thread.php?threadid=$1 [L]
RewriteRule ^([0-9]*)/([0-9]*)/thread\.html$ thread.php?threadid=$1&page=$2 [L]
 
Und ich wiederhol mich schon wieder:
Shorty said:
<Directory "/srv/www/htdocs/web1/html/">
...
/srv/www/web1/html/archive/index.html
Solange das erste Verzeichnis kein Teil des Zweiten ist, wird es bei der Fehlermeldung bleiben.

huschi.
 
Huschi said:
Und ich wiederhol mich schon wieder:

Solange das erste Verzeichnis kein Teil des Zweiten ist, wird es bei der Fehlermeldung bleiben.

huschi.


Sorry ich möchte euch echt nicht auf die nerven gehen , aber wenn ihr es mal so erklären würdet das es ein leihe auch versteht wäre uns allen geholfen.;)

Ich habe es nun so eingetragen:

<Directory "/srv/www/##user##/html/archive/index.html">
AllowOverride All
Options +FollowSymlinks
</Directory>

Dieser Teil wäre deine änderung:

<Directory "/srv/www/##user##/html/archive/index.html">

Aber es geht immer noch nicht?
 
Shorty said:
aber wenn ihr es mal so erklären würdet das es ein leihe auch versteht wäre uns allen geholfen.;)
Wenn Du es mal so verstehen würdest, wie ich es beschreibe, wäre das Thema bereits nach meiner ersten Antwort gegessen gewesen.

Dieser Teil wäre deine änderung:
<Directory "/srv/www/##user##/html/archive/index.html">
Falsch!
Meine Änderung sagte die ganze Zeit nur: "/srv/www/web1/html"
Nicht mehr nicht weniger. Denk mal drüber nach und versteh es endlich.
Und ich hasse es, alles vorkauen zu müssen.

huschi.
 
:eek: Was ist den das für eine art mit den Usern umzugehen?

Ich habe mehr wie einmal geschrieben das ich ein newbie in der sache bin , da muss man sich darauf einstellen und die sache ein wenig genauer erklären dann hättest du auch nicht so viel arbeit?

Aber einfach eine änderung in den raum stellen und dann denken so sehe zu wie du das hinbekommst , ist ja wohl herb?

Ist es den zuviel den genauen Code zu Posten der da eingeben werden soll?

Sorry ich möchte niemanden auf den schlipps tretten , aber ich muss mir auch nicht alles gefallen lasen.;)

Gruss
 
Shorty said:
:eek: Was ist den das für eine art mit den Usern umzugehen?
Sehe es mal von einem anderen Standpunkt:
Wir versuchen hier wirklich jedem (ohne Ausnahme) wirklich kostenlos zu helfen.
Wenn der Hilfesuchende nicht wirklich mitmacht (habe Thread nicht wirklich gelesen, kann ich nicht beurteilen), dann gestaltet sich Helfen auch eher schlecht.

Maul einfach nicht so rum. Wir sind auch nur Menschen.
Bei deinem Provider zahlst du ca. 50€ für einen Techniker, der dir das richtet.

Keep chillin
 
Ja ich weiss das ihr auch nur menschen seid und das ihr schon euer bestes gebt , ich will hier ja auch nichts vom Zaun brechen.

Nur ich verstehe die anweissungen einfach so , wie ihr sie ausgebt nicht weil ich von der Materie keine ahnung habe.Ich will es ja Verstehen aber es ist zu eckig für meinen runden Kopf und deshalb denke ich ist es auch ein wenig verständlich das es etwas genauer für einen leihen erklärt werden sollte?
 
Direkt unter httpd spezial eingefügt müsste dann folgendes im per-server conntext funktionieren

Code:
RewriteEngine On
RewriteRule ^/archive/index\.html$ /archive/index.php [L]
RewriteRule ^/archive/([0-9]*)/board\.html$ /archive/board.php?boardid=$1 [L]
RewriteRule ^/archive/([0-9]*)/([0-9]*)/board\.html$ /archive/board.php?boardid=$1&page=$2 [L]
RewriteRule ^/archive/([0-9]*)/thread\.html$ /archive/thread.php?threadid=$1 [L]
RewriteRule ^/archive/([0-9]*)/([0-9]*)/thread\.html$ /archive/thread.php?threadid=$1&page=$2 [L]

unter der Voraussetzung dein URL-Aufruf ist /archive/index.html und geladen werden soll /archive/index.php

Der per-server conntext ist .htaccess-Dateien definitiv vorzuziehen.
 
Back
Top