Hetzner Server langsame SSD

A

andreas0

Guest
Die waren dauerhaft gestartet, ja.
Die sind aber alle im idle und erzeugen jeweils nicht mehr als ein paar hundert kb/s.

Um Seiteneffekte auszuschließen solltest du die Schreibgeschwindigkeit der beiden SSDs nochmal untersuchen, wenn die VMs komplett heruntergefahren sind. Denn die VMs verhalten sich auf deinem System wie eigene Prozesse, um die sich dein System während der Tests auch kümmern muß.
 

Vengance

Member
Ich habe das nun mit und ohne gestartete VMs getestet und beides mal Werte von rund 370MB/s bekommen.
Ich werde mal beobachten wie sich das weiter verhält, denn bisher ist die Geschwindigkeit nach kurzer Zeit dann wieder gesunken.
 

PHP-Friends

Blog Benutzer
verifizierter Anbieter
Code:
root@pve ~ #  hdparm -Tt /dev/sda

/dev/sda:
 Timing cached reads:   30394 MB in  2.00 seconds = 15213.22 MB/sec
 Timing buffered disk reads: 1310 MB in  3.00 seconds = 436.21 MB/sec
root@pve ~ # hdparm -Tt /dev/sdb

/dev/sdb:
 Timing cached reads:   30606 MB in  2.00 seconds = 15320.33 MB/sec
 Timing buffered disk reads: 1136 MB in  3.00 seconds = 378.12 MB/sec

Interessant(er) wären die Werte mit --direct, aber grundsätzlich weicht die zweite SSD schon deutlich von der ersten ab. Schau mal in deine dmesg-Ausgabe bzw. ins Log, ob sie ggf. an einem falschen SATA-Port hängt. Vielleicht kann Hetzner sie auch auf Kulanz tauschen.

Code:
cat /proc/mdstat
Personalities : [raid1] [linear] [multipath] [raid0] [raid6] [raid5] [raid4] [raid10]
md1 : active raid1 sda2[0] sdb2[1]
      249401664 blocks super 1.2 [2/2] [UU]
      bitmap: 1/2 pages [4KB], 65536KB chunk

Ein write-intent bitmap geht immer etwas auf die Performance. Du könntest es testweise mal entfernen. Bei SSDs sind die Rebuildzeiten ohnehin so kurz, dass sich in der Praxis meist kein großer Vorteil ergibt.


Viele Grüße
Tim
 
Top