• This forum has a zero tolerance policy regarding spam. If you register here to publish advertising, your user account will be deleted without further questions.

Cs1.6 Server Auf Root! Mega Problem!!!!

Cry0x

Registered User
Cs1.6 Server Auf Root

Hallo,

ich habe einen Linux Root-Server und wollte dort CS1.6 installieren!

Es ging acuh erst aber immer wenn ich den server starten will, komm das hier:

Console initialized.
scandir failed:/home/hlds/hlds/./platform/SAVE
Protocol version 47
Exe version 1.1.2.5/Stdio (cstrike)
Exe build: 13:45:30 Nov 24 2005 (3318)
STEAM Auth Server
couldn't exec language.cfg
WARNING: UDP_OpenSocket: port: 27015 bind: Address already in use
FATAL ERROR (shutting down): Couldn't allocate dedicated server IP port 27015.
Add "-debug" to the ./hlds_run command line to generate a debug.log to help with solving this problem


Bitte helft mir!

MfG Pent!
 
Last edited by a moderator:
Cry0x said:
WARNING: UDP_OpenSocket: port: 27015 bind: Address already in use
MfG Pent!
Da steht doch schon das Problem.

Du musst einen anderen Port zuweisen. Nutze in deinem Startbefehl einfach mal folgende Zeile:
Code:
-port 27018

Dann müsstes du deinen Servr unter deiner Root-IP und dem Port 27018 finden.
 
also:

wenn ich den befehl mit 27019 eingebe steht das da:

[1] 8413
hlds@84-16-224-206:~/hlds$ Using Pentium II Optimised binary.
Auto-restarting the server on crash

Console initialized.
scandir failed:/home/hlds/hlds/./platform/SAVE
Protocol version 47
Exe version 1.1.2.0/Stdio (valve)
Exe build: 13:45:30 Nov 24 2005 (3318)
STEAM Auth Server
couldn't exec language.cfg
Server IP address 84.16.224.206:27019
map change failed: 'de_dust' not found on server.

couldn't exec listip.cfg
couldn't exec banned.cfg

wenn ich den dann nochmal eingebe dann steht wieder da dass der port schon benutzt!
 
Und wieder stehen die Fehler ganz ausdrücklich dort:
map change failed: 'de_dust' not found on server.

couldn't exec listip.cfg
couldn't exec banned.cfg

de_dust kennt er nicht
listip.cfg und banned.cfg gibts nicht...

Dann empfehle ich dir noch ein: ps aux | grep hlds_run
Und dann die Pids killen die dir ausgegeben werden (mit kill -9 PID)
 
lol?!

Welche Pids da kommen voll viele!

hlds@84-16-224-206:~$ kill -2481 PID
-sh: kill: 2481: invalid signal specification


sowas steht da wenn ich me irgendeins löschen will!
 
Also erstmal hoi :)
couldn't exec listip.cfg
couldn't exec banned.cfg

Diese zwei sind völlig normal und haben nichts (schlechtes) zu bedeuten.

Zum anderen Fehler, wie hast du denn den Cs_Server installiert? Wird wohl irgendwie ein Fehler unterloffn sein.
Ich kill den HLDS Prozess immer so;
"top"
dann die entsprechende PID des von "hlds_run" raussuchn und dann
kill -9 "diepid"
dann isser weg vom Fenster ;)
mfg
 
Aber da steht kein port 27015,weder 27016 oder sonst was mit 27!

was is das denn?!

das regt mich voll auf!
 
Code:
ps aux | grep hlds_run

dann alle hlds Prozesse killen

Code:
kill -9 PID

Nun solte auch der Port 27015 frei sein. Das kannste nachgucken mit
Code:
netstat -l

da darf nicht stehen:
Code:
udp        0      0 *:27015         *:*        8379/hlds_amd

sonst kill -9 ...

Nun solltest du dir noch mal hlds neuinstallieren "rm -rf hlds" und dann die Anleitung von http://www.counter-strike.de/content/server/linux_steam.php durchlesen und befolgen.

Nebenbei:
couldn't exec listip.cfg
couldn't exec banned.cfg

ist normal. Solange du keinen User gebannt hast, existieren diese Dateien nicht.

MfG, h00ch
 
Infos wie du deinen Server richtig einrichtest gibts wie Sand am Meer.
Bei Fehlermeldungen hilft oft diese einfach bei Google einzugeben.

Ich hab das mal für dich getan und folgende Seite gefunden die schön bei solchen Problem hilft:
http://www.forumplanet.com/counterstrike/topic.asp?fid=4955&tid=1572730

Sollten dich die Meldungen bzgl. der nicht exisiterenden language.cfg etc. stören (obwohl nicht nötig). mach einfach ein 'touch <filename>' und erzeuge so eine leere Datei mit dem entsprechenden Namen.
Das beendet dann das HLDS Gemecker.
 
Hallo hab das problem auch

nur das ich jetzt kein benutztername root hab sondern ein anderes und kann nicht mehr neustarten >.<
Normaleweiße habe ich das mit neustart behoben.

okay also

mit rcon shutdownserver habe ich CS-Server down gemacht

dann habe ich wie immer mit
nohup ./hlds_run -game cstrike +maxplayers 18 +map fy_pool_day mein cs-server gestartet. So server taucht nicht auf o_O hab ihn mit "top" gekillt, aber tauchte ab und zu mal auf.

dann habe ich das ohne nohup gemacht um zu sehen was der fehler ist. Das gleiche mit Port.

Dann habe ich das gemacht was halt hier in Threads stand mit:

ps aux | grep hlds_run

Ich hab da was gemerkt jedes mal wenn ich dsa eingebe kommt da neue zahlen.

guckst du:

Code:
***@bravo9:~> ps aux | grep hlds_run
***     11320  0.0  0.0   2752   748 pts/0    S+   13:04   0:00 grep hlds_run
***@bravo9:~> ps aux | grep hlds_run
***     11322  0.0  0.0   2756   752 pts/0    S+   13:04   0:00 grep hlds_run
***@bravo:~> ps aux | grep hlds_run
***     11324  0.0  0.0   2756   752 pts/0    S+   13:04   0:00 grep hlds_run
***@bravo9:~> ps aux | grep hlds_run
***     11326  0.0  0.0   2756   752 pts/0    S+   13:04   0:00 grep hlds_run
***@bravo9:~> ps aux | grep hlds_run
***     11328  0.0  0.0   2756   752 pts/0    S+   13:04   0:00 grep hlds_run
***@bravo9:~> ps aux | grep hlds_run
***     11330  0.0  0.0   2752   752 pts/0    S+   13:04   0:00 grep hlds_run
***@bravo9:~> ps aux | grep hlds_run
***     11332  0.0  0.0   2756   752 pts/0    S+   13:04   0:00 grep hlds_run
***@bravo9:~> ps aux | grep hlds_run
***     11334  0.0  0.0   2752   748 pts/0    R+   13:04   0:00 grep hlds_run

was nun?

Code:
Aktive Internetverbindungen (Nur Server)
Proto Recv-Q Send-Q Local Address           Foreign Address         State
tcp        0      0 *:mysql                 *:*                     LISTEN
tcp        0      0 *:ftp                   *:*                     LISTEN
tcp        0      0 *:smtp                  *:*                     LISTEN
tcp        0      0 *:imaps                 *:*                     LISTEN
tcp        0      0 *:pop3s                 *:*                     LISTEN
tcp        0      0 *:pop3                  *:*                     LISTEN
tcp        0      0 *:imap                  *:*                     LISTEN
tcp        0      0 *:www-http              *:*                     LISTEN
tcp        0      0 *:ssh                   *:*                     LISTEN
tcp        0      0 *:smtp                  *:*                     LISTEN
udp        0      0 *:27015                 *:*
udp      284      0 bravo9.server4y:26900 *:*


EDIT: lol aber bei "top" habe u gedrückt und mein benutztername geschrieben..... Da tauchte plötzlich hlds_run prozess ....ansonsten hat man den nicht gesehen. Nun konnte ich es entgültig killen.. danke trotzdem =)
 
Last edited by a moderator:
Back
Top