• This forum has a zero tolerance policy regarding spam. If you register here to publish advertising, your user account will be deleted without further questions.

Apache schmiert mit SENDIG SIGTERM ab

Shrek

Registered User
Moin,

ich habe auf einem Server das Problem, das sich mein Apache in unregelmäßigen Abständen mit lauter Meldungen ála:

Code:
[Fri Oct 07 06:15:24 2005] [warn] child process 18539 still did not exit, sending a SIGTERM
[Fri Oct 07 06:15:24 2005] [warn] child process 18489 still did not exit, sending a SIGTERM
[Fri Oct 07 06:15:24 2005] [warn] child process 7904 still did not exit, sending a SIGTERM
[Fri Oct 07 06:15:24 2005] [warn] child process 7465 still did not exit, sending a SIGTERM
[Fri Oct 07 06:15:24 2005] [warn] child process 7398 still did not exit, sending a SIGTERM
[Fri Oct 07 06:15:24 2005] [warn] child process 7920 still did not exit, sending a SIGTERM
[Fri Oct 07 06:15:24 2005] [warn] child process 7921 still did not exit, sending a SIGTERM
[Fri Oct 07 06:15:24 2005] [warn] child process 27690 still did not exit, sending a SIGTERM
[Fri Oct 07 06:15:24 2005] [warn] child process 493 still did not exit, sending a SIGTERM
[Fri Oct 07 06:15:24 2005] [warn] child process 417 still did not exit, sending a SIGTERM
[Fri Oct 07 06:15:24 2005] [warn] child process 29294 still did not exit, sending a SIGTERM
[Fri Oct 07 06:15:24 2005] [warn] child process 30714 still did not exit, sending a SIGTERM
[Fri Oct 07 06:15:24 2005] [warn] child process 30262 still did not exit, sending a SIGTERM
[Fri Oct 07 06:15:24 2005] [warn] child process 7922 still did not exit, sending a SIGTERM
[Fri Oct 07 06:15:24 2005] [warn] child process 7935 still did not exit, sending a SIGTERM
[Fri Oct 07 06:15:24 2005] [warn] child process 31230 still did not exit, sending a SIGTERM
[Fri Oct 07 06:15:24 2005] [warn] child process 670 still did not exit, sending a SIGTERM
[Fri Oct 07 06:15:24 2005] [warn] child process 30757 still did not exit, sending a SIGTERM
[Fri Oct 07 06:15:24 2005] [warn] child process 8341 still did not exit, sending a SIGTERM
[Fri Oct 07 06:15:24 2005] [warn] child process 8077 still did not exit, sending a SIGTERM
[Fri Oct 07 06:15:24 2005] [warn] child process 8342 still did not exit, sending a SIGTERM
[Fri Oct 07 06:15:24 2005] [warn] child process 30831 still did not exit, sending a SIGTERM
[Fri Oct 07 06:15:24 2005] [warn] child process 7939 still did not exit, sending a SIGTERM
[Fri Oct 07 06:15:24 2005] [warn] child process 8244 still did not exit, sending a SIGTERM
[Fri Oct 07 06:15:24 2005] [warn] child process 31029 still did not exit, sending a SIGTERM
[Fri Oct 07 06:15:24 2005] [warn] child process 7952 still did not exit, sending a SIGTERM
[Fri Oct 07 06:15:24 2005] [warn] child process 30933 still did not exit, sending a SIGTERM
[Fri Oct 07 06:15:24 2005] [warn] child process 32485 still did not exit, sending a SIGTERM
[Fri Oct 07 06:15:24 2005] [warn] child process 8351 still did not exit, sending a SIGTERM
[Fri Oct 07 06:15:24 2005] [warn] child process 29789 still did not exit, sending a SIGTERM
[Fri Oct 07 06:15:24 2005] [warn] child process 11819 still did not exit, sending a SIGTERM
[Fri Oct 07 06:15:24 2005] [warn] child process 9220 still did not exit, sending a SIGTERM
[Fri Oct 07 06:15:24 2005] [warn] child process 31608 still did not exit, sending a SIGTERM
[Fri Oct 07 06:15:24 2005] [warn] child process 7982 still did not exit, sending a SIGTERM
[Fri Oct 07 06:15:24 2005] [warn] child process 8886 still did not exit, sending a SIGTERM
[Fri Oct 07 06:15:24 2005] [warn] child process 495 still did not exit, sending a SIGTERM
[Fri Oct 07 06:15:24 2005] [warn] child process 7130 still did not exit, sending a SIGTERM

Ein Amoklaufendes CGI Script kann ich ausschließen.
Ich weiß nicht mehr, woran das liegen könnte.

Da ich diese Meldungen jetzt schon öfter bei verschiedenen Leuten gelesen habe, vermute ich mal, das es ein Bug in der Software zusammenstellung ist:

Suse 9.2
Apache2.0.50
PHP 4.3.8
Confixx 3

Könnte eventuell ein Update der Versionen abhilfe schaffen? Ich traue mich nur nicht, das zu machen. :)

Gruß
 
Hallo!
Eventuell ist einfach zu wenig Hauptspeicher vorhanden. Was hast du für einen Server? Wie sieht deine Apache Konfiguration aus?

mfG
Thorsten
 
Hm, das glaube ich weniger.

Intel Dual XEON 2,8 GHz
2 GB RAM

Im Apache sind nur die gängigen Module wie rewrite, python usw installiert. Zudem läuft noch die suexec von Confixx für Suse 9.2

Im Moment habe ich mal einen Chat abgeschaltet, der auf einem Useraccount lief. Mal sehen ob es besser wird.

Gruß
 
Back
Top