Anzeige:

Aktivierung von SSL leitet auf andere Domain weiter

greystone

Member
Für Fehlerdiagnose für alles vor dem darstellen der Seite empfehle ich auch eher ein Kommandozeilenprogramm.

Die ganze Intelligenz der Browser will man beim Testen gar nicht haben. Und man möchte den einfachen Requestverlauf sehen können.

Z. B. wget ( gibt's auch für Windows ) :

Code:
$ wget --spider www.serversupportforum.de
Spider mode enabled. Check if remote file exists.
--2017-01-15 11:46:39--  http://www.serversupportforum.de/
Resolving www.serversupportforum.de (www.serversupportforum.de)... 104.25.140.19, 104.25.141.19, 2400:cb00:2048:1::6819:8c13, ...
Connecting to www.serversupportforum.de (www.serversupportforum.de)|104.25.140.19|:80... connected.
HTTP request sent, awaiting response... 301 Moved Permanently
Location: http://serversupportforum.de/ [following]
Spider mode enabled. Check if remote file exists.
--2017-01-15 11:46:39--  http://serversupportforum.de/
Resolving serversupportforum.de (serversupportforum.de)... 104.25.141.19, 104.25.140.19, 2400:cb00:2048:1::6819:8d13, ...
Connecting to serversupportforum.de (serversupportforum.de)|104.25.141.19|:80... connected.
HTTP request sent, awaiting response... 301 Moved Permanently
Location: https://serversupportforum.de/ [following]
Spider mode enabled. Check if remote file exists.
--2017-01-15 11:46:39--  https://serversupportforum.de/
Connecting to serversupportforum.de (serversupportforum.de)|104.25.141.19|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: unspecified [text/html]
Remote file exists and could contain further links,
but recursion is disabled -- not retrieving.

Hier sieht man schön, dass der Request von www.ssf.de auf ssf.de weitergeleitet wird und anschließend noch auf https://ssf.de. Das ist dann schon mal die halbe Miete.
 
Last edited by a moderator:

danton

Debian User
Was ich in den ganzen Konfigurationen noch nicht gesehen habe, ist ein Eintrag, der für die per SSL erreichbare Domain von Port 80 auf Port 443 weiterleitet. Wenn ich nämlich im Browser nur domain.de eingebe, versucht der Browser eine Verbindung per http auf Port 80 aufzubauen.
 

Lillyfu

New Member
Was ich in den ganzen Konfigurationen noch nicht gesehen habe, ist ein Eintrag, der für die per SSL erreichbare Domain von Port 80 auf Port 443 weiterleitet. Wenn ich nämlich im Browser nur domain.de eingebe, versucht der Browser eine Verbindung per http auf Port 80 aufzubauen.

Danke für deine Hilfe :eek:
habe bei den Test immer nur http abgefragt. Weiterleitung in der Vhost von 80 auf 443 war die Lösung.
 

danton

Debian User
Du musst weiterhin einen vHost haben, der auf die entsprechende Domain auf Port 80 lauscht (unverschlüsselt) und in dem eine Weiterleitung auf den verschlüsselten Eintrag haben:
Code:
<VirtualHost *:80>
        ServerAdmin webmaster@domain.de
        ServerName www.domain.de
        RedirectPermanent / https://www.domain.de/
</VirtualHost>
Grund: Browser rufen erst die Adresse unverschlüsselt auf, wenn nicht explizit https:// mit eingegeben wurde.
 

Lockslay

New Member
Hallo danton

Code:
<VirtualHost *:80>
        ServerAdmin webmaster@domain.de
        ServerName www.domain.de
        RedirectPermanent / https://www.domain.de/
</VirtualHost>

Soweit verstanden, nur wo soll ich diesen Code vHost einfügen ?
etc/apache2/sites-enabled/
Kann mir da einer weiterhelfen

Gruß
Lockslay
 

danton

Debian User
Wenn du eine Weboberfläche wie Plesk, Webmin usw. verwendest, gar nicht, sondern du erstellst dir einen entsprechenden vHost in dieser Weboberfläche.
Ansonsten je nach eigener Vorliebe separate Dateien in dem von dir genannten Verzeichnis erstellen oder in die bereits vorhandenen Dateien für die betroffenen vHosts mit einfügen (ich mache letzteres). Wenn du separate Dateien für SSL und Nicht-SSL verwendest, dran denken, diese noch per a2ensite zu aktivieren. Anschließend einmal einen reload an den Apachen senden.
 
Top