Raid wird nicht synchronisiert



GregSki

New Member
Guten Morgen Zusammen,

In den Weihnachtsfeiertagen ist eine von zwei Festplatten ausgefallen und musste ausgetauscht werden.

Nachdem dies geschah, habe ich die Partition aus der aktuellen rüberkopiert, in das Raid System hinzugefügt, als auch synchronisiert.

Seit gestern jedoch werden die Partitionen wieder nicht mehr synchronisiert.

Code:
md3 : active raid1 sdb3[0] sda3[2](F)
      1459264192 blocks [2/1] [U_]

md1 : active raid1 sda1[2](F) sdb1[1]
      3911680 blocks [2/1] [_U]
Zunächst habe ich versucht den sda1 in das Raid System hinzu zu fügen, was jedoch nicht möglich ist:


mdadm /dev/md1 -a /dev/sda1
mdadm: Cannot open /dev/sda1: Device or resource busy
Die detailierten Informationen dazu:

Code:
mdadm --detail /dev/md1
/dev/md1:
        Version : 0.90
  Creation Time : Sun Dec 25 16:12:39 2011
     Raid Level : raid1
     Array Size : 3911680 (3.73 GiB 4.01 GB)
  Used Dev Size : 3911680 (3.73 GiB 4.01 GB)
   Raid Devices : 2
  Total Devices : 2
Preferred Minor : 1
    Persistence : Superblock is persistent

    Update Time : Thu Jan  9 10:30:07 2014
          State : clean, degraded
 Active Devices : 1
Working Devices : 1
 Failed Devices : 1
  Spare Devices : 0

           UUID : e2c4dafd:00eb4d05:3fb6082e:e5593158
         Events : 0.4144

    Number   Major   Minor   RaidDevice State
       0       0        0        0      removed
       1       8       17        1      active sync   /dev/sdb1

       2       8        1        -      faulty   /dev/sda1
Woran liegt es?

Viele lieben Dank
Greg
 
Die sda ist, wie du an der Detail-Ausgabe erkennen kannst, als "faulty" markiert. Wirf sie aus dem RAID und füge sie dann hinzu - vorher geht's (logischerweise) nicht. mdadm sieht, dass die Platte noch im RAID hängt, aber eben als faulty.
 
Vielen Dank. Habe sie mit --remote entfernt, bekomme sie aber nicht wieder rein.

Code:
mdadm /dev/md1 -a /dev/sda1
mdadm: failed to write superblock to /dev/sda1

Edit: Da ist wohl schon wieder eine Festplatte defekt :(

Code:
Jan  9 23:44:07 server kernel: sd 0:0:0:0: [sda] Result: hostbyte=DID_BAD_TARGET driverbyte=DRIVER_OK
Jan  9 23:44:07 server kernel: sd 0:0:0:0: [sda] CDB: Read(10): 28 00 00 00 00 00 00 00 08 00
Jan  9 23:44:07 server kernel: end_request: I/O error, dev sda, sector 0
Jan  9 23:44:07 server kernel: Buffer I/O error on device sda, logical block 0
 
Last edited by a moderator:
Ja, das hab ich mir schon gedacht, weil die Platte direkt als faulty markiert wurde (passiert eigentlich nicht wirklich schnell). Lass sie noch mal tauschen. :)
 
Back
Top