PHP 5.2.x RPMS fuer Suse 9.3 und MYSQL 4.1.x

Status
Not open for further replies.

SvenH

Registered User
bitte, hier die Ausgabe von rpm -qa | grep php

Hi,
ich habe auch das Prob. mit dem autoinstaller, wenn ich "alle" Module auswähle.
Lasse ich aber ein paar weg, dann gehts ohne Probleme durch!

Was mich noch interessiert ist folgendes:

Ich habe wbb3 installieren wollen, doch gabs dabei Probleme mit dem Schreibzugriff. Mutig habe ich die SubDom einfach mal mit 777 aktiviert und dann gings auch. Jedoch ist nun nicht den Domänen-User als Besitzer eingetragen sondern wwwrun. Muss ich hier evtl. noch was an der Config ändern, was nun durch die php5 installation evtl. nicht richtig ist?

Gruß
Sven
 

society

Registered User
Update:
- PHP 5.2.3
- Howto auf neuer PHP Version angepasst
 
Last edited by a moderator:

URiCK

Blog Benutzer
Hallo,

ich habe mit Hilfe des Tutorials erfolgreich auf PHP 5.2.3 und MySQL 4.1.22-Max updaten können.

Ich habe jetzt versucht MySQL auf Version 5 upzudaten und Fehlermeldungen erhalten, da libmysqlclient.so.14 fehlt. Ich habe libmysqlclient.so.15.

Ich nehme mal an, dass das Ganze nicht klappt, da die Pakete aus dem Forum mit MySQL 4 und nicht 5 kompiliert wurden.

Gehe ich richtig in der Annahme davon aus, dass die einzigste Möglichkeit somit ist, PHP5 selbst mit MySQL 5 zu kompilieren und zu installieren, oder gibts noch nen anderen Trick das zum Laufen zu bringen?

Habe einen Beitrag gelesen, wo Jemand nur libmysqlclient.so.14 nachkompiliert und handisch eingebunden hat...aber das übersteigt meine Linuxkenntnisse.

Vielen Dank,
Nick
 

ststeppat

Blog Benutzer
Hallo,

ich habe zwei Server, (einen L4 und einen L64) nach dem How-To geupdatet. Die Installation lief Problemlos durch. Nur beim L64 kommt unter der SSH-Console beim

php -v

PHP 4.3.10 (cli) (built: Mar 2 2007 21:38:21) .....

und beim L4


PHP 5.2.3 with Suhosin-Patch 0.9.6.2 (cli) (built: Jun 1 2007 12:45:28)...

was habe ich da falsch gemacht ?

Beide Server haben Suse 9.3 32bit drauf und sind gleich installiert ?

gruß

Stefan

Hat sich erledigt, der L64 läuft jetzt mit 10.1 Suse...
 
Last edited by a moderator:

Robert

Blog Benutzer
64 Bit

@firewire: gern, funktionieren diese mit dem 64 Bit Suse?

Schon mal ein Riesenlob an das Forum hier, habe schon etliche gute Sachen gefunden und umgesetzt.

Nun zur eigentlichen Frage: Habe mein PHP 4 im 64 Bit Suse 9.3 und Plesk 8.1.1 (1und1 XL64 Root) auf php 5.03 aktualisiert, das mediawiki verlangt aber mindestens php 5.1, so dass es ja am sinnvollsten wäre, gleich auf php 5.2.3 umzusteigen. Leider steht im ersten Artikel dickgedruckt, dass die Anleitung hier nicht mit 64 Bit suse funktioniert. Kann mir jemand helfen, wie ich dies bewerkstellige? Wäre toll.
 

Firewire2002

Registered User
Wenn du noch paar 32bit Libs installierst würden die RPMs sicherlich auch laufen. ;)
Ansonsten schnapp dir die src.rpm und bau den Mist neu. :)

Meine RPMs sind bisher nicht mit Plesk getestet. Im Zusammenspiel mit Plesk ist also Vorsicht geboten.
 

society

Registered User
Druchbruch Durchbruch ;-)

Habs nun endlich geschaft Suse 9.3 mit MySQL5 und PHP 5.2.3 auf Plesk laufen zu bekommen!!!!!

HowTo und Pakete folgen die Tage..... Juhu!!!! ;-)
 

society

Registered User
Der bringt unter Suse 9.3 leider Segmentation Faults.... sprich keine Chance weil ich keine Ahnung habe woran das liegt.
 

society

Registered User
Bitte Diskussion nur noch hier weiterführen:
 
Status
Not open for further replies.
Top