ModSecurity + WP = Fail ?



Dennisda

Registered User
Moin,

Mein System: X2 + Debian 6 + Apache2

Habe ModSecurity nach dem Tut installiert:

http://www.netvision-technik.de/forum/showthread.php?t=5526

Soweit funktioniert es ja auch, nur ich kann keine Blog Einträge mehr verfassen, die Vorschau Funktion geht auch nicht mehr. Es kommt immer diese Meldung:

Method Not Implemented

POST to /wp-admin/post.php not supported.
Apache/2.2.0 (Fedora) Server at www.meiendomain.net Port 80

Auf meinem Mybb Forum geht alles weiterhin wie gewohnt nur halt WP geht nicht mehr.

ModSecurity ist noch recht neu für mich, jedoch hat jemand Tipps für mich ?

Gruß
Dennis
 
@naxano:
Siehe:

mfG
Thorsten
 
Danke Thorsten

@naxano

Glaube nicht das es an WP an für sich liegt, das Problem ist liegt wohl eher, so gesehen, bei mir bzw. der Konfiguration. Nur mir fehlt der Ansatz ..
 
Logs sind wie immer das Stichwort.
Dort findest du eine Meldung von mod_security, welche bei post.php anschlägt und diese kannst du dann deaktivieren oder ändern.
 
Hast du dich genau an das TUT gehalten? Wenn ja, dann würd ich erst mal auf die aktuellen Versionen updaten!

Aktuelle Versionen sind:
2.5.13 für mod_security2 und
2.1.2 für das CoreRuleSet
 
Bei dem Core Ruleset gibt es zahlreiche false positive Meldungen im Zusammenhang mit Wordpress.

Welche Regeln das verursachen kann man in der Regel im Error.log sehen.

Schaut man sich mal die kostenlose Version der gotroot Regeln an, kann man sehen, wie viele Ausnahmen zu Wordpress geschrieben wurden. Vielleciht findest du dort Ansätze und Lösungen, wie man für bestimmte Dateien die Regeln neu definieren kann.
 
Back
Top