Mail-Empfang funktioniert nicht - Versand aber schon

svenr

Registered User
Nach dieser Anleitung hättest Du Maildirs hier erstellt
Code:
Wo sollen die Homeverzeichnisse der POP3-Benutzer liegen? [/home/email]:
Auswahl: /home/email
Da ist Dir wohl was durch die Lappen gegangen ;)
Wobei ich obiges Verzeichnis auch nicht passend finde.
Aber besser als /var/www
 

smithy

New Member
Ich bin genau der Anleitung gefolgt.
Es gibt bei mir auch den Ordner email im home verzeichnis dort wiederrum ist ein Ordner namens web1p1 dann Maildir und die ganzen Ordner.

Könnte mir das jemand vllt per Remote machen? Würde auch was bezahlen für. Komme gerade net wirklich weiter.
 

mr_brain

Registered User
In der Anleitung der erste Block zu Postfix. Drauf achten, dass da teilweise eine Shellzeile in zwei Zeilen steht !
 

smithy

New Member
Habs nun abgeändert bzw der mailbox_command hat gefehlt aber weiterhin kein Erfolg.

Code:
# See /usr/share/postfix/main.cf.dist for a commented, more complete version


# Debian specific:  Specifying a file name will cause the first
# line of that file to be used as the name.  The Debian default
# is /etc/mailname.
myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

readme_directory = no

# TLS parameters
smtpd_tls_cert_file=/etc/ssl/certs/ssl-cert-snakeoil.pem
smtpd_tls_key_file=/etc/ssl/private/ssl-cert-snakeoil.key
smtpd_use_tls=yes
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

myhostname = puck279.dedicatedpanel.com
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
mydestination = myorigin, puck279.dedicatedpanel.com, localhost.dedicatedpanel.com, , localhost
relayhost = 
mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = 127.0.0.1
smtpd_sasl_auth_enable = yes
smtpd_helo_required = yes
smtpd_sasl_security_options = noanonymous
smtpd_sasl_local_domain = $myorigin
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_mynetworks, reject_unauth_destination, reject_unknown_sender_domain, check_policy_service inet:127.0.0.1:12525, permit_sasl_authenticated, check_policy_service inet:127.0.0.1:10023 
smtpd_sender_restrictions = permit_mynetworks, permit_tls_clientcerts, reject_unknown_sender_domain, reject_non_fqdn_sender, reject_unauth_pipelining, permit_sasl_authenticated
home_mailbox = Maildir/
mailbox_command = procmail

### PARALLELS CONFIXX POSTFIX ENTRY ###

virtual_maps = hash:/etc/postfix/confixx_virtualUsers, hash:/etc/postfix/confixx_localDomains

### /PARALLELS CONFIXX POSTFIX ENTRY ###
 

svenr

Registered User
Nur so anbei.... wenn ich auf deinen Server schaue sehe ich
Ubuntu .. das Howto ist für Squeeze, da kann es durchaus Abweichungen bei Paketen geben.
 

svenr

Registered User
Ich weiß zwar nicht wie die Domain bei Dir auf den Server kommt. Doch sie löst zu S4U auf. Aber nicht zu deiner Serverip. Solltest das wohl mal anpassen.
Hostname bei Dir musste auch mal schauen.

Gruß Sven
 

svenr

Registered User
Code:
cat /etc/hosts
cat /etc/mailname
evtl hier noch was drin. Ich weiß ja nicht wo Confix die Domain hernimmt.
Hab jetzt auch nicht im Howto das Du nutzt nachgelesen ob Du die selber eingetragen hast.
 

smithy

New Member
Code:
puck279:~# cat /etc/hosts
127.0.0.1   localhost
85.25.243.177 puck279.server4you.de puck279
puck279:~# cat /etc/mailname
puck279.dedicatedpanel.com
 
Last edited by a moderator:

svenr

Registered User
Zu "warum etwas installiert wurde wie es installiert ist" wende Dich an deinen Hoster, der wird wohl wissen ob das einen Grund hat oder einfach ein Fehler im Template o.ä. ist.

Gruß Sven
 

smithy

New Member
So nach Absprache mit meinem Hoster S4YOU gab es einen Konfigurationsfehler der nun behoben wurde. Ich werde jetzt nochmal Confixx installieren und dann das Ergebnis hier posten.
 

killahmark

Blog Benutzer
ähnlicher Fehler

Hey Leute, habe da einen ähnlichen Fehler und würde natürlich hoffen, dass Ihr mir dabei weiterhelfen könnt.
System: Debian 6.0 Squeeze mit selbst installiertem Confixx

Also mein Fehler ist folgender (E-Mail von anderem Provider [gmx] bekommen):

Code:
Sep 26 23:01:41 killahmark postfix/smtpd[30425]: connect from mout.gmx.net[212.227.15.19]
Sep 26 23:01:41 killahmark postfix/smtpd[30425]: setting up TLS connection from mout.gmx.net[212.227.15.19]
Sep 26 23:01:41 killahmark postfix/smtpd[30425]: Anonymous TLS connection established from mout.gmx.net[212.227.15.19]: TLSv1 with cipher DHE-RSA-AES128-SHA (128/128 bits)
Sep 26 23:01:41 killahmark postfix/smtpd[30425]: E036688C4FC: client=mout.gmx.net[212.227.15.19]
Sep 26 23:01:41 killahmark postfix/cleanup[30412]: E036688C4FC: message-id=<[email protected]-gmx-bs15>
Sep 26 23:01:41 killahmark postfix/qmgr[30396]: E036688C4FC: from=<[email protected]>, size=1357, nrcpt=1 (queue active)
Sep 26 23:01:41 killahmark postfix/pipe[30429]: fatal: get_service_attr: unknown username: spamc
Sep 26 23:01:41 killahmark postfix/smtpd[30425]: disconnect from mout.gmx.net[212.227.15.19]
Sep 26 23:01:42 killahmark postfix/qmgr[30396]: warning: private/spamassassin socket: malformed response
Sep 26 23:01:42 killahmark postfix/qmgr[30396]: warning: transport spamassassin failure -- see a previous warning/fatal/panic logfile record for the problem description
Sep 26 23:01:42 killahmark postfix/master[30390]: warning: process /usr/lib/postfix/pipe pid 30429 exit status 1
Sep 26 23:01:42 killahmark postfix/master[30390]: warning: /usr/lib/postfix/pipe: bad command startup -- throttling
Sep 26 23:01:42 killahmark postfix/error[30430]: E036688C4FC: to=<[email protected]x.server.de>, orig_to=<[email protected]>, relay=none, delay=1.1, delays=0.06/1/0/0.01, dsn=4.3.0, status=deferred (unknown mail transport error)
Ich hatte vorher Postfix mit Spamassassin und Greylisting. Allerdings habe ich dann Greylisting wieder deaktiviert.

Über localhost geht der Empfang optimal.
 
Top