Cisco IOS Port Channel

vb-server

Registered User
Hallo zusammen

Hat zwar nichts mit Serverhardware zu tun, hoffe aber dass ich es hier trotzdem schreiben kann ;) Und zwar hat mein Internetprovider (zuhause) heute die Bandbreite von 100Mbit/s auf 150Mbit/s erhöht. Bisher war der Uplink ein eigenes VLAN auf csw01 (Catalyst 2940), auf einem 100Mbit/s Port. Da ich durch diesen jedoch nicht 150Mbit/s durchbringe, habe ich das Ganze verschoben auf den GigabitEthernet-Port.

Damit der zweite Switch, welcher am csw01 hängt (SG200-08), ebenfalls von den 150Mbit/s profitieren kann, habe ich einen Port Channel mit 2 100Mbit-Interfaces erstellt. Leider erhalte ich aber nie mehr als 100Mbit/s über diesen.

Config:
Code:
interface Port-channel1
 description UPLINK-SW01-PORTCHANNEL
 switchport trunk native vlan 912
 switchport trunk allowed vlan 910-919
 switchport mode trunk
 flowcontrol send off
!
interface FastEthernet0/1
 description PORTCHANNEL-1-1
 switchport trunk native vlan 912
 switchport trunk allowed vlan 910-919
 switchport mode trunk
 channel-group 1 mode active
!
interface FastEthernet0/2
 description PORTCHANNEL-1-2
 switchport trunk native vlan 912
 switchport trunk allowed vlan 910-919
 switchport mode trunk
 channel-group 1 mode active
!

show int po 1
Code:
Port-channel1 is up, line protocol is up (connected)
  Hardware is EtherChannel, address is 000d.2936.2382 (bia 000d.2936.2382)
  Description: UPLINK-SW01-PORTCHANNEL
  MTU 1500 bytes, BW 200000 Kbit, DLY 1000 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Full-duplex, 100Mb/s, media type is unknown media type
  input flow-control is off, output flow-control is off
  Members in this channel: Fa0/1 Fa0/2 
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:01, output 00:00:01, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 9000 bits/sec, 9 packets/sec
  5 minute output rate 189000 bits/sec, 22 packets/sec
     3313649 packets input, 272946675 bytes, 0 no buffer
     Received 4898 broadcasts (3597 multicast)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 3597 multicast, 0 pause input
     0 input packets with dribble condition detected
     7268506 packets output, 2206391929 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out
Laut dieser Angabe soll das Ganze ja auf 200Mbit/s laufen. sh int status ist da aber anderer Meinung:

Code:
Po1       UPLINK-SW01-PORTCH connected    trunk      a-full  a-100


Hat vielleicht jemand einen Tipp für mich, was hier schief geht?


Viele Grüsse
 
Was zeigt denn show port-channel load-balance?

Default ist source-dest-mac, was bei einer Punkt-zu-Punkt-Verbindung eher ungünstig ist - dann geht doch wieder alles nur über ein Kabel.

Zur Auswahl steht noch destination-ip | destination-mac | destination-port | source-dest-ip | source-dest-mac | source-dest-port | source-ip | source-mac | source-port, wobei ich zu source-dest-ip tendieren würde.
 
Das IOS ist wohl etwas zu alt :rolleyes: (12.1)

Code:
Switch(config)#do show port-channel load-balance
show port-channel load-balance
          ^
% Invalid input detected at '^' marker.

Werd mich mal schlau machen drüber und danach wieder posten :)


EDIT:
Heisst wohl etherchannel:
Switch#show etherchannel load-balance
Source MAC address

Setzen kann ich aber nur diese:
Switch(config)#port-channel load-balance ?
dst-mac Dst Mac Addr
src-mac Src Mac Addr

Ist hier wirklich mein IOS zu alt? :(
 
Last edited by a moderator:
show etherchannel load-balance

Gut war ich zu spät..

Evtl. mal LACP anschauen
 
Last edited by a moderator:
Kann er auch nicht :mad: Aber offenbar unterstützt er nur dot1q:

Code:
FastEthernet0/1
  Model:                 WS-C2940-8TT-S
  Type:                  10/100BaseTX
  Speed:                 10,100,auto
  Duplex:                half,full,auto
  UDLD:                  yes
  Trunk encap. type:     802.1Q
  Trunk mode:            on,off,desirable,nonegotiate
  Channel:               yes
  Broadcast suppression: percentage(0-100)
  Flowcontrol:           rx-(none),tx-(none)
  Fast Start:            yes
  CoS rewrite:           yes
  ToS rewrite:           yes
  Inline power:          no
  SPAN:                  source/destination
  PortSecure:            Yes
  Dot1x:                 Yes
 
Last edited by a moderator:
Back
Top