Apache 2 startet nicht mehr



com98

New Member
Hey,
Ich bin noch neu hier, aber ich hoffe ihr könnt mir bei meinem Problem weiterhelfen, ich habe seit kurzem einen vServer und gestern ist mir mein Apache2 abgeschmiert. Ich habe es so gut wie´s geht selber versucht aber ich komm einfach nicht mehr weiter. Ich hoffe ihr könnt mir helfen. Also wenn ich versuche Apache 2 zu starten kommt dieser Error:
Code:
root@vm10:/var# /etc/init.d/apache2 start
Starting web server: apache2Action 'start' failed.
The Apache error log may have more information.
 failed!
In der Logfile steht nur folgende Zeile, die sich immer wieder wiederholt:
Code:
(2)No such file or directory: apache2: could not open error log file /var/customers/logs/test-error.log.
Unable to open logs
Ansonsten stehen nur ein paar alte Sachen drinn, die damit nichts zu tun haben. Bisher hab ich schon Apache2 neu installiert, mein WWW Verzeichnis gecleared, Alle Apache Dienste beendet aber keines will funktionieren. Was mache ich falsch?

LG
com98
 
Was an
(2)No such file or directory: apache2: could not open error log file /var/customers/logs/test-error.log

verstehst Du nicht? Anscheinend gibt es die Datei nicht, oder der Apache hat keine Rechte, um dort reinzuschreiben.
 
Die Ordnerstruktur klingt nach Froxlor.

Wie sehen die Rechte des Ordners aus? Vermutlich ist dem Apache dort nichts gestattet.
 
Ja das schaut nach Froxlor aus evtl. hat da jemand bei der Konfiguration von Froxlor einfach nur Copy Paste gemacht und nicht den Paste kontrolliert^^
 
Plesk12 update verursacht Fehler

Hallo an die Fachleute hier.
Ich habe nach dem update von Plesk auf version 12 riesige Probleme.
Zeigt keine Webseiten mehr an:
Fehler:
Aufgrund folgender Fehler in den Konfigurations-Templates konnten keine neuen Konfigurationsdateien für den Apache Webserver erstellt werden: Can not restart web server: Service /etc/init.d/apache2 failed to start Service /etc/init.d/apache2 failed to start . Ausführliche Fehlerbeschreibungen wurden Ihnen per E-Mail zugesendet. Bitte lösen Sie das Problem und klicken Sie hier, um die beschädigten Konfigurationsdateien erneut zu erstellen, oder hier, um alle Konfigurationsdateien zu erstellen.

Bitte dringend um Hilfe,bin leider kein Fachmann :o
Danke
Loisl
 
Auf Server mit SSH-Client zugreifen
in der Shell aufrufen
/usr/local/psa/admin/bin/httpdmng --reconfigure-all
 
danke für die info aber das geht nicht :


root@hxxxxx:~# /usr/local/psa/admin/bin/httpdmng --reconfigure-all
Execution failed.
Command: httpdmng
Arguments: Array
(
[0] => --reconfigure-server
[1] => -no-restart
)

Details: [2014-09-08 12:12:56] ERR [util_exec] proc_close() failed
[2014-09-08 12:12:59] ERR [util_exec] proc_close() failed
[2014-09-08 12:13:00] ERR [panel] Apache config (14101711750.66142400) generation failed: Template_Exception: nginx: [emerg] PEM_read_bio_X509_AUX("/opt/psa/var/certificates/certIGHJU52") failed (SSL: error:0906D064:PEM routines:PEM_read_bio:bad base64 decode)
nginx: configuration file /etc/nginx/nginx.conf test failed

file: /opt/psa/admin/plib/Template/Writer/Webserver/Abstract.php
line: 75
code: 0
nginx: [emerg] PEM_read_bio_X509_AUX("/opt/psa/var/certificates/certIGHJU52") failed (SSL: error:0906D064:PEM routines:PEM_read_bio:bad base64 decode)
nginx: configuration file /etc/nginx/nginx.conf test failed
 
Last edited by a moderator:
Sieht so aus als ob das SSL-Zertifikat /opt/psa/var/certificates/certIGHJU52 defekt ist.

//EDIT:
Ist das ein gekauftes Zertifikat?

Schau mal in welcher Apache-Konfig das ist:
grep -R certIGHJU52 /etc/apache2/plesk.conf.d/

Das sollte anzeigen für welche Domain das ist:
openssl x509 -subject -noout -in /opt/psa/var/certificates/certIGHJU52
 
Last edited by a moderator:
Sieht so aus als ob das SSL-Zertifikat /opt/psa/var/certificates/certIGHJU52 defekt ist.

//EDIT:
Ist das ein gekauftes Zertifikat?
ja das plesk zertifikat ist gekauft ( 30 Domains)
Schau mal in welcher Apache-Konfig das ist:
grep -R certIGHJU52 /etc/apache2/plesk.conf.d/
root@h2123992:~# grep -R certIGHJU52 /etc/apache2/plesk.conf.d/
/etc/apache2/plesk.conf.d/atmail.conf.bak: SSLCertificateFile "/opt/psa/v ar/certificates/certIGHJU52"
/etc/apache2/plesk.conf.d/horde.conf.bak: SSLCertificateFile "/opt/psa/va r/certificates/certIGHJU52"
/etc/apache2/plesk.conf.d/atmail.conf: SSLCertificateFile "/opt/psa/var/c ertificates/certIGHJU52"
/etc/apache2/plesk.conf.d/server.conf.bak: SSLCertificateFile "/opt/psa/v ar/certificates/certIGHJU52"
/etc/apache2/plesk.conf.d/server.conf.bak: SSLCertificateFile "/opt/psa/v ar/certificates/certIGHJU52"
/etc/apache2/plesk.conf.d/horde.conf: SSLCertificateFile "/opt/psa/var/ce rtificates/certIGHJU52"
/etc/apache2/plesk.conf.d/server.conf: SSLCertificateFile "/opt/psa/var/c ertificates/certIGHJU52"
/etc/apache2/plesk.conf.d/server.conf: SSLCertificateFile "/opt/psa/var/c ertificates/certIGHJU52"

Das sollte anzeigen für welche Domain das ist:
openssl x509 -subject -noout -in /opt/psa/var/certificates/certIGHJU52

root@hxxxxx:~# openssl x509 -subject -noout -in /opt/psa/var/certificates/certIGHJU52
unable to load certificate
140486151517856:error:0906D064:PEM routines:PEM_read_bio:bad base64 decode:pem_lib.c:811:
 
Last edited by a moderator:
Das SSL-Zertfikat sollte aus drei Abschnitten (..., sind BAse64-kodiert Daten Buchstabenfolgen) bestehen:

-----BEGIN PRIVATE KEY-----
....
-----END PRIVATE KEY-----

-----BEGIN CERTIFICATE-----
....
-----END CERTIFICATE-----

-----BEGIN CERTIFICATE-----
.....
-----END CERTIFICATE-----

Das ist:
Privater Schlüssel
Öffentlicher Schlüssel
CA-Zertifikat
 
Das SSL-Zertfikat sollte aus drei Abschnitten (..., sind BAse64-kodiert Daten Buchstabenfolgen) bestehen:

-----BEGIN PRIVATE KEY-----
....
-----END PRIVATE KEY-----

-----BEGIN CERTIFICATE-----
....
-----END CERTIFICATE-----

-----BEGIN CERTIFICATE-----
.....
-----END CERTIFICATE-----


Privater Schlüssel
Öffentlicher Schlüssel
CA-Zertifikat

sorry aber das sagt mir jetzt nicht wirklich erwas, ist es defekt oder was meinst
Das ist:
 
Ein cat /opt/psa/var/certificates/certIGHJU52 sollte diese Abschnitte zeigen.

//EDIT:
Du schriebst das Zertifikat ist für 30 Domains?
Du meinst Plesk hat die Lizenz für 30 Domains.

Was ich meine: das SSL-Zertifikat.

Hast du kein Backup deiner SSL-Zertifikate für die Domains?
 
Last edited by a moderator:
Ich wollte nur wissen, ob dort die Trenner ----...----- drin sind, nicht den Inhalt!
Private bedeutet auch Privat!!!! Nicht für andere :eek:

Würdest du bitte diese im Posting unkenntlich machen?

Ansonsten, wenn dort die Leerzeichen so drin sind, ist da was nicht in Ordnung mit den Zertifikaten.
Irgendwie müssen die falsch nach der Erstellung kopiert worden sein.
 
Last edited by a moderator:
Ich wollte nur wissen, ob dort die Trenner ----...----- drin sind, nicht den Inhalt!
Private bedeutet auch Privat!!!! Nicht für andere :eek:
ok thx

Würdest du bitte diese im Posting unkenntlich machen?
erledigt

Ansonsten, wenn dort die Leerzeichen so drin sind, ist da was nicht in Ordnung mit den Zertifikaten.
Irgendwie müssen die falsch nach der Erstellung kopiert worden sein.

auch wenn sich der satz immer blöd anhört aber: ich hab nix gemacht :eek:
außer einen klick auf update.
 
Back
Top