Win-Server 2016: Abhängigkeit des Audiodienstes

D

Deeshined

Guest
Hallo zusammen.

Ich habe ein Problem mit der Konfiguration meines Windows-Servers (V 2016). Der Audiodienst ist abhängig von der bestehenden Remotedesktopverbindung. Wenn ich die Remotedesktopverbindung schließe, wird auch der Audiodienst beendet. Gibt es eine Möglichkeit, den Dienst auch nach dem Schließen der Verbindung aufrecht zu erhalten?

Grüße,
Daniel

Hello everybody.
I have a problem with the configuration of my Windows server (2016). The audio service depends on the existing Remote Desktop connection. When I close the Remote Desktop connection, the audio service also quits. Is there a way to maintain the service even after the connection is closed?
Best Regards,
Daniel
 

Attachments

danton

Debian User
Der Audiodienst nicht nicht vom Remotedesktop-Dienst abhängig, wie man auch auf deinem Screenshot sehen kann. Erhängt vom Audioendpunkt und dem RPC-Dienst ab. Letzterer ist nicht der Remotedesktop-Dienst.
Falls allerdings keine Soundkarte in deinem Server vorhanden ist, wird meines Wissens der Audioendpunkt beendet, sobald die RDP-Verbindung getrennt wird, da dann kein Audio-Ausgabe-Gerät mehr vorhanden ist (RDP stellt quasi eine Art virtueller Soundkarte bereit).
 
D

Deeshined

Guest
Ich habe eine virtuelle Soundkarte (Virtual Audio Cable) installiert, um Audio von einem Mumble-Server an eine andere Software 'weiterzuleiten'. In den Ressourcen-Einstellungen meiner RDP-Verbindung ist festgelegt, dass Sound auf dem Remoterechner wiedergegeben wird.
 

danton

Debian User
Ich habe gerade mal auf einem 2019er Server nachgesehen, da laufen die beiden Audio-Dienste auch weiter, wenn keine RDP-Verbindung besteht. Stehen die Dienste denn auf der richtigen Startart? Windows-Audio auf "Automatisch" und der Audio-Endpunkt ist bei mir auf Manuell.
 
D

Deeshined

Guest
Das ist bei mir auch so eingestellt, ja. Mein Server scheint aber die Soundkarte zu beenden, wenn ich die RDP schließe.

Mein Fall: Ein Funkscanner scannt eine Amateurfunkfrequenz und überträgt dieses Audio über einen Raspi via Mumble auf den V-Server. Auf dem V-Server habe ich die Software "Virtual Audio Cable" installiert, welche als virtuelle Soundkarte fungiert und das Audiosignal an eine Software weiterleitet, die das gestreamte decodiert und aufzeichnet. So lange ich die RDP offen habe bzw. wieder öffne, funktioniert die decodierung einwandfrei, sobald ich diese schließe wieder nicht.
 

dermaxem

New Member
Hallo, habe hier ein ähnliches Problemchen.Windows-Server, via RemoteDesktop.
Der Server hat eine int. Soundkarte, im Bios aktiv.
Verwaltet wird über RemoteDesktop, und hier ist Sound zu hören, am Client-PC.
Ziel ist es aber, das via Audioplayer (hier Foobar) eins der installierten Virtual-Audio-Cables genutzt wird um dann Sound als Musikbot in einen TS3-Server einzuspielen, der auch auf diesem Server läuft.
Was muss ich am Server machen, das die schon installierten Virtual Audio-Cable in der Software (hier dann Foobar und TS3-Client für den Bot) als Device auswählbar werden?
server-no-sound.jpg
 
Top