Websocket auf Port 5000 Aktivierung

mwagner

New Member
Hallo,
Ich habe bei iblu einen vServer R4. Darauf läuft ein System für www.donation-tracker.de . Habe nun seit geraumer Zeit folgende Fehlermeldung: "Bitte aktivieren Sie schnellstmöglich den Websocket auf Port 5000! ". Da ich absoluter Laie auf diesem Fachgebiet bin, wende ich mich in diesem Forum wegen des Problemes an Euch. Seltsamerweise lief bis zum 01. März alles problemlos. Ich habe keinerlei Einstellungen oder Veränderungen vorgenommen. Habe vor 2 Tage festgestellt, das der Server runtergefahren wurde und diese besagte Fehlermeldung immer und immer wieder ausgeworfen wird. Habe nun den Server wieder neu gestartet und die Homepage läuft wieder. Jedoch bleibt der o.g. Fehler immer noch bestehen. Wie kann man den Websocket auf Port 5000 wieder aktivieren? Es wäre schön, wenn Ihr mir hier weiterhelfen könntet. Vielen Dank im voraus!
 

DeaD_EyE

Blog Benutzer
Vielleicht benötigt der DonationTracker einen Websocket-Server, um Daten auszutauschen.
Falls der DonationTracker das benötigt, werden die das Tool/Dienst zur Verfügung gestellt haben.
Du oder jemand anderes wirst diesen Dienst auch irgendwann einmal auf dem Server installiert haben.

Der Neustart des Servers wird wahrscheinlich genau diesen Dienst nicht gestartet haben.
Da der Betreiber keine vernünftigen Informationen zur Verfügung stellt (bin nicht angemeldet), kann ich auch nicht mehr darüber sagen.

Die haben sicherlich einen Support-Bereich für Kunden.
 

mwagner

New Member
Vielleicht benötigt der DonationTracker einen Websocket-Server, um Daten auszutauschen.
Falls der DonationTracker das benötigt, werden die das Tool/Dienst zur Verfügung gestellt haben.
Du oder jemand anderes wirst diesen Dienst auch irgendwann einmal auf dem Server installiert haben.

Der Neustart des Servers wird wahrscheinlich genau diesen Dienst nicht gestartet haben.
Da der Betreiber keine vernünftigen Informationen zur Verfügung stellt (bin nicht angemeldet), kann ich auch nicht mehr darüber sagen.

Die haben sicherlich einen Support-Bereich für Kunden.
Das Webprojekt www.donation-tracker.de läuft schon seit dem Jahr 2013 ohne Fehlermeldung beim Hoster 1Blu. Auch mit der Anmietung des Paketes vServer 4R gab es bisher keine Probleme. Nur seit dem 01.03.2020 gibt es nun die technischen o.g. beschriebenen Probleme mit der Aktivierung des Websocket auf Port 5000.
Jemand anderes hat das gesamte System auf dem vServer installiert. Leider kann ich diesen Kontakt nicht erreichen und auch der Support Bereich von 1Blu kann mir allem Anschein auch nicht weiterhelfen. Bei Fragen zur Konfiguration soll ich die Dokumentation Ihres Betriebssystems sowie ggf. das Handbuch zu Ihrer Plesk-Version konsultieren.
Ich weiß beim besten Willen nicht wo ich den Websocket auf Port 5000 aktivieren könnte bzw. wo das einzustellen wäre, geschweige denn wo ich das nachlesen könnte um mir selbst eine Lösung zu erarbeiten. Ich habe im gesamten Plesk Kundenlogin nach diesem Dienst gesucht, jedoch nicht gefunden. Jetzt ist die Frage: Wo und wie kann ich diesen Dienst wieder nachträglich aktiveren.
 

danton

Debian User
Ohne zu wissen, wass du da für eine Software auf deinem Server einsetzt, die den Websocket auf Port 5000 bereitstellen soll, wird dir keiner helfen können. Ich könnte mir vorstellen, dass der Websocket für die Kommunikation mit eurer App notwendig ist oder eine Schnittstelle zu bestimmten Zahlungsdienstleistern. Der Dienst wird vermutlich nicht Websocket heisse. Es kann z.B. ein Perl- oder Python Script sein, ein Tomcat-Server mit Java, eine andere Script-Sprache, Node.js, ein selbstgeschriebenes C++ Programm (und diese Liste läßt sich beliebig verlängern).
Was für Software wird auf dem Server eingesetzt (außer Plesk, das wissen wir schon), welches Linux. Wurden in letzter Zeit Updates installiert? Wenn ja, welche? Was sagen die Logdateien auf dem Server (Syslog, Logs der einzelnen Dienster etc.).
Vielleicht ist es auch an der Zeit, mal nach professioneller Hilfe zu suchen (z.B. hier im Forum unter Angebote -> Suche eine Anfrage stellen), denn du scheinst da ja Geld mit zu verdienen.
 

DeaD_EyE

Blog Benutzer
1Blu ist der falsche Ansprechpartner, es seiden dein Server ist nicht erreichbar oder irgendwas ist mit dem Netz.

Es ist nicht die Aufgabe von 1Blu den Kunden irgendwelche Software auf dem Server zu installieren.
Das hast du mit den AGB bereits so akzeptiert.

Deine Anlaufstelle wäre www.donation-tracker.de
Die müsstest du fragen was das ist, woher du das bekommst und was du machen musst.
Die werden doch sicherlich eine Installationsanleitung für Kunden haben.

EDIT: Ich habe mich dort mal kurz angemeldet. Dort ist von einem Websocket nicht die Rede. Was die Anbieten ist eine URL, die man z.B. in OBS einbinden kann. Ich schätze mal, falls das irgendwas für deine Website ist, muss es nicht direkt von donation-tracker stammen. Habe leider keine API-Dokumentation gefunden, einen API-Key stellen sie aber für ihre eigene Desktop-Anwendung zur Verfügung.
 
Last edited:

DeaD_EyE

Blog Benutzer
ACHSOOO omg

Ja und dann weiß er nicht wie seine eigene Seite funktioniert?
Irgendjemand muss die doch entwickelt haben und einem Webentwickler weiß was Websockets sind.
Habs jetzt nicht weiter verfolgt, aber dieses Altert-Fenster für OBS könnte die Update via Websockets bekommen, was aber mit einschließen würde, dass diese Streaming-Tools JavaScript ausführen. Unheimlich :-D
 

danton

Debian User
Tja, dieser Webentwickler scheint wohl nicht mehr erreichbar zu sein. Daher auch weiter oben schon mein Rat, professionelle Hilfe in Anspruch zu nehmen. Kostet Geld, aber mit der Seite wird ja anscheinend auch Geld verdient...
 

d4f

Müder Benutzer
Ich würde mal spontan behaupten dass die Firewall-Regeln vermutlich nicht persistent gespeichert wurden.
"iptables -I INPUT -p tcp --dport 5000 -j ACCEPT" könnte das vorliegende Problem his zum nächsten Reboot lösen.
Persistenz wird je nach Betriebssystem unterschiedlich realisiert. Unter RHEL/CentOS bis v6 standardmässig mit "service iptables save"
Falls nicht, könnte man mit "lsof -nP -i :5000" mal überprüfen ob auf Port 5000 überhaupt was läuft.

Bitte aber, auch wenn dies das Problem löst, dringendst Fachrat suchen.
 
Last edited:

danton

Debian User
Da hier anscheinend mit Plesk gearbeitet wird, würde ich eher empfehlen, die Firewall-Regel in Plesk zu prüfen und ggfl. hinzufügen.
Und ich stimme dir zu: Fachmännischer Rat wird hier dringend benötigt.
 

mwagner

New Member
Hallo zusammen,
danke für Euer Feedback für meine Problemstellung.

Habe nun unter "Angebote" eine Suchanzeige aufgegeben.

 
Top