Webmin Sendmail und 501 Error

Amaleae

New Member
Hallo,

Ich mehrer Domains auf meinem Server und Sendmail kann an einige Provider keine Email senden.
Anscheindend liegt das Problem daran, dass Sendmail meine Emails (Ich benutze phpmailer) nicht mit dem richtigen Absender versieht?
sondern mit:
Ubuntu-1004-lucid-64-minimal

----- Transcript of session follows -----
... while talking to mx-ha02.*******.de.:
>>> HELO Ubuntu-1004-lucid-64-minimal
<<< 501 Syntax error in parameters or arguments
... while talking to mx-ha03.*******.de.:
>>> HELO Ubuntu-1004-lucid-64-minimal
<<< 501 Syntax error in parameters or arguments
554 5.0.0 Service unavailable

Hat jemand ne Idee? Wäre wirklich super!
 

GwenDragon

Registered User
1. Benutzt du wirklich das Original sendmail oder exim oder sowas
2. Hast du versuch auf der Shell mal was mit sendmail zu versenden, klappt der Versand dann auch nicht
 

Amaleae

New Member
Sendmail -t

Danke für deine Antwort,

Es handelt sich wirklich um das gute alte Sendmail.

auch über die commandline mit "sendmail -t" geht es bei
gmail und web.de leider nicht.
Bei yahoo.de gibt es genauso wie beim Aufruf über PHP keinerlei Probleme.

----- Transcript of session follows -----
... while talking to mx-ha03.web.de.:
>>> HELO Ubuntu-1004-lucid-64-minimal
<<< 501 Syntax error in parameters or arguments
... while talking to mx-ha02.web.de.:
>>> HELO Ubuntu-1004-lucid-64-minimal
<<< 501 Syntax error in parameters or arguments
554 5.0.0 Service unavailable
 

GwenDragon

Registered User
Ich nehme mal an, manche Mailanbieter versuchen per DNS den Hostname im HELO reverse aufzulösen. Da du keinen FQDN sendest, wird das nicht klappen.
Eigentlich dürfen Mailserver nicht Mails wegen ungültiger HELO abweisen.
 
Top