WebDAV im Windows-Server

biertragl

Member
Mahlzeit.

Habe einen 2016er Essentials laufen, versuche da vergeblich WebDAV drauf einzurichten.

- WebDAV Publishing ist installiert
- Es gibt eine Gruppe "webdav", darin sind 2 User
- IIS -> Default Web Site -> WebDAV-Erstellungsregeln -> WebDAV aktiviert
- Virtuelles Verzeichnis "WebDAV" angelegt, das Verzeichnis auf durchsuchbar gesetzt, Authentifizierung alles ausgeschaltet, Windows-Authentifizierung eingeschaltet
- WebDAV Erstellungsregel -> Gruppe "webdav" hat kompletten Zugriff

Nun zum Problem:
Wenn ich per Browser auf den WebDAV zugreife
- von außen: https://domain.de/WebDAV
- vom server selbst: https://localhost/WebDAV

funktioniert alles einwandfrei. Ich kann meine Userdaten eingeben und sehe alles.

Wenn ich das Ganze jedoch als Netzlaufwerk oder als Netzwerkadresse verbinden möchte (egal ob von außen oder vom internen Netzwerk) bekomme ich promt die Meldung "Der eingegebene Ordner ist ungültig. Wählen Sie einen anderen Ordner."

Probiert habe ich das
- mit meinem PC (im internen Netzwerk) -> Windows 10
- PC von einem Bekannten (von außen) -> Windows 10
- von einem Windows Server 2012 r2 (im Rechenzentrum)

Wie gesagt, Browser geht - netzlaufwerk oder ressource leider nicht.
Jemand eine Idee? Bei meinem 2012er Server hat's vorher geklappt, wüsste nicht dass ich was Anderes eingestellt hätte.

LG
 

biertragl

Member
Nachtrag 2:
Grad vom Iphone mit einer WebDAV-App probiert -> Komme ohne Probleme drauf und kann Dateien bearbeiten etc. Nur die PC's klappen nicht...
 

GwenDragon

Registered User
Erinnert mich an einen WebDAV-Bug mit älteren Windows.
Im Explorer ein # an die URI angehängt und es klappte.
Probier es doch mal, kostet ja nur eine Minute deiner Zeit.
 

danton

Debian User
Der WebDAV-Client von Windows ist etwas zickig, evtl. reicht es aber schon, in der REgistry den BasicAuthLevel anzupassen, wie es z.B. Caschy beschrieben hat. Der hat zumindest bei mir den Zugriff auf meine Nextcloud ermöglicht.
 

biertragl

Member
Das könnte ich zur Not probieren, jedoch ist es nicht Sinn und Zweck der Übung an den Clients was zu verstellen - schon gar nicht in der Registry. Gibt es keine Möglichkeit da Serverseitig was einzustellen - sei es die Sicherheit etwas "runter zu drehen" ?

LG
 

danton

Debian User
Eine Sache könntest du evtl. noch testen: Windows schickt gerne die Domäne als Bestandteil des Usernamens mit. Da kann es schon helfen, den Usernamen inkl. Domäne bzw. Rechnername anzugeben. Wenn dein WebDAV-Server keiner Domäne angehört, also SERVERNAME\username oder in Kurzschreibweise .\username (das mit dem Punkt ist hilfreich, wenn man sich mit einem lokalen Benutzer an einem Mitgliedsrechner einer Domäne anmelden will).
 

danton

Debian User
Ist das SSL-Zertifikat ein offizielles oder selbstsigniert? Bei letzterem solltest du es zum Zertifikatsstore von Windows hinzufügen, so dass keine Meldung kommt. Hast du alternativ mal in die Logs vom IIS geschaut, ob die Webdav-Anfrage überhaupt bei deinem Server ankommt und was er antwortet?
 

biertragl

Member
ich schau mal nach den Logs, da kam aber glaub ich nix bei rum.
Zertifikat ist ein kostenloses, aber nicht selbst zertifiziert. Es funktioniert damit ja sogar der Zugriff von jedem Browser bzw. auch RDP von überall aus funktioniert - sogar wenn ich über Gateway-Server verbinden muss weil bei uns auf der Firma sonst alles geblockt ist außer Port 80 :)
 
Top