• This forum has a zero tolerance policy regarding spam. If you register here to publish advertising, your user account will be deleted without further questions.

Webalizer auf Deutsch Howto und ein problem

D

dereine

Guest
Moin Moin

Ich habe von mein hoster ein Klein Howto bekommen


Code:
apt-get remove webalizer

wget http://archive.mgm51.com/mirrors/webalizer-files/webalizer-2.01-10-src.tgz
tar xzf webalizer-2.01-10-src.tgz
cd webalizer-2.01-10
./configure --with-language=german
make
make install
ln -s /usr/local/bin/webalizer /usr/bin/webalizer

hat auch bis jetze sehr gut funktioniert :)

aber wenn ich make aus führe kommt folgende meldung:

Code:
make: *** No rule to make target `install'.  Stop.

das habe ich alles im verzeichniss /root/ gemacht

-Was habe ich falsch gemacht ???
-wie kann ich es richtig machen ???

MFG
Dennis
 
Hier muss configure bereits abgebrochen haben, welches normalerweise eine Datei mit dem Namen Makefile erzeugt.
Starte nochmal die configure-Zeile und achte auf die Ausgaben am Ende.

tim

P.S.: Tut mir leid - ich bin zwar kein Moderator, aber ich meine mal was über Groß-/Kleinschreibung in den Board-Regeln gelesen zu haben.

Ich zitiere mal mit Fehlerberichtigung:

Moin Moin
Ich habe von meinem Hoster ein kleines Howto bekommen.
Es hat auch bis jetzt sehr gut funktioniert. :)
Aber wenn ich make ausführe kommt folgende Meldung:
Das habe ich alles im Verzeichnis /root/ gemacht.
-Was habe ich falsch gemacht ???
-Wie kann ich es richtig machen ???

16 Fehler in 6 Sätzen :(
 
Last edited by a moderator:
Soory ich kann manches mal auf Die Tasten hauen wie ich will
aber die Spinnen rum.

Ok hier mal die Ausgabe:

Code:
creating cache ./config.cache
checking for gcc... gcc
checking whether the C compiler (gcc  ) works... yes
checking whether the C compiler (gcc  ) is a cross-compiler... no
checking whether we are using GNU C... yes
checking whether gcc accepts -g... yes
checking whether ln -s works... yes
checking for a BSD compatible install... /usr/bin/install -c
checking how to run the C preprocessor... gcc -E
checking whether char is unsigned... no
checking for main in -l44bsd... no
checking for main in -lm... yes
checking for main in -lz... yes
checking for gzrewind in -lz... yes
checking for main in -lpng... no
configure: error: png library not found... please install png.


Ich Denke mal es liegt hier dran :

Code:
configure: error: png library not found... please install png.

Aber wie Ich das Beheben kann weiß ich nicht
 
Gib mal ./configure --help ein. Vielleicht findet sich dort ein Parameter, über den man die PNG-Library mit angeben kann. Suche mal Dateien, welche mit libpng anfangen. Bei mir sind sie unter /usr/lib abgelegt.

tim
 
@tim

Der Befehl funkt bei mir net : ./configure --help

und wenn ich Die Datei suche kommt folgendes raus:

Code:
./var/lib/dpkg/info/libpng2.postinst
./var/lib/dpkg/info/libpng2.prerm
./var/lib/dpkg/info/libpng2.postrm
./var/lib/dpkg/info/libpng2.shlibs
./var/lib/dpkg/info/libpng2.list
./usr/share/doc/libpng2
./usr/share/doc/libpng2/copyright
./usr/share/doc/libpng2/README.gz
./usr/share/doc/libpng2/TODO.gz
./usr/share/doc/libpng2/changelog.gz
./usr/share/doc/libpng2/ANNOUNCE.gz
./usr/share/doc/libpng2/KNOWNBUG.gz
./usr/share/doc/libpng2/changelog.Debian.gz
./usr/doc/libpng2
./usr/lib/libpng.so.2.1.0.12
./usr/lib/libpng.so.2
find: ./proc/1/fd: Permission denied
find: ./tmp/auto: Permission denied
find: ./tmp/5.6.1: Permission denied
find: ./tmp/i686-linux: Permission denied

mmhhh K.a
 
Wenn ich es ausführe Kommt Folgendes:

Code:
Reading Package Lists... Done
Building Dependency Tree... Done
E: Couldn't find package lib-png-devel
:(
 
Google 2sek: apt-get install libpng-devel

Bitte Google doch mal erst bevor du frägst das hatten andere schon X mal
 
Oder versuch einfach mal Folgendes:

cd /usr/lib
ln -s libpng.so.2 libpng.so


Und jetzt nochmal configure probieren.


tim
 
@tim

Man du bist ein Engel das wars jetze funkt es Einwandfrei
 
Gleihes Problem

Hallo Leute,

ich habe auch das Problem mit der libpng-Sache. Nur, der angegebene Tipp mit dem In-Befehl klappt bei mir nicht. Es kommt der Command not Found

Kann mir da jemand weiterhelfen? Die LIBPNG*.* sind vorhanden.
 
mecie21313 said:
Hallo Leute,

ich habe auch das Problem mit der libpng-Sache. Nur, der angegebene Tipp mit dem In-Befehl klappt bei mir nicht. Es kommt der Command not Found

Kann mir da jemand weiterhelfen? Die LIBPNG*.* sind vorhanden.

Moin!

Der Befehl lautet nicht In, sondern ln (ein kleines L).
 
Back
Top