• This forum has a zero tolerance policy regarding spam. If you register here to publish advertising, your user account will be deleted without further questions.

WBB2 auf Suse9.0

CoBrEtTi

Registered User
Hallo erstmal,


bevor ich zum eigentlichen komme kurze Systemvorstellung:

Dediz. Server, Suse9.0 :rolleyes: , confixx ..
phpMyAdmin 2.5.6, MySQL 4.0.15, php, perl, apache2, ..
Provider: webtropia

Alles soweit okay.. Habe nun das WoltLab 2.2.1 installiert, es gab keine Fehler meldungen wärende der installation. Beim Posten eines Beitrages, egal welche usergruppe; Amdin, mod, smod, gast, regget-user ... ab einer Beitragslänge von 1000 Zeichen werden die Beiträge nicht gespeichert.. sprich 1000 +1 Zeichen!! ? ? 1000 und drunter sind okay :eek:
Wenn man nun auf "Vorscha" klickt bekomm ich das hier als Fehlermeldung "Es wurden nicht alle Felder ausgefüllt" !! Wenn man "Beitrag Speichern" klickt bekommt man das gleiche als Fehler.. allerdings wird nix gespeichert..
Beitrag wird gelöscht, und was übrigbleibt ist nur der Titel..
Wenn man die Nachrichtenlänge prüft, ist ein Javascript, sagt er mir auch "3846 Zeichen von 10000 max Zeichen" .. sobald ich Beitrag speicher drücken is alle swieder wech..

Die Einstellungen,sind alle Original auf 10000 Zeichen gesetzt! Habe das auch in der options.inc.php "$postmaxchars = "10000";" nochmals geprüft,, in der MySql datenbank habe ich auch nochamls den Eintrag gefunden, und auch dort sind 10000 Zeichen als Beitragslänge eingetragen!!

Diese Fehler habe ich sowohl bei einem 2.2.1 woltlab als auch bei einem 2.3.0 woltlab .. beide boards original !! nichts am code gepfuschft.. die boards sind installt und im orgi. zustand gelassen... Ich text deshalb soviel, um einige fragen aus der welt zu schaffen, da ich schon das halbe netz gesucht habe...
Ich schliesse das Board script aus als fehlerquelle, da der gleiche script auf nem debian lüppt .. und wende mich an Linux götter :D ... da ich fest davon überzeugt bin, das es eine einstellung am server selbst ist, bzw. der Server die fehlerursache ist !?!?! :confused:

Danke in vorraus, bin für jede Hilfe Dankbar!
 
Ich nutze auch das WBB, nur mal neben bei hast du die rechte (chmod) Richtig vergeben ??
wenn ja dann schau mal in den Gruppen nach,
 
Ja, die rechte sind alle laut Anleitung vergeben.. folgende ordner bzw files auf chmod 777 ..


Code:
/attachments
 /images/avatars
 /acp/lib
 /acp/temp
 /cache/templates
 /cache/templates/acp
 /cache/language
  
 /acp/lib/config.inc.php
 /acp/lib/options.inc.php
 
Hallo!
Was sagt Woltlab dazu? Schließlich hast du doch für die Software bezahlt.

mfG
Thorsten
 
Aus denen ihre Sicht war alles okay, code war okay!

Habe es auch schon rausbekommen was es war.
Mein provider hat einen Sicherheitspatch (Hardened-PHP) installiert. :eek:

Falls einer auch mal so prob hat einfach in seiner php.ini
Code:
varfilter.max_value_length = 10000
einfügen ... fertig!

Wer mehr als 10000 Zeichen braucht, dementsprechend ändern.
Mehr zum thema Hardened-PHP findet man HIER :)
 
Back
Top