• This forum has a zero tolerance policy regarding spam. If you register here to publish advertising, your user account will be deleted without further questions.

vServer S4Y Debian: Mail funzt net bei mehr als einem Empfänger

Petzi

Registered User
Hi Leute,

bei meinem ganz neu installierten und noch nicht upgedateten oder anderweitig verändertem vServer von S4Y habe ich folgendes Problem:

Wenn ich in Confixx ganz normal E-Mail-Adressen anlege, die nur einen Empfänger haben (ob Postfach oder Weiterleitung ist egal), dann funktioniert es problemlos.

Sobald ich aber einen zweiten Empfänger unter Nebenempfänger 1 eintrage (oder noch mehr Empfänger), dann kann ich keine Mails mehr an diese Adresse (also die die ich in Confixx angelegt habe) senden.

Wenn ich dann aber die Nebenempfänger wieder herausnehme, dann klappt das wieder ohne Probleme.

Hat jemand eine Ahnung, was das sein könnte und was man machen könnte, dass Sammelmails wieder funktionieren?

Danke!

Gruß, Petzi
 
Was sagt denn der Maillog dazu?
Und: guck mal in /etc/exim4/confixx/virtualusertable ob die korrekt aussieht.
 
/etc/exim4/confixx/virtusertable schaut folgendermaßen aus:

Bei normalen Adressen mit einem Empfänger:
z.B. adresse1@domain.de web1p1
adresse2@domain.de user@t-online.de

Bei Adressen mit mehreren Empfängern:
z.B. sammeladresse1@domain.de confixx-du-74


Wenn ich das richtig sehe, dann wird jetzt in /etc/exim4/confixx/confixx-verteiler nach confixx-du-74 geschaut:

confixx-du-74: web1p1#user@t-online.de
confixx-du-17: user1@t-online.de#user2@t-online.de, user3@t-online.de

Wobei mir auffällt, dass zwischen dem Hauptempfänger und den Nebenempfängern eine Raute steht, zwischen den Nebenempfängern aber nur ein Komma.

Kann das der Grund sein?
 
Wenn ich an sammeladresse1@domain.de eine Mail schreibe erhalte ich folgende Fehlermeldung zurück:

"Reporting-MTA: dns;<entfernter_Mailserver>
Received-From-MTA: dns;<Mailserver_zwischen_eigenem_und_entferntem>
Arrival-Date: Thu, 31 Mar 2005 13:02:12 +0200

Final-Recipient: rfc822;web1p1#user@t-online.de
Action: failed
Status: 5.1.1"


In meinem Maillog steht folgendes:

"2005-03-31 13:02:08 1DGxRA-0000Bv-E2 <= absender@domain.de H=(WORKSTATION) [Absender-IP-Adresse] P=asmtp A=login_saslauthd:web1p1 S=1244
2005-03-31 13:02:10 1DGxRA-0000Bv-E2 => web1p1#user@t-online.de <sammeladresse1@domain.de> R=dnslookup T=remote_smtp H=MX-Eintrag_vom_entfernten_Mailserver [Mailserver_IP-Adresse]
2005-03-31 13:02:10 1DGxRA-0000Bv-E2 Completed"

Hoffe man kann noch erkennen, was ich meine, obwohl ich die Daten abgeändert habe ;)

Für mich schauts fast so aus, dass er die Raute nicht als Trennungszeichen erkennt, sondern die erste und zweite Adresse als eine erkennt?

Deswegen bekomme ich auch erst vom Empfängerserver eine Fehlermeldung, wenn ich als Hauptempfänger ein Postfach drin hab. Dann schaut die Adresse nämlich so aus: web1p1#user@t-online.de

Wenn ich an eine Adresse sende, in der der Hauptempfänger auch eine Weiterleitung ist, dann bekomme ich sofort eine Fehlermeldung, noch bevor die Übermittlung klappen konnte, weil da möglicherweise die Mailadresse so aussieht: user1@t-online.de#user2@t-online.de

Das wäre für mich erklärbar, was meinst Du? :confused:
 
Da ich auch einen Vserver von S4Y hab hab ichs gleich mal ausgetestet
Und es stimmt es liegt an der "#".

Bei mir macht er genau den gleichen Fehler. Das Problem ist: Confixx erstellt den Verteiler mit dem Updatescript ob sich an dem Erstellungs-Zyklus was ändern läßt...Keine Ahnung. Ich schau gerade mal...

Update: Tja scheint ein Bug in Confixx zu sein, und die Scripts kann ich nicht ändern, da sie , verständlicherweise, verschlüsselt sind.
 
Last edited by a moderator:
Ich hab jetzt mal die Datei /etc/exim4/confixx/confixx-verteiler abgeändert und die '#' durch ', ' ersetzt. Hoffe Confixx überschreibt das nicht wieder?

Jedenfalls funktioniert jetzt die Adresse so wie sie sollte.

Danke Dir!
 
Ich befürchte, sobald du etwas veränderst am Verteiler oder jemand einen neuen Verteiler macht oder oder wird das von Confixx überschrieben.

Das funktioniert nur solange keiner an IRGENDEINEM Verteiler (und seis auch ein anderer Kunde) rumspielt.

Deswegen wäre das für mich keine "befriedigende" Lösung, allerdings fällt mir im Moment auch keine andere ein als den Support anzurufen und sie auf den Bug hinzuweisen.
 
Du hast Recht. Habs gerade ausprobiert und einen neuen Verteiler eingerichtet und schon sind die # wieder drin.

Hab diesen Thread mal als Supportticket aufgegeben. Mal schauen was da raus kommt...
 
Hier übrigens - der Vollständigkeit halber - noch die Antwort von S4Y:

"01.04.2005 17:54 -
Sehr geehrter Kunde,

leider ist dies in der Tat ein Confixx-Bug, wir haben dieses Problem bereits an den Herstellerfirma von Confixx gemeldet und warten auf eine Problemlösung."

Na dann bin ich mal gespannt...
 
Jut...also warten wir auf Bugfixe für eine Version die nicht mehr supportet wird von SW Soft...bin ja mal gespannt ;)

Wäre Confixx OpenSource hätte man sich jetzt mal eben schnell ein Bugfix schreiben können. - Ist wahrscheinlich nur nur eine # zu viel irgendwo im Quellcode # gegen , tauschen und fertig...

Wir merken: Ja Opensource hat schon einen guten Grundgedanken und wird nur von Kapitalisten verhöhnt :)
 
Naja, ich hoffe das Probleme wird bald gefixt. Stört mich auch schon seit längerem...
 
Last edited by a moderator:
Ich bin bei webhostlist.de über die Lösung gestolpert. Hier der Link:

http://forum.webhostlist.de/show/showthread.php?t=55166

Und hier noch die genaue Erklärung:
1) Öffne als root mit vim die /etc/exim4/confixx/makemap
2) in Zeile 10 befindet sich folgendes:
sed 's/ /#/'
tausche das aus durch:
sed 's/ /,/'
3) in Zeile 11:
sed 's/#/ /'
tausche das aus durch:
sed 's/,/ /'

4) vim mit ESC, :wq schließen
5) ./makemap ausführen, dann sollte es gehen

Die weiter beschriebene Vorgehensweise mit dem @ habe ich nicht durchgeführt. Jedenfalls funktioniert es jetzt bei mir!
 
Oder aber den Confixx Cronjob abändern:

Code:
6,16,26,36,46,56 * * * * root  /usr/local/confixx/confixx_counterscript.pl;cat /etc/exim4/confixx/confixx-verteiler |sed "s/\#/\,/">tmp.txt;mv tmp.txt /etc/exim4/confixx/confixx-verteiler

-Torsten
 
Back
Top