VServer Postfix Emailversand 1und1

madscience

New Member
Hallo zusammen,

bitte nicht gleich hauen :)

Folgende Situation:
Ich habe mir bei 1und1 vor Kurzem einen vituellen Clous Server gebucht, auf diesem ist Debian installiert und administriert wird das Ganze mit Plesk. Ich betreibe damit eine Wordpress Seite, funktioniert bis dahin auch.

Jetzt kommt das Problem:
Postfix - ich finde hier im Forum viele Beiträge zu diesem Thema und auch immer wieder den Verweis, dass es gute Tutorials im Internet gibt - leider finde ich diese aber nicht. Im Prinzip möchte ich gar keinen richtigten Mailserver aufsetzen, da nutze ich das benutzerfreundliche Emailsystem meines Anbieters.

Aber trotzdem muss ich Emails über Wordpress versenden, beispielsweise um einem neuen Abonnementen eine Betäigungsemail zu senden. Diese Emails kommen aber nicht durch und bleiben im PLesk in der Warteschlange hängen, ich komme einfach nicht weiter.

Kann mir jemand einen Tipp geben, wie ich das bewerkstelligen kann? Ich habe bereits in der Postfix config über putty ein paar Versuche gestartet, kriege es aber nicht hin? Kann mir jemand einen heißen Tipp geben, wie ich weiter komme? Gegebenenfalls auch den Link zu einem Tutorial, dass mit weiterhelfen wird?

Danke und viele Grüße! Mad Science!
 

nexus

Well-Known Member
Sende eine Testmail ab, merke dir die genaue Uhrzeit, gehe in dein Mailserver-Logfile und schau nach, was zu diesem Zeitpunkt dort steht.
 
A

andreas0

Guest
Aber trotzdem muss ich Emails über Wordpress versenden, beispielsweise um einem neuen Abonnementen eine Betäigungsemail zu senden. Diese Emails kommen aber nicht durch und bleiben im PLesk in der Warteschlange hängen, ich komme einfach nicht weiter.
Da bei 1und1 der Port 25 ausgehend standardmäßig bei den Cloud-Servern geschlossen ist, mußt du den Support bitten, diesen für dich öffnen zu lassen.
 

greystone

Member
bitte nicht gleich hauen ;)
Falsches Forum ;)

Im Prinzip möchte ich gar keinen richtigten Mailserver aufsetzen, da nutze ich das benutzerfreundliche Emailsystem meines Anbieters.
Weise Entscheidung. Du kannst afaik bei WordPress direkt auch die Zugangsdaten für Deinen Anbieter Account eintragen.

Falls Port 25 geschlossen ist, kannst Du es mit 587 probieren.
 

danton

Debian User
Da viele Pakete bei Debian ein virtuelles Mail-Server-Paket voraussetzen, sollte aber auch nicht ganz darauf verzichtet werden. Da braucht es aber keinen Postfix für, sondern es reicht ein minimaler Mail-Server aus. Ich nutze für solche Zwecke gerne nullmailer, der recht einfach zu konfiguriere, andererseits aber einiges an Features bietet (im Gegensatz z.B. zu ssmtp). Der macht letztendlich nichts anderes, als Mails, die über /usr/sbin/sendmail verschickt werden wollen, an einen Mail-Server weiterzuleiten, der dann die Verteilung übernimmt (z.B. in deinem Fall der von 1&1)
Die einzige Frage wäre, wie sich nullmailer mit Plesk verträgt - sollte aber eigentlich klappen, da der Mail-Server für Plesk lt. deren Doku ein optionales Feature ist. nullmailer läßt sich halt nicht über Plesk administrieren, aber ist mit der Anpassung von ein paar Konfigdateien per SSH auch kein Hexenwerk.
 

madscience

New Member
Hallo zusammen,

vielen Dank für eure tollen Antworten. Ich war ganz überrascht, wie schnell einem hier Hilfe angeboten wird. Den Port 25 habe ich bei 1und1 freischalten lassen, das hat aber noch nicht geholfen.

Den Tipp von Danton (Verwendung Nullmailer) werde ich definitiv ausprobieren, habe in der Zwischenzeit ein paar Sachen ausprobiert.

Zuerst habe ich postfix und dovecot runtergeschmissen und neu installiert, danach habe ich nochmal versucht Mails zu verschicken. Folgendes steht im Log, Postfix it allerdings erstmal ganz frisch aufgesetzt.

Code:
Sep  8 07:35:05 mein-serverprojekt postfix/postfix-script[49887]: starting the Postfix mail system
Sep  8 07:35:05 mein-serverprojekt postfix/master[49889]: daemon started -- version 2.10.1, configuration /etc/postfix
Sep  8 07:35:05 mein-serverprojekt dovecot: master: Warning: Killed with signal 15 (by pid=49917 uid=0 code=kill)
Sep  8 07:35:05 mein-serverprojekt dovecot: master: Dovecot v2.2.27 (c0f36b0) starting up for imap, pop3, sieve (core dumps disabled)
Sep  8 07:35:10 mein-serverprojekt /usr/lib64/plesk-9.0/psa-pc-remote[46736]: PleskFilter: mi_stop=1
Sep  8 07:35:22 mein-serverprojekt dovecot: master: Warning: SIGHUP received - reloading configuration
Sep  8 07:35:25 mein-serverprojekt postfix/postfix-script[53869]: refreshing the Postfix mail system
Sep  8 07:35:25 mein-serverprojekt postfix/master[49889]: reload -- version 2.10.1, configuration /etc/postfix
Sep  8 07:37:29 mein-serverprojekt dovecot: master: Dovecot v2.2.27 (c0f36b0) starting up for imap, pop3, sieve (core dumps disabled)
Sep  8 07:37:30 mein-serverprojekt postfix/postfix-script[2132]: warning: not set-gid or not owner+group+world executable: /usr/sbin/postdrop
Sep  8 07:37:30 mein-serverprojekt postfix/postfix-script[2166]: starting the Postfix mail system
Sep  8 07:37:30 mein-serverprojekt postfix/master[2183]: daemon started -- version 2.10.1, configuration /etc/postfix
Sep  8 07:38:18 mein-serverprojekt check-quota[2823]: Starting the check-quota filter...
Sep  8 07:38:18 mein-serverprojekt check-quota[2823]: Starting the check-quota filter...
Sep  8 07:38:18 mein-serverprojekt journal: plesk sendmail[2822]: handlers_stderr: SKIP
Sep  8 07:38:18 mein-serverprojekt journal: plesk sendmail[2822]: SKIP during call 'check-quota' handler
Sep  8 07:38:18 mein-serverprojekt postfix/pickup[2316]: E41AC810AFDC: uid=10000 from=<ich.selbst@mein-serverprojekt.de>
Sep  8 07:38:18 mein-serverprojekt postfix/cleanup[2828]: E41AC810AFDC: message-id=<2b48a0ee9e0a763d66a66dd51a45eb58@www.mein-serverprojekt.de>
Sep  8 07:38:19 mein-serverprojekt postfix/qmgr[2317]: E41AC810AFDC: from=<ich.selbst@mein-serverprojekt.de>, size=886, nrcpt=1 (queue active)
Sep  8 07:38:19 mein-serverprojekt postfix/smtp[2830]: E41AC810AFDC: host smtp-02.tld.t-online.de[194.25.134.12] refused to talk to me: 554 IP=82.165.166.66 - A p
Sep  8 07:38:19 mein-serverprojekt postfix/smtp[2830]: E41AC810AFDC: to=<ichselbst@mein-empfänger.de>, relay=smtp-01.tld.t-online.de[194.25.134.76]:25, d
So weit so schlecht, stehe recht ratlos da. Aus Datenschutzgründen habe ich die Emailadressen und Serverbezeichnungen geändert, falls sich jemand fragt.

Danke für eure Hilfe! Gruß Madscience!


P. S. Die Serverdaten in Wordpress einzutragen und auf diese Art zu versenden würde das Problem nicht wirklich lösen, da verschiedene Emailadressen verwendet werden. Hatt ich ganz vergessen zu schreiben, aber danke für diesen Tipp.
 
Last edited by a moderator:

GwenDragon

Registered User
Ich stehe auch ratlos da ;) , weil du das Log nur teilweise kopiert hast!
Sep 8 07:38:19 mein-serverprojekt postfix/smtp[2830]: E41AC810AFDC: host smtp-02.tld.t-online.de[194.25.134.12] refused to talk to me: 554 IP=82.165.166.66 - A p
Sep 8 07:38:19 mein-serverprojekt postfix/smtp[2830]: E41AC810AFDC: to=<ichselbst@mein-empfänger.de>, relay=smtp-01.tld.t-online.de[194.25.134.76]:25, d
Sieht danach aus als sei dein Server bei T-Com auf einer Blacklist.
Lies bitte http://postmaster.t-online.de/#t4.
Frage mal bei tosa@rx.t-online.de an.
 
Last edited by a moderator:

madscience

New Member
Nachtrag - ich habe jetzt Postfix und Dovecot runtergeschmissen und MSMTP installiert - bin aber mittlerweile sehr verwirrt und finde widersprüchliche Informationen zur Einrichtung. Wenn mir jetzt noch jemand einen Hinweis gibt, wie ich MSMTP einrichte wird es hoffentlich funktionieren. Habe mich gerade mit Putty und Midnight Commander auf meinem Server umgesehen aber finde die Konfiguartionsdatei nicht. In Plesk kann ich zwar ebenfalls Anagben zum SMTP Server machen, aber nur die im Screenshot verfügbaren. Screenshot ist hier im Googledrive
https://drive.google.com/open?id=0B8_ieECBTDmXeGt3a0FQMXM1Vmc. Merci Beaucoup.
 

madscience

New Member
Ich stehe auch ratlos da ;) , weil du das Log nur teilweise kopiert hast!

Sieht danach aus als sei dein Server bei T-Com auf einer Blacklist.
Lies bitte http://postmaster.t-online.de/#t4.
Frage mal bei tosa@rx.t-online.de an.
Ups Sorry, hier die fehlenden Fragmente.

Code:
Sep  8 07:35:25 mein-serverprojekt postfix/postfix-script[53869]: refreshing the Postfix mail system
Sep  8 07:35:25 mein-serverprojekt postfix/master[49889]: reload -- version 2.10.1, configuration /etc/postfix
Sep  8 07:37:29 mein-serverprojekt dovecot: master: Dovecot v2.2.27 (c0f36b0) starting up for imap, pop3, sieve (core dumps disabled)
Sep  8 07:37:30 mein-serverprojekt postfix/postfix-script[2132]: warning: not set-gid or not owner+group+world executable: /usr/sbin/postdrop
Sep  8 07:37:30 mein-serverprojekt postfix/postfix-script[2166]: starting the Postfix mail system
Sep  8 07:37:30 mein-serverprojekt postfix/master[2183]: daemon started -- version 2.10.1, configuration /etc/postfix
Sep  8 07:38:18 mein-serverprojekt check-quota[2823]: Starting the check-quota filter...
Sep  8 07:38:18 mein-serverprojekt journal: plesk sendmail[2822]: handlers_stderr: SKIP
Sep  8 07:38:18 mein-serverprojekt journal: plesk sendmail[2822]: SKIP during call 'check-quota' handler
Sep  8 07:38:18 mein-serverprojekt postfix/pickup[2316]: E41AC810AFDC: uid=10000 from=<ich.selbst@mein-serverprojekt.de>
Sep  8 07:38:18 mein-serverprojekt postfix/cleanup[2828]: E41AC810AFDC: message-id=<2b48a0ee9e0a763d66a66dd51a45eb58@www.mein-serverprojekt.de>
Sep  8 07:38:19 mein-serverprojekt postfix/qmgr[2317]: E41AC810AFDC: from=<ich.selbst@mein-serverprojekt.de>, size=886, nrcpt=1 (queue active)
Sep  8 07:38:19 mein-serverprojekt postfix/smtp[2830]: E41AC810AFDC: host smtp-02.tld.t-online.de[194.25.134.12] refused to talk to me: 554 IP=82.165.166.66
 - A problem occurred. (Ask your postmaster for help or to contact tosa@rx.t-online.de to clarify.) (BL)
Sep  8 07:38:19 mein-serverprojekt postfix/smtp[2830]: E41AC810AFDC: to=<ich.selsbt@mein-serverprojekt>, relay=smtp-01.tld.t-online.de[194.25.134.76]:25,
 delay=0.27, delays=0.14/0.07/0.07/0, dsn=4.0.0, status=deferred (host smtp-01.tld.t-online.de[194.25.134.76] refused to talk to me: 554 IP=82.165.166.66 - A problem occurred.
(Ask your postmaster for help or to contact tosa@rx.t-online.de to clarify.) (BL))
Ja die Telekom will nicht mit mir reden, wie gemein. :)

Ich vermute, dass ich in Postfix theoretisch erstmal die Angaben zu Host etc neu konfigurieren muss. Denke aber, dass eine hoffentlich einfachere Lösung mit MSMTP bald gelingt. :)

Danke und Gruß. Madsciene.
 
Last edited by a moderator:
A

andreas0

Guest
Jetzt geht es endlich! Dank Umstellung auf MSMTP!
Wenn du eventuell schon früher gewußt hättest, dass bei 1und1 standardmäßig der Port 25 ausgehend gesperrt ist und hättest ihn durch 1und1 wieder freischalten lassen, so nehme ich mal an, hättest du es nicht auf MSMTP umstellen müssen.

Unter Umständen sind jetzt durch diese Maßnahme für die Zukunft sogar Probleme vorprogrammiert. Da Plesk beim nächsten größeren Update eventuell Konfigurationsdateien mit aktualisieren wird, die du eventuell per Hand optimiert hast.

Besser wäre es gewesen, wenn du den Unterbau von Plesk erst gar nicht geändert hättest. Es sei denn, du kennst Plesk vom Unterbau so gut, so dass du nach einem umfangreichen Update von Plesk Systemprobleme schnell wieder korrigieren kannst.
 

danton

Debian User
Da er wie oben bereits geschrieben eigentlich gar keinen eigenen Mailserver betreiben will, ist die Entscheidung für msmtp schon richtig - insbesondere vom Sicherheitsgedanken her (weniger Angriffsfläche als Postfix). Ich würde auch bei einem Plesk-Update mehr Probleme sehen, wenn Postfix in einer Konfiguration weiter genutzt würde, die Plesk so nicht vorsieht - msmtp dürfte ein Plesk-Update schlichtweg ignorieren. Der Mail-Server ist in Plesk lt. deren Doku schließlich optional.
Außerdem würde der Versand direkt vom Cloud-Server statt Relay über die 1&1 Mailserver auch nocht andere Probleme mit sich bringen (IP steht mind. einer Blacklist, es ist kein PTR gesetzt, usw.)
 
Top