• This forum has a zero tolerance policy regarding spam. If you register here to publish advertising, your user account will be deleted without further questions.

VPNC Verbindungsproblem

C

collecty

Guest
Hallo @ all,

hier ein Problem mit VPNC, aufgesetzt nach folgender Anleitung: https://waal70blog.wordpress.com/2019/01/14/connect-vpn-to-fritzbox-with-vpnc-from-debian-linux/

Ich betreibe mehrere VServer unter Debian Bullseye, die alle gleich konfiguriert sind.

Auf einem STRATO-VServer funktioniert VPNC zu meiner privaten Fritzbox problemlos. Nach Aufbau des Tunnels kann ich die Fritzbox mit ping 192.168.182.1 erreichen und auch NAS-Freigaben mounten.
tap0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1024
inet 192.168.182.200 netmask 255.255.255.255 broadcast 0.0.0.0
ether 1a:e6:9c:1f:1a:c3 txqueuelen 1000 (Ethernet)
RX packets 3 bytes 238 (238.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 3 bytes 238 (238.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

Kernel-IP-Routentabelle
Ziel Router Genmask Flags Metric Ref Use Iface
default 0.0.0.0 0.0.0.0 U 0 0 0 venet0
192.168.182.0 0.0.0.0 255.255.255.0 U 0 0 0 tap0

Auf einem RootServer bei NETCUP bekomme ich jedoch mit der gleichen Config keine IP-Verbindung hin. Der VPN-Dienst startet ohne Fehlermeldung und es schaut eigentlich gut aus:
tap0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1024
inet 192.168.182.200 netmask 255.255.255.255 broadcast 0.0.0.0
ether 7a:62:eb:f6:be:78 txqueuelen 1000 (Ethernet)
RX packets 0 bytes 0 (0.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 0 bytes 0 (0.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
default 88.60.30.1 0.0.0.0 UG 0 0 0 eth0
88.60.30.0 0.0.0.0 255.255.252.0 U 0 0 0 eth0
192.168.182.0 0.0.0.0 255.255.255.0 U 0 0 0 tap0

Bei dem Netcup-Server erhalte ich auf ping 192.168.182.1 keine Antwort und auch sonst gelingt keine IP-basierte Verbindung über VPNC zur privaten Fritzbox. Weiß jemand Rat, woran das liegen könnte?

Gruß, Collecty
 
Die Vermutung ist natürlich naheliegend. Auf beiden Servern läuft UFW. Ein komplettes Deaktivieren der UFW macht aber keinen Unterschied. Auf dem Server bei Netcup bekomme ich auch ohne Firewall keine IP-Verbindung hin.
 
Baust du die Verbindung von beiden Servern gleichzeitig auf oder trennst du sie auf dem Strato-Server, bevor du sie vom Netcup-Server aus startest?
 
Nein - nicht gleichzeitig. Ich baue den Tunnel mit vpnc-disconnect auf dem Strato-Vserver erst ab, bevor ich es auf dem Netcup-Server teste.
 
OK - ich hab eine Lösung gefunden. Auf dem Rootserver bei NETCUP funktioniert es mit einem tun device. In der conf-Datei unter /etc/vpnc habe ich in der Zeile
Interface mode tap
eine Umstellung auf tun vorgenommen. Damit ist jetzt eine IP-Verbindung möglich. Danke an NEXUS und DANTON für eure Hilfe.
 
Back
Top