VMware auf HETZNER Rootserver

Xeleon

New Member
Hallo zusammen,

vor einer Woche habe ich mir einen Rootserver (EQ4) bei Hetzner gemietet und wollte zwei virtuelle Server einrichten. Leider hat sich das als etwas komplizierter erwiesen als ich gedacht habe. Auf dem Hostsystem läuft Debian (Lenny) Minimalsystem und als Gastsystem sollte FreeBSD dienen.

Die ersten Versuche machte ich mit VirtualBox und nach einer Weile lief dank dieser Anleitung:
http://blog.damn1337.de/2009/07/hetzner-eq-serie-mit-zusatzlichen-ip-adressen-howto/
der erste virtuelle Server. Diesen konnte ich auch ohne Probleme von überall per SSH erreichen.

Nun soll es aber VMware Server werden und nicht VirtualBox. Also VirtualBox entfernt VMware Server installiert und Gastsystem im NAT Modus draufgespielt und eingerichtet. Leider läst sich der Server so nicht von außen erreichen und ich versuchte es genau so, wie ich es mit VirtualBox nach der Anleitung gemacht habe - aber leider funktioniert das nicht. Weiterhin habe ich das so versucht wie es Hetzner bei sich auf der Seite beschreibt,
http://wiki.hetzner.de/index.php/VMware_Externe_IP-Adressen_zuordnen_über_NAT
aber auch das ging schief. Wahrscheinlich weil die Beschreibung nicht gang vollständig ist und mir das nötige Wissen fehlt um es zu vervollständigen.

Kennt sich jemand mit der Geschichte aus und könnte mich etwas bei der Einrichtung unterstützen?

Wie muss VMware Server konfiguriert werden:
Bridged,
Nat,
oder HostOnly?

Was muss in der /etc/network/interfaces ändern?

net.ipv4.ip_forward=1 ist eingetragen


Langsam bin ich mit meinem Latein am Ende – hat vielleicht jemand ein Ansatz für mich?

Gruß / und Danke
 

Xeleon

New Member
Hi,

habe gestern das ganze noch einmal versucht.
Neues Gastsystem (FreeBSD) mit NAT eingerichtet und anschließend auf Hostonly umgestellt.
Aber leider keine Verbindung nach außen.
Beim beantragen der zusätzlichen IP’s bei Hetzner bekam ich einen Link wie die zusätzlichen IP’s eingerichtet werden sollen.
http://wiki.hetzner.de/index.php/Zusätzliche_IP-Adressen_Debian#Zus.C3.A4tzliche_IP-Adressen
Dies habe ich getan und meine /etc/network/interfaces des Hosts sieht jetzt so aus:

## Hetzner Online AG - installimage
# Loopback device:
auto lo
iface lo inet loopback

# device: eth0
auto eth0
iface eth0 inet static
address 178.xxx.xxx.74
broadcast 178.xxx.xxx.127
netmask 255.255.255.255
gateway 178.xxx.xxx.65
pointopoint 178.xxx.xxx.65

addresses 178.xxx.xxx.110/32

Anschließend nach der Instruktion auf dieser Seite weiter verfahren:
http://wiki.hetzner.de/index.php/VMware_Externe_IP-Adressen_zuordnen_über_NAT


Weitere Daten:

vmnet1 von VMware ist hostonly und hat die IP: 192.168.2.1/255.255.255.0
das erste Gastsystem hat die IP: 192.168.2.110/255.255.255.0
als Default GW und DNS-server ist 192.168.2.1 eingetragen (vmnet1)

Im Hostsystem kamen noch die beiden Einträge in die Console:

iptables -t nat -I PREROUTING -d 178.xxx.xxx.110 -j DNAT --to 192.168.2.110
iptables -t nat -I POSTROUTING -s 192.168.2.110 -j SNAT --to 178.xxx.xxx.110


Intern kann ich alles und jeden Anpingen, aber die Verbindung zum Gast von außen und vom Gast nach außen bleibt verwert.

Und wenn ich mich von außen per SSH versuche am Gast anzumelden - also ssh name@178.xxx.xxx.110 verbinde ich mich mit dem Hostsystem und nicht mit dem Gast.

Firewall habe ich zum Testen komplett ausgeschaltet.

Also ich steige in dem Wirwar zurzeit nicht durch, jemand einen Tipp was ich falsch gemach habe?

Gruß
 
Top