Verzweiflung pur: HDD Performance Probleme mit HP DL380 G6

FirstSoul

New Member
Moin,

so langsam falle ich von meiner Kompetenz ab... Ich weiß einfach nicht weiter. Jetzt bin ich auf eure Hilfe angewiesen.
Ich habe massive Performance Probleme in meinem HP DL380 G6.
Die Hardware liste ich unten auf.

Als OS läuft ESXi 6.0U3 (HP Version), aktuellste Treiber und Updates. Meine VMs sind teilweise ultra langsam. Besonders wenn ich ein Filebackup von meiner NAS VM auf meinen Backup Server kopiere. Er hat jetzt gerade mal 800GB in 48 Stunden geschafft. 1Gbit Netzwerk! Ich habe schon alles gecheckt. Netzwerkprobleme sind auszuschließen.
Ein HDD Test über die ESXi Shell nach diesem Tipp: Geschwindigkeitstest Schreibgeschwindigkeit Storage - SAN oder Festplatte - unter VMware ESX oder ESXi – znilwiki
hat folgendes erbracht:

mit dem P410i 1GB FBWC Controller:
Write: 67 MByte/s
R/W: 33,9 MByte/s

mit dem P420 1GB FBWC Controller:
Write: 29,34 MByte/s
R/W: 16,49 MByte/s

Der Cache ist bei beiden mit Write 75% / Read 25% konfiguriert.

Ich habe nun Drei Möglichkeiten, woran es liegen kann:

1) HDDs --> Zu langsam
2) RAID Controller --> Zu langsam/alt/was auch immer
3) RAID Level = 5 --> RAID5 doch zu langsam?

Folgendes habe ich getestet:

Zu 1) Aktuell kein Geld für andere Festplatten
Zu 2) Habe es mit dem P420 getestet. Sogar schlechtere Ergebnisse
Zu 3) Zwei Platten dazu und RAID50 testen oder Vier HDDs dazu und RAID10 testen?

Alternativ:
Zwei Festplatten im RAID1 an den P410i für die VMs
Vier Festplatten im RAID5 an den P420 und direkt an die NAS VM per PCI Passthrough anbinden
Was aber mit den beiden SAS Kabeln in dem SSF Case nicht geht.... Muss ein zweites Case her.

Was meint ihr?

Meine Hardware:
HP DL380 G6
2x Intel(R) Xeon(R) CPU L5640 @ 2.27GHz
64GB ECC RAM
HP P410i 1GB FBWC RAID Controller
Zum Test: HP P410 1GB FBWC RAID Controller
1Gbit onBoard Ethernet Adapter
6x HGST Travelstar Z5K1 HTS541010B7E610 - Festplatte - 1TB - 5400 U/min ---> RAID5
OS: ESXi 6.0U3 (HP Version)

Hier die Details vom P410i über HPSSA CLI:

Code:
Smart Array P410i in Slot 0 (Embedded)
   Bus Interface: PCI
   Slot: 0
   Serial Number: XXXXXXXXXXXXXX
   Cache Serial Number: XXXXXXXXXXXXXXXX
   Controller Status: OK
   Hardware Revision: C
   Firmware Version: 6.64-0
   Rebuild Priority: Medium
   Expand Priority: Medium
   Surface Scan Delay: 15 secs
   Surface Scan Mode: Idle
   Parallel Surface Scan Supported: No
   Queue Depth: Automatic
   Monitor and Performance Delay: 60  min
   Elevator Sort: Enabled
   Degraded Performance Optimization: Disabled
   Wait for Cache Room: Disabled
   Surface Analysis Inconsistency Notification: Disabled
   Post Prompt Timeout: 0 secs
   Cache Board Present: True
   Cache Status: OK
   Cache Ratio: 25% Read / 75% Write
   Drive Write Cache: Disabled
   Total Cache Size: 1.0
   Total Cache Memory Available: 0.9
   No-Battery Write Cache: Disabled
   Cache Backup Power Source: Capacitors
   Battery/Capacitor Count: 1
   Battery/Capacitor Status: OK
   SATA NCQ Supported: True
   Number of Ports: 2 Internal only
   Encryption: Not Set
   Driver Name: HPE HPSA
   Driver Version: 6.0.0.132-1OEM
   PCI Address (Domain:Bus:Device.Function): 0000:04:00.0
   Port Max Phy Rate Limiting Supported: False
   Host Serial Number: XXXXXXXXXXXXXX
   Sanitize Erase Supported: False
   Primary Boot Volume: None
   Secondary Boot Volume: None
Backupserver:
HP Microserver N54L
AMD Turion Neo N54L @ 2.00 GHz
8GB RAM
HP P410 1GB FBWC RAID Controller
1GBit Intel CT Desktop Ethernet
2x TOSHIBA MD04ACA4 - Festplatte - 4TB - 7200 U/min ---> RAID1
1x WDC WD10EAVS-00D + 1x Hitachi HDT72101 - Festplatte - 1TB - 7200 U/min ---> RAID1
 

Thunderbyte

Moderator
Staff member
6x HGST Travelstar Z5K1 HTS541010B7E610 - Festplatte - 1TB - 5400 U/min ---> RAID5
Du nutzt friggin 2,5" 5400 UPM NOTEBOOK Festplatten (also das langsamste Speichermedium, das man aktuell jenseits der Diskette kaufen kann) als Serverplatten und wunderst Dich, dass nichts geht!?!??!?!?!? :eek::confused:

Wenn man sich http://hdd.userbenchmark.com/SpeedTest/9932/HGST-HTS541515A9E630 (ist 1,5TB, aber ansonsten vermutlich die gleiche Serie) ansieht, dann sind die Dinger, wenns irgend etwas anderes als Sequential Reads/Writes sind SCHNARCHLANGSAM.

Der Server hat anscheinend nur 2,5" Slots. Die sind aber für 10.000 UPM Server HDs gedacht (gewesen), also diese hier: https://geizhals.de/?cat=hde7s&xf=1080_SAS+12Gb/s~1080_SAS+3Gb/s~1080_SAS+6Gb/s~3772_2.5 , nicht für Notebook Krücken, die noch dazu beileibe nicht für Dauerlauf geeignet sind. Alternativ kämen natürlich noch SSDs in Frage, die würden die Sache nochmals deutlich beschleunigen.

Davon abgesehen ist VSphere 6.7 aktuell (mit deutlich coolerem Webinterface), Deine Version ist 1,5 Jahre alt. Ein Update wäre hier angebracht nachdem Du vernünftige Platten gekauft hast.

1) HDDs --> Zu langsam
Zu 1) Aktuell kein Geld für andere Festplatten
Das ist das EINZIGE Problem. Hättest Du nicht Geld sinnlos für Laptops HDs versenkt, hättest Du jetzt statt dessen einige 10.000UPM HDs, die vernünftig arbeiten würden.:eek:
 
Top