Verzweifelung AUTH-DAEMON und SA24.conf

#1
Hallo,

ich bin total verzweifelt. Ich habe einen Root Server bei Strato. Der Server hatte heute morgen auf einmal ein Problem, dass er sporadisch Emails ablehnte.
Ich hatte daraufhin den internen Virenscanner abgeschaltet und konnte mich daraufhin nicht mehr auf der Serveradmin24 Oberfläche anmelden - Dienst angeblich nicht verfügbar.

Nun habe ich weiter festgestellt, dass die SA24.conf Datei offensichtlich zerschossen war. Wieder neu gemacht - hochgeladen, Rechte gesetzt, alles soweit ok.

Zudem Zeitpunkt lief alles einwandfrei wieder. Auf einmal kamen einige Emails wieder nicht an. Es gab einfach eine Rückmeldung ohne einen wirklichen mir ersichtlichen Grund. Ich habe daraufhin die Spameinstellungen für die beiden betreffenden Accounts geändert (es betraf nur zwei Accounts). Irgendwie kam es dann dazu, dass die Emails nicht mehr abrufbar waren. Er emldete Auth Fehler. Ich habe festegestellt, dass der Courier Authdaemon nicht startet. Ich glaube es ist ein Fehler in der Verbdinung zum MySql Server.

Kann mir irgendwer helfen?

Bitte :(
 

sbr2d2

Registered User
#2
Ein paar mehr Infos wären klasse.
Betriebssystem und welches Adminpanel wenn vorhanden, ein paar Zeilen aus den betreffenden Logs wären auch nett um das Problem etwas einzugrenzen.
 
#3
Ja sorry,

bin total durcheinander:

ServerAdmin24 Version: ServerAdmin24 3.2
Distribution: openSUSE 10.2 (i586)


Hier ein Auszug aus dem Mail Logfile:

Jul 12 12:42:53 h1337740 pop3d: Connection, ip=[::ffff:IP gelöscht]
Jul 12 12:42:53 h1337740 pop3d: Disconnected, ip=[::ffff:IP gelöscht]
Jul 12 12:42:53 h1337740 pop3d: Connection, ip=[::ffff:IP gelöscht]
Jul 12 12:42:53 h1337740 pop3d: authdaemon: s_connect() failed: Connection refused
Jul 12 12:42:53 h1337740 pop3d: [Hint: perhaps authdaemond is not running?]
Jul 12 12:42:53 h1337740 pop3d: LOGIN FAILED, user=Email gelöscht, ip=[::ffff:IP gelöscht]
Jul 12 12:42:53 h1337740 pop3d: authentication error: Connection refused



Was mir auffällt ist, dass die SA24.conf sich ständig löscht. Wie kann das sein?
 

d4f

Blog Benutzer
#4
Jul 12 12:42:53 h1337740 pop3d: authdaemon: s_connect() failed: Connection refused
Jul 12 12:42:53 h1337740 pop3d: [Hint: perhaps authdaemond is not running?]
Ich habe festegestellt, dass der Courier Authdaemon nicht startet. Ich glaube es ist ein Fehler in der Verbdinung zum MySql Server.
Üblicherweise startet er dann trotzdem. Führe mal folgendes durch.
http://www.courier-mta.org/authlib/README.authdebug.html
Zumal der Punkt ihn auf der Konsole laufen zu lassen sollte dir sagen welche Fehlermeldung ihn nicht starten lässt.


Was mir auffällt ist, dass die SA24.conf sich ständig löscht. Wie kann das sein?
Vermutlich ein Cronjob. Du kannst sie mit chattr +i unlöschbar machen aber es gibt vermutlich einen Grund für das Löschen.
 

TerraX

Active Member
#5
Maybe etwas off-Topic: Aber ist Serveradmin24 nicht schon seit 2010 von Strato beerdigt worden? Ich würde eine Migration auf ein aktuelles ACP in Erwägung ziehen.
 
#6
Ich habe nun den Debug Level auf 1 gesetzt. Normal sollte ich dann ja eine Info in der Mail Log bekommen.

Zitat:
Was mir auffällt ist, dass die SA24.conf sich ständig löscht. Wie kann das sein?

Vermutlich ein Cronjob. Du kannst sie mit chattr +i unlöschbar machen aber es gibt vermutlich einen Grund für das Löschen.
Es ist eher so, dass das Löschen nicht einem bestimmten Zeitrhythmus unterliegt, sondern vielmehr wenn ich Einstellungen im Bereich SA24 vornehme, dann ist auf einmal der Inhalt der SA24.conf leer.
 
#8
Einen Schritt weiter:

Nun hatte ich eine Fehlermeldung und es war einfach nur ein Leerzeile in der authdaemonrc.

Nun habe ich einen weiteren Fehler bekommen:

Jul 12 14:58:26 h1337740 authdaemond: failed to connect to mysql server (server=localhost, userid=root.): Access denied for user 'root.'@'localhost' (using password: YES)

Ich habe in der authmysqlrc bereits das Kennwort für den User root für die MySql SA24 Datenbank überprüft. Das stimmt soweit.

Wo kann ich noch nachsehen?
 

d4f

Blog Benutzer
#9
Access denied for user 'root.'@'localhost' (using password: YES)
dein User heisst "root." (Punkt am Ende.)
Sicher dass dieser wirklich so heisst?

Falls du "root" meinst; eeeeeek. Mailserver als Root auf die Datenbank lassen?!
 
Top