• This forum has a zero tolerance policy regarding spam. If you register here to publish advertising, your user account will be deleted without further questions.

Typo3 auf vserver@server4you???

B

BerK

Guest
Hallo,

erst einmal, ich bin Newbee! Aber nachdem ich mir vor einem Monat einen vserver bei s4u geleistet habe, will ich dann doch mal typo3 ausprobieren! Und nix geht! Ich habe so ziemlich alles was ich finden konnte gelesen, aber ichts hat geholfen! Die Installation per SSH / Telnet funktionierte zwar reibungslos, die Symlinks sind auch richtig gesetzt, aber es will einfach nicht klappen, bekomme immer wieder die 403 Forbidden Meldung! Kann mir einer ein Tip geben? Hat jemand Erfahrung mit typo3 auf vserver? Bitte dringend um Hilfe!

Danke BerK
 
BerK said:
Hat jemand Erfahrung mit typo3 auf vserver?
Hat hier jemand meinen Namen gerufen? ;)

Als erstes brauch ich Infos über Deine Typo3-Installation:
1.) Welche Version (3.6beta oder 3.5)?
2.) Weches Packet (dummy, freepage, quickstart)?
3.) Am wichtigsten: als zip oder tar.gz?
3.a) Wenn als tar.gz, hast Du die src und ein Packet gezogen?
4.) Wo hast Du installiert? (.../web1/html/...)?
5.) Wann tritt der 403-Fehler auf?
(bei http://webX.123456.vserver.de/index.php oder http://webX.123456.vserver.de/typo3/index.php?)

Die Infos brauche ich erstmal um helfen zu können.
Zusätzlich wäre es gut, wenn Du mir die Version Deiner GDlib und von ImageMagick sagst. Dann kann ich Dir dazu Einstellungstips geben.

huschi.
 
Ein Licht am Ende des Tunnels....

Moin Huschi,

danke für die fixe Antwort, hier die gewünschten Infos

1.-3a. bis dato 3.5.0-3tar.gz und die testsite3.5.0-3.tar.gz

4. /var/www/web1/html/...

5. Wenn ich alles installiert habe, dann sieht man ganz kurz die Weiterleitung und den InstallFrame, dann kommt egal wo die 403!

6. Wildcards hab ich nicht und subdomians auch nicht! Ist nur der Basic

7. GD ist 2.0.15 with FreeType

8. Laut php.info ist Virtual Directory Support disabled

Was kann ich noch tun?
 
Zusatz

Die imagamagick hat per rpm installation gestreikt, bin halt nur bsd user und kann besser mit meinen ports! habe die statische von weiland genommen! Genauso, wie xpdf und catdoc!
 
BerK said:
4. /var/www/web1/html/...
Heißt das, Du hast dort die Verzeichnisse 'typo3_src-3.5.0' und 'testsite-3.5.0'?
Oder hast Du das testsite-Packet so ausgepackt, daß es direkt unter html liegt?

Deine Fehlermeldung weißt halt darauf hin, daß irgendwas in der der Installation nicht stimmt. Daher frage ich nochmal nach.

Zweite Anlaufstelle wäre das error_log von Apache.
Evtl. steht da was drin, wie 'Symlinks not allowed' oder ähnliches. Die müßtest Du noch aktivieren. Meine Apache-Konfiguration zu dem Verzeichnis sieht übrigends so aus:
Code:
<Directory "/var/www/web5/html">
  Options -Indexes FollowSymLinks Includes MultiViews
  AllowOverride Indexes FileInfo Options
  PHP_ADMIN_FLAG safe_mode off
  PHP_ADMIN_VALUE safe_mode_exec_dir /
  PHP_ADMIN_VALUE open_basedir /
</Directory>
Die Directories sind offen, damit ImageMagick aus dem /usr/local/bin-Verzeichnis gestartet werden kann. Der safe_mode muß auf jedenfall aus, und wegen mangelnder 'Options FollowSymLinks' könnte es bei Dir haken. 'AllowOverride Options' brauchst Du um das Rewriting in Betrieb zu nehmen. (Aber erst, wenn die Installation läuft... ;) )

Wichtig ist auch, daß Du alles dem richtigen User zusprichst, damit die Schreibberechtigungen stimmen:
chmod -R web1:ftponly /var/www/web1/html/*


habe die statische von weiland genommen!
Damit kann man schon mal nichts falsch machen. Entpacke sie am besten nach /var/www/web1/files. Dann sind sie per http nicht erreichbar, aber von den PHP-Scripten schon.

PS: Denk dran die Zeile mit 'die...' aus typo3/install/index.php auszukommentieren, sonst hängst Du gleich am nächsten Fehler. ;)

huschi.
 
Ich versuche es

Wenn es nicht klappt, dann melde ich mich noch weiter, aber schonmal tausend Dank!
 
Noch wach?

Wo hast du die einstellung mit dem directory denn gemacht? überlagert die confixx_vhost.conf nicht die httpd.conf, oder muß das in beide eingetragen werden? Sitze noch länger dran vermute ich! Hast du nen eigenen kunden für das typo system angelegt und was sollt durch den res bzw admin zur verfügung gestellt werden?
 
BerK said:
Wo hast du die einstellung mit dem directory denn gemacht?
Wie üblich bei Confixx, entweder:
a) eine eigene conf-Datei anlegen und sie nach der confixx...conf includen, oder
b) einfach in die httpd.conf nach dem confixx-include.

Ich habe eine Directory-Sektion verwendet, da es die VirtualHost-Sektion ergänzt und nicht einfach nur überschreibt.

Hast du nen eigenen kunden für das typo system angelegt
Ja. Und habe das src-Packet direkt unter web5 installiert (nicht im html) und ich eröffne pro Domain ein eigenes Unterverzeichnis innerhalb von web5, setze die Links korrekt und den Eintrag im VirtualHost. So entfällt wahnsinnig viel Konfigurationsarbeit mit Typo3.

huschi.
 
Warn

Habe die Angaben, die Du mir gemacht hast per include myhttpd.conf eingefügt. Sofar so was auch immer, aber der Apache gibt folgende Warung aus:
[warn]name virtuelhost ipadresse:80 has no virtualhosts

Heißt das jetz es ist fürn a...?
 
BerK said:
[warn]name virtuelhost ipadresse:80 has no virtualhosts
Das hat der bestimmt auch schon vorher gemacht... ;)
Außerdem heißt das nichts.
Wichtiger ist, ob Du immer noch einen 403 bekommst.

huschi.
 
einen nach vor und einen zurück

Habe die Pakte jetzt nochmals unter ../html/ entpackt, die chmod hat er wegen web1:ftponly nicht angenommen! hab dann nur chgrp ftponly gesetzt, will aber immer noch nicht, kriege die beknackte 403 Meldung! Was habe ich falsch gemacht?
 
error_log gecheckt....

Das apache error_log gibt folgende Fehler an:

directory index forbidden by rule : /var/.../html/
nochmal
#dann meine Aufrufe per browser
(13)permission denied: /var/.../html/testsite-3.5.0
#das dann viermal!

Nehme mal an, das mein directory set in meiner myhttpd.conf den vhost mist von confixx nicht überschrieben hat! Übrigens, wenn ich das directory set in der httpd.conf da eintrage, wo die anderen sind gibts ne fehlermeldung! Bist du noch da?
 
habe Typo3 auf einem Vserver laufen, in der Directoryrule muss "Follow Symbolic Links" aktiv sein (notfalls muss man das mit Confixx auskämpfen, ich habs manuell in die http.conf geschrieben...)
dann tritt der fehler nimmer auf..habe auch einen Tag daran rumgedoktort bis es lief.
 
Kannst dich noch erinnern, wo genau du das eingetragen hast? oder kannst du mal deine conf ( nur ausschnittsweise posten)!
 
confixx ist sch...

Gibts denn ne Möglichkeit den Mist von Confixx zu löschen und stattdessen webmin zu nehmen?
 
BerK said:
directory index forbidden by rule : /var/.../html/
Dann liegt dort nicht Deine index.php von Typo3, oder in in httpd.conf sind die Indexfiles nicht korrekt deklariert (kann ich mir aber nicht vorstellen).

huschi.
 
Schluß für heut...

Ich habe jetzt so ziemlich alles durchprobiert, was ich mir noch so erklären konnte! Aber es hat leider nichts geklappt! Das Problem 403 bleibt bestehen! Werde also nochmal einen Reboot machen und morgen weiter versuchen!
Aber schon vorab ein paar Fragen:

-Kann die Hotline (0190) irgendetwas helfen??
-Hat nícht jemand eine Dokumentation oder einen Link oder ein HowTo?

Danke Euch! Bis morgen!
 
Back
Top