TS3 Autoscript funktioniert nicht

Brause_Junior

New Member
Hallo,
ich bräuchte mal eure Hilfe.


Folgendes habe ich gemacht:

-TeamSpeak3 Server erstellt und getestet, läuft
-TS3 Daten liegen in
Code:
/usr/local/teamspeak
-Unter
Code:
/etc/init.d/
Datei
Code:
teamspeak
mit Inhalt
Code:
#!/bin/sh 
### BEGIN INIT INFO 
# Provides: 		teamspeak3 
# Required-Start: 	$local_fs $network 
# Required-Stop:	$local_fs $network 
# Default-Start: 	2 3 4 5 
# Default-Stop: 	0 1 6 
# Description: 		Teamspeak 3 Server 
### END INIT INFO 


# INIT Script by www.SysADMINsLife.com 
###################################### 
# Customize values for your needs: "User"; "DIR"  

USER="teamspeak"
DIR="/usr/local/teamspeak" 

###### Teamspeak 3 server start/stop script ###### 

case "$1" in 
start) 
su $USER -c "${DIR}/ts3server_startscript.sh start" 
;; 
stop) 
su $USER -c "${DIR}/ts3server_startscript.sh stop" 
;; 
restart) 
su $USER -c "${DIR}/ts3server_startscript.sh restart" 
;; 
status) 
su $USER -c "${DIR}/ts3server_startscript.sh status" 
;; 
*) 
echo "Usage: {start|stop|restart|status}" >&2 
exit 1 
;; 
esac 
exit 0
erstellt

-Rechte auf 755 gesetzt
-Befehl
Code:
update-rc.d teamspeak Defaults
verwendet
-Teamspeak gestoppt und gestartet
-Server neu gestartet

Nachdem ich Server neugestartet habe startete TeamSpeak nicht neu!










-Befehl
Code:
/etc/init.d/teamspeak start
lieferte
Code:
-bash: /etc/init.d/teamspeak: /bin/sh^M: bad Interpreter: No such file or directory



-Befehl
Code:
cd /etc/init.d/
-Befehl
Code:
teamspeak start
lieferte
Code:
-bash: teamspeak: command not found
 

phibo

New Member
Womit bzw wie hast du denn das Initscript geschrieben? Probiers mal mit
Code:
apt-get install dos2unix
mv /etc/init.d/teamspeak /etc/init.d/teamspeak.bak
cat /etc/init.d/teamspeak.bak | dos2unix > /etc/init.d/teamspeak

Zu deiner letzten Fehlermeldung: Da /etc/init.d bzw "." nicht Teil deiner PATH-Umgebungsvariable ist, musst du ein "./" voranstellen, wenn du dich in /etc/init.d befindest und das Script "teamspeak" ausführen möchtest -> "./teamspeak start"
 

MadMakz

Member
dos2unix kannst du dir übrigens sparen wenn du den Kindergarteneditor (Notepad) nie wieder anrührst. Notepad++, PSPad uvm. bieten dir die Möglichkeit das richtige Format für Zeilenenden zu setzten.

Jedenfalls würde ich nach dem Formatfix auch nochmal z.B. via chkconfig schauen ob "teamspeak" auch wirklich als Start eingetragen ist denn ich denke nicht das update-rc.d teamspeak Defaults das tat was es die Erwartungshaltung erhofft hatte ;)

Danach benutzt du dann auch bitte nicht mehr ./teamspeak start sondern service teamspeak start und stellst vorher sicher das TS3 gestoppt & pidfile gelöscht ist (./teamspeak stop dürfte in dem Fall reichen). Ansonsten kannst du ein Problem u.a. mit den Pidfilerechten bekommen wenn du den Service beispielsweise zum Test als root gestartet hast und nicht sauber beendet wurde.
 
Last edited by a moderator:

anonemuss

New Member
Hallo.
Dazu gibt es einen noch viel simpleren Ansatz. :p
Denn Teamspeak liefert ein sh-Script mit. Am besten eine Config Datei nutzen und diese als Start-Parameter übergeben.
Bsp von meinem TS: ./ts3server_minimal_runscript.sh inifile=ts3server.ini'
Habe das nun einfach in die Initial System Bootup gesetzt als Respawn Process, was zur Folge hat, dass der TS Server sogar automatisch neu startet sollte er aus irgendwelchen Gründen crashen. :D

MFG
Anonemuss
 
Top