Suche,brauche hilfe für Probleme beim Debian root server ....

Onkel

Registered User
Hallo,

Ich habe vor kurzem mein Server gewechselt und seid dem geht beim Server fast nichts mehr, der Server braucht ewig um eine Seite zu laden.

Aufm Server läuft ein Realchat und ein CMS mit mehr als 10 000 registrierten User und durchschnittlich (leider durch die Probleme) 30 User Online.

Ich brauche jemanden der sich Server technisch auskennt und das Problem finden, dafür bin ich breit was zu zahlen.

Mein System:
Debian mit Plesk
Code:
Apache/2.0.54 (Debian GNU/Linux) FrontPage/5.0.2.2635 mod_python/3.1.3 Python/2.3.5 PHP/4.3.10-13 mod_ssl/2.0.54 OpenSSL/0.9.7e mod_webapp/1.2.0-dev mod_perl/1.999.21 Perl/v5.8.4
PHP-Version:
Code:
 4.3.10-13
MySql-Version:
Code:
4.0.24_Debian-5-log
Server bei 1u1 :

Intel Pentium 4
mit 3,0 GHz
2.048 MB DDR-RAM

Wer Lust hat ein verzweifelten Menschen zu helfen, sollte sich bei mir per PM melden.


Mit freundlichen Grüßen
 

society

Registered User
Am besten machste erstmal alles Module aus dem Apache raus die du nicht benötigt. Wie unteranderem Frontpage etc.

Danach solltest du einfach mal die Werte erhöhen in der httpd.conf.

Vielleicht weiß jemand hier genau bescheid über die 1und1 Debian Version
 

Onkel

Registered User
Ich habe die Lösung gefunden :) lag an der apache2.conf.

Ich hoffe ich habe es richtig gemacht, jedenfalls rennt die Seite.

Jetzt würde es mich interessieren wie ich die Module deaktivieren kann und welche ich deaktivieren kann.



Vorher

Code:
# prefork MPM
# StartServers ......... number of server processes to start
# MinSpareServers ...... minimum number of server processes which are kept spare
# MaxSpareServers ...... maximum number of server processes which are kept spare
# MaxClients ........... maximum number of server processes allowed to start
# MaxRequestsPerChild .. maximum number of requests a server process serves
<IfModule prefork.c>
StartServers         5
MinSpareServers      5
MaxSpareServers     10
MaxClients          20
MaxRequestsPerChild  0
</IfModule>



Nachher

Code:
# prefork MPM
# StartServers ......... number of server processes to start
# MinSpareServers ...... minimum number of server processes which are kept spare
# MaxSpareServers ...... maximum number of server processes which are kept spare
# MaxClients ........... maximum number of server processes allowed to start
# MaxRequestsPerChild .. maximum number of requests a server process serves
<IfModule prefork.c>
StartServers         5
MinSpareServers      30
MaxSpareServers     60
MaxClients          256
MaxRequestsPerChild  100
</IfModule>
 

HornOx

Registered User
Jetzt würde es mich interessieren wie ich die Module deaktivieren kann
Wenn du ein halbwegs normales Debian hast sollte das mit a2dismod gehn. Aber ich hab keine Ahnug ob Plesk da Nebenwirkungen hat.
NAME
a2dismod - disables an apache2 module

SYNOPSIS
a2dismod [module]

DESCRIPTION
This manual page documents briefly the a2dismod command.

a2dismod is a program that disables the specified apache2 module within the apache2 configuration.
Also z.b.
Code:
a2dismod cgi
/etc/init.d/apache2 force-reload
und welche ich deaktivieren kann.
Ohne zu wissen was du brauchst und was aktiv ist kann dir niemand die Frage beantworten. Schau mal per
Code:
ls /etc/apache2/mods-enabled/
nach was aktiv ist und entscheide selber.


Aber eigentlich würde ich dir emfehlen da nichts zu verändern, das sind nur ein paar zusätzliche MB die ungenützt im Speicher sind und ansonsten kaum stören. PHP und MySQL zu optimieren bringt meist mehr.

MaxClients 20
Mal eine neugierige Frage: Welcher Anbieter trägt so einen lächerlich niedrigen Wert in die Standartkonfiguration eines 3 GHz Servers ein?
 
Last edited by a moderator:

Onkel

Registered User
Mal eine neugierige Frage: Welcher Anbieter trägt so einen lächerlich niedrigen Wert in die Standartkonfiguration eines 3 GHz Servers ein?
Das war kein Anbieter, sondern die Standard Einstellung von Debian.

Jetzt brauche ich nur noch die optimalen mysql Einstellungen, ich habe in verschiednen Boards nachgeschaut aber es steht überall was anderes.


Das sind jetzt meine einstellungen.

# * Fine Tuning
#
skip-locking
Code:
table_cache             = 256
sort_buffer             = 4M
record_buffer           = 1M
net_buffer_length       = 8K
thread_stack            = 128K
myisam_sort_buffer_size = 64M
#
# * Query Cache Configuration
#
query_cache_limit       = 12M
query_cache_size        = 12M
query_cache_type        = 1
max_connection          = 500
#
# * Logging and Replication
#
# Both location gets rotated by the cronjob.
# Be aware that this log type is a performance killer.
#log = /var/log/mysql.log
#log = /var/log/mysql/mysql.log
 
Top