• This forum has a zero tolerance policy regarding spam. If you register here to publish advertising, your user account will be deleted without further questions.

Subversion/httpd 2.0.48-1.5.intergenia

HornOx

Registered User
Hallo,
ich versuche Subversion auf meinem Vserver zu installieren, aber irgendwie klappt es nicht:(
Das installieren der RH9.0 RPMs funktioniert ohne Fehlermeldungen aber wenn ich ein
Code:
LoadModule dav_svn_module modules/mod_dav_svn.so
in http.conf eintrage und apache neu starte gibts eine Fehlermeldung:
Code:
[root@devmode root]# /etc/init.d/httpd restart
Stopping httpd:                                            [  OK  ]
Starting httpd: httpd: module "/home/dsummers/rpms/build/subversion-1.0.1/subversion/mod_dav_svn/mod_dav_svn.c" is not compatible with this version of Apache (found 20020903, need 20020628).
Please contact the vendor for the correct version.
                                                           [FAILED]
Wenn ich beim Subversion-Sourcecode ein ./configure mache gibts nach einer weile folgende Fehlermeldung:
Code:
checking for static Apache module support... no
checking for Apache module support via DSO through APXS... found at /usr/sbin/apxs
checking httpd version... configure: error: apache too old:  mmn must be at least 20020903
Ich hab die Standart rh9-vserver Apache Version httpd 2.0.48-1.5.intergenia installiert(die sollte noch neu genug sein). Es gibt zwar mittlerweile Apache 2.0.49 aber da sind laut Changelog nur ein paar für mich unwichtige Bugs gefixed und es gibt noch kein rpm von der neuen Version deshalb hab ich keine Lust nur auf verdacht apache neu zu kompilieren. Das "20020903" sieht _sehr_ nach einem Datum aus, könnte es sein das einfach nur irgendwo im httpd 2.0.48-1.5.intergenia Packet oder sonstwo ein falsches Datum steht?
 
Mich wundert eher:
"(found 20020903, need 20020628)"
und:
"mmn must be at least 20020903"
dort sind die Angaben was gebraucht wird genau anders rum?! Es könnte auch sein, dass es inkompatibel zu Apache2 ist. Schonmal mit Apache 1.3.xx versucht?

Edit: Ok vergessen wir das mit Apache 1.3.xx .. ich hab mir gerade mal die FAQs des Projekts angeschaut. Ich muss gestehen ich habe bisher noch nicht davon gehört...
 
Last edited by a moderator:
djrick said:
Mich wundert eher:
"(found 20020903, need 20020628)"
und:
"mmn must be at least 20020903"
dort sind die Angaben was gebraucht wird genau anders rum?! Es könnte auch sein, dass es inkompatibel zu Apache2 ist. Schonmal mit Apache 1.3.xx versucht?

Edit: Ok vergessen wir das mit Apache 1.3.xx .. ich hab mir gerade mal die FAQs des Projekts angeschaut. Ich muss gestehen ich habe bisher noch nicht davon gehört...

Das Problem liegt darin das der Magic String gepatcht werden muss damit die Frontpage Extensions sauber mit Apache2 laufen, du kannst ja im Subversion configure mal suchen und das gegebenfalls aendern :) Mit einem Default Apache2 ohne FPSE funktioniert das aber.
 
Mich wundert eher:
"(found 20020903, need 20020628)"
und:
"mmn must be at least 20020903"
dort sind die Angaben was gebraucht wird genau anders rum?!
ein Fehler in der Fehlermeldung :rolleyes:
du kannst ja im Subversion configure mal suchen und das gegebenfalls aendern
danke :) jetzt hat das kompilieren funktioniert

gibt noch einen neuen Fehler aber da hab ich wenigstens schon eine Lösung: http://svnbook.red-bean.com/svnbook/apb.html#svn-ap-b-sect-1.2.11 (nur falls jemand auch Subversion installieren will) (KeepAlive sollte man bei apache auch noch anschalten)
 
Last edited by a moderator:
Back
Top