Strato Webserver: Allgemeine Fragen zur Domainverbindung

VRGround

New Member
Hallo zusammen, bin neu hier und würde gerne meine Frage mit euch teilen, in der Hoffnung, jemand kann mir weiterhelfen.

Ich arbeite als Azubi in einer Werbeagentur und möchte privat nun mein eigenes kleines Webprojekt zu gegebenem Anlass starten. Dazu durfte ich mir ein Template aus der Arbeit als Vorlage nehmen. Nun habe ich mir eine passende Domain für dieses Projekt auf einem Webserver von Strato geholt, habe über SFTP die Dateien aus dem Template hochgeladen und möchte diese nun mit der Domain verbinden.

Für alle, die Strato kennen und auch nutzen: Ich habe die Domainumleitung intern auf den entsprechenden Ordner und die index.php Datei gelegt, dann konnte ich auch das Template quasi live auf der entsprechenden Domain sehen.

Nun ist es aber so, sobald ich irgendein Element dieses Templates angeklickt habe, wurde ich zum Testserver meiner Firma weitergeleitet, auf dem dieses Template normalerweise läuft. Und auch, wenn ich zum Ausprobieren Änderungen an der style.css übernommen habe, hat sich zwar in der Datei auf dem Webserver was geändert, jedoch nicht live im Web selbst.

Liegt da ein Verbindungsfehler bei Strato vor? Oder muss ich irgendwas bei der Website selbst ändern, damit das so bleibt? Bei htaccess habe ich z.B. halt den Domainnamen angegeben, ansonsten weiß ich nicht weiter.

Vielleicht kann mir ja jemand weiterhelfen. Vielen Dank und liebe Grüße.
 

GwenDragon

Registered User
Da wirst du in deinem Template bei Links wohl absolute URLs drin haben, die noch mit dem Domain-Teil auf die Firma zeigen, oder du hast eeine htaccess-Datei oder Web-Proxy, welche falsch weiter leitet.
Zeig doch mal deine htaccess-Datei, mal sehen, ob die so richtig ist.

Was Links anbelangt, eine absolute URL kann z.B. so aussehen: https://www.example.org/index.php, eine domain-relative, die du ja brauchst, z.B. so: /index.php

Und um den aktuellen Inhalt einer Webseite zu sehen, ist manchmal ein Neuladen mit Ctrl+F5 im Browser nötig.
 
Last edited:

VRGround

New Member
Da wirst du in deinem Template bei Links wohl absolute URLs drin haben, die noch mit dem Domain-Teil auf die Firma zeigen, oder du hast eeine htaccess-Datei oder Web-Proxy, welche falsch weiter leitet.

Eine absolute URL kann z.B. so aussehen: https://www.example.org/index.php
Eine domain-relative, die du ja brauchst, z.B. so: /index.php
Ja, das vermute ich auch. Aber wie kann ich das ändern? Über htaccess habe ich geändert, dass, wenn ich den Domainnamen aufrufe, zu index.php gelange, das ist soweit geregelt. Aber die ganzen anderen Inhalte?

Wenn ich in der Nav z.B. auf Kontakt klicke, leitet er mich zum Testserver der Firma weiter. Die Verlinkung ist aber ganz normal - href="kontakt", welche Seite wiederum auch auf meinem Webserver drin ist. Gibt es da noch eine htaccess Regelung oder irgendwo anders, wo ich das quasi neu weiterleiten muss?
 

GwenDragon

Registered User
Ja, was das Template anbelangt musst du schon in den Quellocde reinsehen, dort stehen im href-Attribut des HTML-Elements a die URLs drin, das musst du mit einem Texteditor ändern.
Was ist das überhaupt für ein Template? Welches Content Management oder eine spezielle PHP-Datei?

Ist es so geheimnisumwittert, was in der .htaccess steht, kannst ja aus dem Domain-Teil eine xxxxxxxx.xy machen, wenn die nicht hier publik sein soll.
 
Last edited:
Top