Strato-vServer mit Plesk per SSH nicht mehr erreichbar

nobodyisperfect

New Member
Hallo zusammen,
ich habe folgendes Problem und hoffe, jemand von euch kann mir helfen.
Derzeit kann ich auf meinen Server weder per SSH zugreifen (Port geschlossen) noch über die Plesk-Oberfläche (vermutlich deswegen, weil SSH nicht funktioniert?). Der Server ist aber weiterhin per Ping erreichbar und auch der Webserver läuft und liefert Seiten über http und https problemlos aus. Eine vorhandene Owncloud-Installation läuft z.B. ohne Probleme, so dass mir die Problematik mit Plesk und SSH zunächst nicht aufgefallen ist.
Ein Neustart des Servers über die Strato-Oberfläche brachte keine Besserung, auch ein zweiter Versuch einige Tage später hat nichts gebracht.

Ich nutze einen Strato vServer mit PleskOnyx. Plesk ist über eine Erweiterung so eingestellt, dass es den Server automatisch updatet. Die ein oder andere Erweiterung aus dem Standardkatalog habe ich ebenfalls aktiviert, z.B. auch kcare. Von dieser Erweiterung bekam ich irgendwann Mails mit folgendem Inhalt:
Cron <[email protected]> /usr/bin/kcarectl --auto-update --gradual-rollout=auto
Unknown Kernel (Ubuntu 4.4.0-042stab136.1)

Strato nutzt, soweit ich gelesen habe, Virtuozzo als Virtualisierungsplattform, so dass Systemupdates, die man selbst durchführt, z.T. Probleme verursachen. Kann es vielleicht sein, dass die Plesk-Erweiterung ein Kernel-Update durchgeführt hat, das sich mit dem von Strato zur Verfügung gestellten Kernel nicht verträgt? (Entschuldigung für die unpräzise Ausdrucksweise). Auf diese Idee hat mich ein Telefon-Supporter von Strato gebracht - auch, wenn der mir ansonsten leider nicht helfen konnte.

Im Folgenden habe ich einen Auszug aus der syslog-Datei eingefügt. Dafür habe ich den Server zunächst einmal "normal" über die Strato-Oberfläche neu booten lassen. Anschließend habe ich ihn im Rescue-System booten lassen und mir so die Syslog-Files heruntergeladen. Der folgende Ausschnitt zeigt also das, was ich als Bootvorgang des Servers identifizieren konnte.

Da ich keine tieferen Linux-Kenntnisse besitze würde ich mich über Anregungen freuen, wie ich mein Problem beheben kann bzw. Rückfragen, welche Infos zusätzlich nötig sind, um das Problem einzugrenzen. Danke schon mal im Voraus für eure Hilfe!!

Code:
Mar 24 01:31:00 h2752XXX rsyslogd: [origin software="rsyslogd" swVersion="8.16.0" x-pid="205" x-info="http://www.rsyslog.com"] start
Mar 24 01:31:00 h2752XXX rsyslogd-3003: invalid or yet-unknown config file command 'KLogPermitNonKernelFacility' - have you forgotten to load a module? [v8.16.0 try http://www.rsyslog.com/e/3003 ]
Mar 24 01:31:00 h2752XXX rsyslogd: rsyslogd's groupid changed to 110
Mar 24 01:31:00 h2752XXX rsyslogd: rsyslogd's userid changed to 106
Mar 24 01:31:00 h2752XXX systemd-sysctl[80]: Couldn't write '1' to 'kernel/kptr_restrict', ignoring: Permission denied
Mar 24 01:31:00 h2752XXX systemd-sysctl[80]: Couldn't write '1' to 'fs/protected_hardlinks', ignoring: No such file or directory
Mar 24 01:31:00 h2752XXX rsyslogd-2039: Could not open output pipe '/dev/xconsole':: No such file or directory [v8.16.0 try http://www.rsyslog.com/e/2039 ]
Mar 24 01:31:00 h2752XXX systemd-sysctl[80]: Couldn't write '1' to 'fs/protected_symlinks', ignoring: No such file or directory
Mar 24 01:31:00 h2752XXX rsyslogd-2007: action 'action 9' suspended, next retry is Sun Mar 24 01:31:30 2019 [v8.16.0 try http://www.rsyslog.com/e/2007 ]
Mar 24 01:31:00 h2752XXX systemd-sysctl[80]: Couldn't write '176' to 'kernel/sysrq', ignoring: Permission denied
Mar 24 01:31:00 h2752XXX systemd-sysctl[80]: Couldn't write '1' to 'kernel/yama/ptrace_scope', ignoring: No such file or directory
Mar 24 01:31:00 h2752XXX systemd-tmpfiles[106]: [/usr/lib/tmpfiles.d/var.conf:14] Duplicate line for path "/var/log", ignoring.
Mar 24 01:31:00 h2752XXX systemd-tmpfiles[106]: Unsafe symlinks encountered in /var/log, refusing.
Mar 24 01:31:00 h2752XXX systemd-tmpfiles[106]: Unsafe symlinks encountered in /run/sendsigs.omit.d, refusing.
Mar 24 01:31:00 h2752XXX systemd-tmpfiles[106]: Unsafe symlinks encountered in /run/dovecot, refusing.
Mar 24 01:31:00 h2752XXX systemd-tmpfiles[106]: Unsafe symlinks encountered in /run/fail2ban, refusing.
Mar 24 01:31:00 h2752XXX systemd-tmpfiles[106]: Unsafe symlinks encountered in /run/lock/subsys, refusing.
Mar 24 01:31:00 h2752XXX systemd-tmpfiles[106]: Unsafe symlinks encountered in /var/cache, refusing.
Mar 24 01:31:00 h2752XXX systemd-tmpfiles[106]: Unsafe symlinks encountered in /var/cache/man, refusing.
Mar 24 01:31:00 h2752XXX systemd-tmpfiles[106]: Unsafe symlinks encountered in /run/php, refusing.
Mar 24 01:31:00 h2752XXX systemd-tmpfiles[106]: Unsafe symlinks encountered in /run/lock/files, refusing.
Mar 24 01:31:00 h2752XXX systemd-tmpfiles[106]: Unsafe symlinks encountered in /run/lock/lmlib, refusing.
Mar 24 01:31:00 h2752XXX systemd-tmpfiles[106]: Unsafe symlinks encountered in /var/run/screen, refusing.
Mar 24 01:31:00 h2752XXX systemd-tmpfiles[106]: Unsafe symlinks encountered in /var/run/sshd, refusing.
Mar 24 01:31:00 h2752XXX systemd-tmpfiles[106]: Unsafe symlinks encountered in /var/run/sudo, refusing.
Mar 24 01:31:00 h2752XXX systemd-tmpfiles[106]: Unsafe symlinks encountered in /var/run/sudo/ts, refusing.
Mar 24 01:31:00 h2752XXX systemd-tmpfiles[106]: Unsafe symlinks encountered in /run/nologin, refusing.
Mar 24 01:31:00 h2752XXX systemd-tmpfiles[106]: Unsafe symlinks encountered in /run/user, refusing.
Mar 24 01:31:00 h2752XXX systemd-tmpfiles[106]: Unsafe symlinks encountered in /run/utmp, refusing.
Mar 24 01:31:00 h2752XXX systemd-tmpfiles[106]: Unsafe symlinks encountered in /run/systemd/ask-password, refusing.
Mar 24 01:31:00 h2752XXX systemd-tmpfiles[106]: Unsafe symlinks encountered in /run/systemd/seats, refusing.
Mar 24 01:31:00 h2752XXX systemd-tmpfiles[106]: Unsafe symlinks encountered in /run/systemd/sessions, refusing.
Mar 24 01:31:00 h2752XXX systemd-tmpfiles[106]: Unsafe symlinks encountered in /run/systemd/users, refusing.
Mar 24 01:31:00 h2752XXX systemd-tmpfiles[106]: Unsafe symlinks encountered in /run/systemd/machines, refusing.
Mar 24 01:31:00 h2752XXX systemd-tmpfiles[106]: Unsafe symlinks encountered in /run/systemd/shutdown, refusing.
Mar 24 01:31:00 h2752XXX systemd-tmpfiles[106]: Unsafe symlinks encountered in /run/systemd/netif, refusing.
Mar 24 01:31:00 h2752XXX systemd-tmpfiles[106]: Unsafe symlinks encountered in /run/systemd/netif/links, refusing.
Mar 24 01:31:00 h2752XXX systemd-tmpfiles[106]: Unsafe symlinks encountered in /run/systemd/netif/leases, refusing.
Mar 24 01:31:00 h2752XXX systemd-tmpfiles[106]: Unsafe symlinks encountered in /run/log, refusing.
Mar 24 01:31:00 h2752XXX systemd-tmpfiles[106]: Unsafe symlinks encountered in /var/lib, refusing.
Mar 24 01:31:00 h2752XXX systemd-tmpfiles[106]: Unsafe symlinks encountered in /var/lib/systemd, refusing.
Mar 24 01:31:00 h2752XXX systemd-tmpfiles[106]: Unsafe symlinks encountered in /var/lib/systemd/coredump, refusing.
Mar 24 01:31:00 h2752XXX systemd-tmpfiles[106]: Unsafe symlinks encountered in /var/log/wtmp, refusing.
Mar 24 01:31:00 h2752XXX systemd-tmpfiles[106]: Unsafe symlinks encountered in /var/log/btmp, refusing.
Mar 24 01:31:00 h2752XXX systemd-tmpfiles[106]: Unsafe symlinks encountered in /var/spool, refusing.
Mar 24 01:31:00 h2752XXX systemd-tmpfiles[106]: Unsafe symlinks encountered in /tmp/.X11-unix, refusing.
Mar 24 01:31:00 h2752XXX systemd-tmpfiles[106]: Unsafe symlinks encountered in /tmp/.ICE-unix, refusing.
Mar 24 01:31:00 h2752XXX systemd-tmpfiles[106]: Unsafe symlinks encountered in /tmp/.XIM-unix, refusing.
Mar 24 01:31:00 h2752XXX systemd-tmpfiles[106]: Unsafe symlinks encountered in /tmp/.font-unix, refusing.
Mar 24 01:31:00 h2752XXX systemd-tmpfiles[106]: Unsafe symlinks encountered in /tmp/.Test-unix, refusing.
Mar 24 01:31:00 h2752XXX systemd-tmpfiles[106]: Unsafe symlinks encountered in /run/log/journal, refusing.
Mar 24 01:31:00 h2752XXX systemd-tmpfiles[106]: Unsafe symlinks encountered in /run/log/journal/2d2087d9863a475a8ce53fab528d6c43, refusing.
Mar 24 01:31:00 h2752XXX quota-initial-check.sh[90]: quotaon: Cannot stat() mounted device /dev/vzfs: No such file or directory
Mar 24 01:31:00 h2752XXX vzquota[195]: /etc/init.d/vzquota: 15: [: 0: unexpected operator
Mar 24 01:31:00 h2752XXX cron[194]: (CRON) INFO (pidfile fd = 3)
Mar 24 01:31:00 h2752XXX cron[194]: (CRON) INFO (Running [USER=12255]@reboot[/USER] jobs)
Mar 24 01:31:00 h2752XXX sh[230]: ifup: waiting for lock on /run/network/ifstate.venet0
Mar 24 01:31:00 h2752XXX ifup[117]: Waiting for DAD... Done
Mar 24 01:31:00 h2752XXX sh[230]: ifup: interface venet0 already configured
Mar 24 01:31:00 h2752XXX psa-vpn[324]: psa-vpn: OpenVPN is disabled
Mar 24 01:31:00 h2752XXX apache2[326]:  * Starting Apache httpd web server apache2
Mar 24 01:31:00 h2752XXX xinetd[323]:  * Starting internet superserver xinetd
Mar 24 01:31:00 h2752XXX xinetd[323]:    ...done.
Mar 24 01:31:00 h2752XXX sshd[321]: Missing privilege separation directory: /var/run/sshd
Mar 24 01:31:00 h2752XXX xinetd[406]: Reading included configuration file: /etc/xinetd.d/chargen [file=/etc/xinetd.conf] [line=14]
Mar 24 01:31:00 h2752XXX xinetd[406]: Reading included configuration file: /etc/xinetd.d/daytime [file=/etc/xinetd.d/daytime] [line=28]
Mar 24 01:31:00 h2752XXX xinetd[406]: Reading included configuration file: /etc/xinetd.d/discard [file=/etc/xinetd.d/discard] [line=26]
Mar 24 01:31:00 h2752XXX xinetd[406]: Reading included configuration file: /etc/xinetd.d/echo [file=/etc/xinetd.d/echo] [line=25]
Mar 24 01:31:00 h2752XXX xinetd[406]: Reading included configuration file: /etc/xinetd.d/ftp_psa [file=/etc/xinetd.d/ftp_psa] [line=26]
Mar 24 01:31:00 h2752XXX xinetd[406]: Reading included configuration file: /etc/xinetd.d/poppassd_psa [file=/etc/xinetd.d/poppassd_psa] [line=18]
Mar 24 01:31:00 h2752XXX xinetd[406]: Reading included configuration file: /etc/xinetd.d/time [file=/etc/xinetd.d/time] [line=16]
Mar 24 01:31:00 h2752XXX xinetd[406]: removing chargen
Mar 24 01:31:00 h2752XXX xinetd[406]: removing chargen
Mar 24 01:31:00 h2752XXX xinetd[406]: removing daytime
Mar 24 01:31:00 h2752XXX xinetd[406]: removing daytime
Mar 24 01:31:00 h2752XXX dovecot[330]: doveconf: Warning: NOTE: You can get a new clean config file with: doveconf -Pn > dovecot-new.conf
Mar 24 01:31:00 h2752XXX dovecot[330]: doveconf: Warning: Obsolete setting in /etc/dovecot/conf.d/11-plesk-security-ssl.conf:2: ssl_protocols has been replaced by ssl_min_protocol
Mar 24 01:31:00 h2752XXX dovecot[330]: doveconf: Warning: Obsolete setting in /etc/dovecot/conf.d/11-plesk-security-ssl.conf:4: ssl_dh_parameters_length is no longer needed
Mar 24 01:31:00 h2752XXX xinetd[406]: removing discard
Mar 24 01:31:00 h2752XXX xinetd[406]: removing discard
Mar 24 01:31:00 h2752XXX xinetd[406]: removing echo
Mar 24 01:31:00 h2752XXX xinetd[406]: removing echo
Mar 24 01:31:00 h2752XXX xinetd[406]: removing time
Mar 24 01:31:00 h2752XXX xinetd[406]: removing time
Mar 24 01:31:00 h2752XXX xinetd[406]: xinetd Version 2.3.15 started with libwrap loadavg options compiled in.
Mar 24 01:31:00 h2752XXX xinetd[406]: Started working: 2 available services
Mar 24 01:31:00 h2752XXX sw-cp-serverd[322]: nginx: [emerg] BIO_new_file("/opt/psa/admin/conf/httpsd.pem") failed (SSL: error:02001002:system library:fopen:No such file or directory:fopen('/opt/psa/admin/conf/httpsd.pem','r') error:2006D080:BIO routines:BIO_new_file:no such file)
Mar 24 01:31:00 h2752XXX sw-cp-serverd[322]: nginx: configuration file /etc/sw-cp-server/config test failed
Mar 24 01:31:00 h2752XXX dovecot[330]: doveconf: Warning: NOTE: You can get a new clean config file with: doveconf -Pn > dovecot-new.conf
Mar 24 01:31:00 h2752XXX dovecot[330]: doveconf: Warning: Obsolete setting in /etc/dovecot/conf.d/11-plesk-security-ssl.conf:2: ssl_protocols has been replaced by ssl_min_protocol
Mar 24 01:31:00 h2752XXX dovecot[330]: doveconf: Warning: Obsolete setting in /etc/dovecot/conf.d/11-plesk-security-ssl.conf:4: ssl_dh_parameters_length is no longer needed
Mar 24 01:31:00 h2752XXX dovecot[330]: doveconf: Warning: service auth { client_limit=1000 } is lower than required under max. load (1224)
Mar 24 01:31:00 h2752XXX dovecot[330]: doveconf: Warning: service anvil { client_limit=1000 } is lower than required under max. load (1227)
Mar 24 01:31:00 h2752XXX dovecot[330]: Warning: service auth { client_limit=1000 } is lower than required under max. load (1224)
Mar 24 01:31:00 h2752XXX dovecot[330]: Warning: service anvil { client_limit=1000 } is lower than required under max. load (1227)
Mar 24 01:31:00 h2752XXX dovecot: master: Warning: service auth { client_limit=1000 } is lower than required under max. load (1224)
Mar 24 01:31:00 h2752XXX dovecot: master: Warning: service anvil { client_limit=1000 } is lower than required under max. load (1227)
Mar 24 01:31:00 h2752XXX dovecot: master: Dovecot v2.3.4.1 (f79e8e7e4) starting up for imap, pop3, sieve (core dumps disabled)
Mar 24 01:31:00 h2752XXX dovecot: doveconf: Warning: NOTE: You can get a new clean config file with: doveconf -Pn > dovecot-new.conf
Mar 24 01:31:00 h2752XXX dovecot: doveconf: Warning: Obsolete setting in /etc/dovecot/conf.d/11-plesk-security-ssl.conf:2: ssl_protocols has been replaced by ssl_min_protocol
Mar 24 01:31:00 h2752XXX dovecot: doveconf: Warning: Obsolete setting in /etc/dovecot/conf.d/11-plesk-security-ssl.conf:4: ssl_dh_parameters_length is no longer needed
Mar 24 01:31:00 h2752XXX dovecot: config: Warning: NOTE: You can get a new clean config file with: doveconf -Pn > dovecot-new.conf
Mar 24 01:31:00 h2752XXX dovecot: config: Warning: Obsolete setting in /etc/dovecot/conf.d/11-plesk-security-ssl.conf:2: ssl_protocols has been replaced by ssl_min_protocol
Mar 24 01:31:00 h2752XXX dovecot: config: Warning: Obsolete setting in /etc/dovecot/conf.d/11-plesk-security-ssl.conf:4: ssl_dh_parameters_length is no longer needed
Mar 24 01:31:00 h2752XXX dovecot: config: Warning: service auth { client_limit=1000 } is lower than required under max. load (1224)
Mar 24 01:31:00 h2752XXX dovecot: config: Warning: service anvil { client_limit=1000 } is lower than required under max. load (1227)
Mar 24 01:31:01 h2752XXX sshd[698]: Missing privilege separation directory: /var/run/sshd
Mar 24 01:31:01 h2752XXX sshd[839]: Missing privilege separation directory: /var/run/sshd
Mar 24 01:31:01 h2752XXX sshd[914]: Missing privilege separation directory: /var/run/sshd
Mar 24 01:31:02 h2752XXX sshd[953]: Missing privilege separation directory: /var/run/sshd
Mar 24 01:31:02 h2752XXX fail2ban-client[314]: ERROR  There is no directory /var/run/fail2ban to contain the socket file /var/run/fail2ban/fail2ban.sock.
Mar 24 01:31:02 h2752XXX kcare: Gradual rollout is not applicable.
Mar 24 01:31:02 h2752XXX fail2ban-client[1089]: ERROR  There is no directory /var/run/fail2ban to contain the socket file /var/run/fail2ban/fail2ban.sock.
Mar 24 01:31:03 h2752XXX psa-firewall[325]: psa-firewall: firewall configuration successfully applied
Mar 24 01:31:03 h2752XXX fail2ban-client[1161]: ERROR  There is no directory /var/run/fail2ban to contain the socket file /var/run/fail2ban/fail2ban.sock.
Mar 24 01:31:03 h2752XXX fail2ban-client[1170]: ERROR  There is no directory /var/run/fail2ban to contain the socket file /var/run/fail2ban/fail2ban.sock.
Mar 24 01:31:03 h2752XXX fail2ban-client[1197]: ERROR  There is no directory /var/run/fail2ban to contain the socket file /var/run/fail2ban/fail2ban.sock.
Mar 24 01:31:03 h2752XXX php-fpm[312]: [24-Mar-2019 01:31:03] WARNING: Nothing matches the include pattern '/opt/plesk/php/5.6/etc/php-fpm.d/*.conf' from /opt/plesk/php/5.6/etc/php-fpm.conf at line 119.
Mar 24 01:31:03 h2752XXX php-fpm[312]: [24-Mar-2019 01:31:03] ERROR: No pool defined. at least one pool section must be specified in config file
Mar 24 01:31:03 h2752XXX php-fpm[312]: [24-Mar-2019 01:31:03] ERROR: failed to post process the configuration
Mar 24 01:31:04 h2752XXX php-fpm[312]: [24-Mar-2019 01:31:03] ERROR: FPM initialization failed
Mar 24 01:31:04 h2752XXX kcare: Unknown Kernel (Ubuntu 4.4.0-042stab136.1)
Mar 24 01:31:04 h2752XXX kcare[328]: Unknown Kernel (Ubuntu 4.4.0-042stab136.1)
Mar 24 01:31:04 h2752XXX spamd[203]: logger: removing stderr method
Mar 24 01:31:05 h2752XXX apache2[326]:  *
Mar 24 01:31:09 h2752XXX spamd[1222]: zoom: able to use 344/346 'body_0' compiled rules (99.421%)
Mar 24 01:31:10 h2752XXX spamd[1222]: spamd: server started on IO::Socket::IP [::1]:783, IO::Socket::IP [127.0.0.1]:783 (running version 3.4.2)
Mar 24 01:31:10 h2752XXX spamd[1222]: spamd: server pid: 1222
Mar 24 01:31:10 h2752XXX spamd[1222]: spamd: server successfully spawned child process, pid 1250
Mar 24 01:31:10 h2752XXX spamd[1222]: prefork: child states: I
Mar 24 01:31:12 h2752XXX postfix[1271]:  * Starting Postfix Mail Transport Agent postfix
Mar 24 01:31:12 h2752XXX postfix[1349]: Postfix is running with backwards-compatible default settings
Mar 24 01:31:12 h2752XXX postfix[1349]: See http://www.postfix.org/COMPATIBILITY_README.html for details
Mar 24 01:31:12 h2752XXX postfix[1349]: To disable backwards compatibility use "postconf compatibility_level=2" and "postfix reload"
Mar 24 01:31:13 h2752XXX postfix[1271]:    ...done.
Mar 24 01:31:13 h2752XXX postfix/master[1386]: /etc/postfix/master.cf: line 123: using backwards-compatible default setting chroot=y
Mar 24 01:31:13 h2752XXX postfix/master[1386]: /etc/postfix/master.cf: line 125: using backwards-compatible default setting chroot=y
Mar 24 01:31:13 h2752XXX postfix/master[1386]: /etc/postfix/master.cf: line 134: using backwards-compatible default setting chroot=y
Mar 24 01:31:13 h2752XXX postfix/master[1386]: daemon started -- version 3.1.0, configuration /etc/postfix
Mar 24 01:31:14 h2752XXX ntpdate[160]: step-systime: Operation not permitted
Mar 24 01:32:01 h2752XXX CRON[1402]: (root) CMD (/opt/psa/admin/bin/php -dauto_prepend_file=sdk.php '/opt/psa/admin/plib/modules/revisium-antivirus/scripts/ra_executor_run.php')
Mar 24 01:33:01 h2752XXX CRON[1431]: (root) CMD (/opt/psa/admin/bin/php -dauto_prepend_file=sdk.php '/opt/psa/admin/plib/modules/revisium-antivirus/scripts/ra_executor_run.php')
Mar 24 01:34:01 h2752XXX CRON[1450]: (root) CMD (/opt/psa/admin/bin/php -dauto_prepend_file=sdk.php '/opt/psa/admin/plib/modules/revisium-antivirus/scripts/ra_executor_run.php')
Mar 24 01:35:01 h2752XXX CRON[1469]: (root) CMD (/opt/psa/bin/sw-engine-pleskrun /opt/psa/admin/plib/DailyMaintainance/task-script.php StoreOutgoingMessagesStatistics >/dev/null 2>&1)
Mar 24 01:35:01 h2752XXX CRON[1470]: (root) CMD (/opt/psa/admin/bin/php -dauto_prepend_file=sdk.php '/opt/psa/admin/plib/modules/revisium-antivirus/scripts/ra_executor_run.php')
Mar 24 01:35:01 h2752XXX CRON[1471]: (root) CMD ([ -x /opt/psa/admin/sbin/backupmng ] && /opt/psa/admin/sbin/backupmng >/dev/null 2>&1)
Mar 24 01:36:01 h2752XXX CRON[1495]: (root) CMD (/opt/psa/admin/bin/php -dauto_prepend_file=sdk.php '/opt/psa/admin/plib/modules/revisium-antivirus/scripts/ra_executor_run.php')
Mar 24 01:36:01 h2752XXX CRON[1496]: (root) CMD (cd / && run-parts --report /etc/cron.hourly)
Mar 24 01:36:16 h2752XXX proftpd[1517]: fatal: TLSRSACertificateFile: '/opt/psa/admin/conf/httpsd.pem' does not exist or does not contain a certificate on line 50 of '/etc/proftpd.conf'
Mar 24 01:36:19 h2752XXX rsyslogd: [origin software="rsyslogd" swVersion="8.16.0" x-pid="205" x-info="http://www.rsyslog.com"] exiting on signal 15.
 
Last edited:

marce

Well-Known Member
Bitte nutze [ code]-Tags für Logausgaben, macht das alles lesbarer.

Auf den ersten Blick scheinst Du irgendein Problem mit /var/run/* zu haben - zumindest meckert alles , was darin irgendwas tun will.
 

nobodyisperfect

New Member
Bitte nutze [ code]-Tags für Logausgaben, macht das alles lesbarer.

Auf den ersten Blick scheinst Du irgendein Problem mit /var/run/* zu haben - zumindest meckert alles , was darin irgendwas tun will.
Hallo marce,
danke für deinen Hinweis. Ich habe den Server nochmals im Rescue-Modus gestartet, mir mittels WinSCP die Verzeichnisstruktur angesehen und einige Screenshots erstellt.

Hinweis: Im Rescue-System von Strato wird der Inhalt der virtuellen Serverplatte im Ordner /repair/ gemountet.

Hier die Verzeichnisrechte für das entsprechende Verzeichnis /repair/var/ , das ja allerdings ein symlink ist.
repair-var.PNG

Der symlink in /repair/var/run scheint auf /run/ zu verweisen, da ich in folgendem Ordner gelandet bin:
symlink-repair-var-run auf run.PNG

Wenn ich mir den entsprechenden Ordner /repair/run/ (also den Ordner /run/ auf der virtuellen Platte) ansehe, ist der leer. (Ups, ich war's nicht.)
repair.PNGrepair-run.PNG

Soll/Muss ich den Server wegen dieses Problems neu aufsetzen oder lässt sich das über die Shell als root reparieren? (Kann ich z.B. einfach den Inhalt des run-Ordners des Rescue-Systems dort hineinkopieren?)
In Verbindung dazu stellt sich die Frage, ob es eher sinnvoll ist, mit winSCP die Datenzu sichern und dann den Server mit dem neuesten Ubuntu einmal sauber zu installieren und bei Plesk den ganzen nicht voreingestellten Upgrade-Mist rauszunehmen. Das ist aber natürlich ein ordentlicher Konfigurationsaufwand.

Danke schon mal für Anregungen dazu.
 

nobodyisperfect

New Member
Ich würde wohl einfach sicherstellen, dass meine Backups valide sind und den Server dann neu aufsetzen.
Ok. Es gibt vollständige Backups des Servers, allerdings habe ich keine, die z.B. nur die Plesk-Einstellungen umfassen. Um diese exportieren zu können wäre es gut, wenn ich einen Tippbekommen könnte, wie ich SSH und Co zumindest kurzfristig wieder zum Laufen bekomme, damit ein Login dort möglich ist.
 

danton

Debian User
Bietet Strato keinen Zugriff auf die Konsole des vServers? Bei meinem dedizierten Server damals konnte ich per SSH auf die serielle Konsole des Servers zugreifen - was ähnliches sollte doch beim vServer auch vorhanden sein, da sogar ohne zusätzliche Hardware machbar. Ich meine, der Punkt im Strato-Menü hies REmoteConsole.
 

nobodyisperfect

New Member
Bietet Strato keinen Zugriff auf die Konsole des vServers? Bei meinem dedizierten Server damals konnte ich per SSH auf die serielle Konsole des Servers zugreifen - was ähnliches sollte doch beim vServer auch vorhanden sein, da sogar ohne zusätzliche Hardware machbar. Ich meine, der Punkt im Strato-Menü hies REmoteConsole.
Die RemoteConsole ist im Servermenü bei Strato leider nicht enthalten.
 

eocookie

New Member
Damit funktioniert dein Login unter Strato mit Plesk per ssh wieder:

Lösung:
1) Starte das Rettungssystem,
2) Bearbeite /etc/repair/ssh/sshd_config
3) Ersetze den folgenden Eintrag auf no:
#UsePrivilegeSeparation yes
UsePrivilegeSeparation no

Unter z.B. Ubuntu18 steht die Option gar nicht mehr drin, ist deprecated.
OpenSSH 7.5 was released on 2017-03-20
"This release deprecates the sshd_config UsePrivilegeSeparation option, thereby making privilege separation mandatory."

Versions-Check per Terminal:
# sshd -V
 
Last edited:

Avalon

New Member
Nicht gut für mich. Ich hab seit heute das gleiche Problem. Aus dem Nichts ist der Server nur noch per Ping erreichbar. Die Lösung von eocookie hat leider nicht funktioniert. Ich bin ratlos. Die Pleskoberfläche ist nicht erreichbar, Domains sind nicht ereichbar. Putty und WinSCP gehen nur im abgesicherten Modus. Diverse Vorschläge aus der Google Suche funktionieren nicht, weil z.B. Dateien, die geändert werden sollen, garnicht vorhanden sind. Möchte jemand helfen?
 

marce

Well-Known Member
"Abgesicherter Modus" klingt irgendwie nach Windows-Server - damit wärest Du in dem Thread hier eh falsch.
 

Avalon

New Member
Nein. Ist Ubuntu. Windows hab ich zu Hause. :-D Deswegen. Macht der Gewohnheit. Strato nennt das Notfall-System.
 

sbr2d2

Registered User
Das Notfall System ist nicht "dein System". Du kannst in dieses System deine Festplatte einbinden und dann an deinem System arbeiten, sprich nach Fehler suchen und beheben.
 

Thorsten

SSF Facilitymanagement
Staff member
Und ein Kernel Update, bedingt durch die genannte Plesk Erweiterung, dürfte bei einem vServer nicht möglich sein. Auf der anderen Seite sollte dadurch allerdings auch nicht das komplette System in einen undefinierbaren Zustand versetzt werden können.
 

Ray7six

New Member
Hey, habe die selben probleme. habe von einen vserver zu einen root gewechselt und mit den vserver mit plask und ts keine probleme.
server über kindenaccount installiert, debian9 64 bit mit plesk. eingeloggt, firewall antivirus usw installt, domain angelegt, email accounts. ts3 installiert, ports freigegeben füt ts3 ... wie immer halt.
habe mich dann ausgeloggt, 4 std später eingeloggt und nach ca 5 min im plesk keinen zugriff mehr.
auch nicht über ssh. webseite nicht erreichbar. über das resu. eingeloggt aber nichts gefunden das auf den fehler hinweist.
server neu installiert und wieder das selbe. manchmal läuft es 20 min gut manchmal bis 24 stunden.

Lg Ray
 

danton

Debian User
Mal über die SSH-Konsole geschaut, ob der Server überhaupt noch lebt? Das Verhalten hört sich für mich nach einem Hardware-Problem an, so dass der Server abstürzt.
 

nexus

Well-Known Member
@Ray7six:
Achte bitte zukünftig auf korrekte Groß-/Kleinschreibung, das macht deine Posts enorm besser lesbar.

Das Verhalten hört sich für mich nach einem Hardware-Problem an, so dass der Server abstürzt.
Wenn es (nur) ein Hardwareproblem wäre, dann dürfte er aber auch nicht über das Rescue Zugriff auf sein System erlangen, welchen er ja laut seiner Beschreibung bekommt.
 

danton

Debian User
Das kommt auf das Hardware-Problem an. Ein defekter Speicherriegel beispielsweise kann dazu führen, dass der Server erst einige Zeit normal funktioniert, bis der defekte Speicherbereich auch wirklich gebraucht wird. Auch ein thermisches Problem wäre denkbar. Zugriff über eine (serielle) Konsole kann da schon entscheidene Hinweise geben, Wenn der Server darüber noch reagiert, kann man auf diesem Weg auf dem Server nachschauen, warum er anscheinend keine Netzwerk-Verbindung mehr hat. Reagiert er dort auch nicht, dann spricht das für meine Vermutung eines Hardwaredefekts...
 

Ray7six

New Member
Problem gelöst.

Hatte heute Zeit mir das anzusehen und den Fehler schnell gefunden.
Ping der Server IP war möglich doch kein Zugriff über SSH oder Web.
Habe von einer anderen IP probiert zuzugreifen und siehe da es hat funktioniert.

Fail2Ban hat meine IP gebannt, diese als vertraunswürdig gesetzt und alles wieder OK.

Lg Ray
 

GwenDragon

Registered User
Fail2Ban hat meine IP gebannt
Sowas prüfen erfahrene Admins sofort nach. ;)
Kannst auch kurz bei dir den Router neu starten, dann bekommeste auch ne neue IP (oder habt ihr eine Standleitung mit fester Firmen-IP?)..
 
Top