Strato Server einrichten

hokkabaz81

New Member
Hallo, ich weiss nicht, in welches Unterforum ich diesen Beitrag einstellen soll. Darum, wenn falsch, bitte entspechend verschieben :) Danke.

Zu meiner Herausforderung:

Ich möchte als "Vollanfänger" eine private Webseite (Chat) einrichten.

Habe mir von Strato nun eine Domain gemietet und einen V-Server
(Linux V10). Als BS habe ich Unbutu 16.04 LTS 64 Bit + Plesk Onyx aufgespielt.

Auf der Plesk-Oberfläche habe ich wie gewohnt, den stratoserver.net drin. Wenn ich auf "Domain hinzufügen" gehe, um die "eigene-seite.de" hinzu zu fügen, klappt es auch. Aber ich bekomme die Meldung "
Warnung: Die Domain eigene-seite.de kann nicht aufgelöst werden oder wird in eine andere IP-Adresse (81.xxx ) aufgelöst. Bitte korrigieren Sie die DNS-Einstellungen."

Auf der Hilfeseite wird dazu geschrieben, dass man in den DNS Einstellungen die zugehörigen DNS und Domainnamen mit dem Domainnamen auf der Website des Registrars verknüpfen soll.( hier die Hilfeseite)

Den Punkt gibt es aber nicht, wie es dort steht.

Ich bekomme die Daten einfach nicht auf meine Seite hochgeladen. Es wird immer auf stratoserver.net geladen und nur mit dieser Seite ist meine Seite erreichbar. Soll aber wie gesagt, über die Domain erreicht werden.

Kann mir da jemand, wenn möglich in Laiensprache, erklären, wo ich was falsch mache!?
 
A

andreas0

Guest
Ich möchte als "Vollanfänger" eine private Webseite (Chat) einrichten.
Kann mir da jemand, wenn möglich in Laiensprache, erklären, wo ich was falsch mache!?
Du hast den Fehler gemacht, dir als "Vollanfänger" einen V-Server zu mieten, der nur für Profis mit recht viel Hintergrundwissen gedacht ist.

Besser wehre es gewesen, wenn du dir ein kleines Hosting-Paket bei Strato bestellt hättest, da diese auch für "Vollanfänger" gedacht sind. Näheres siehe hier.
 

GwenDragon

Registered User
Bei welchem Anbieter ist deine Domain registriert? In dessen Domainverwaltung musst du die IP deiner Servers eintragen.
Dann einige Stunden warten, bis die IP auch im Internet bei allen DNS-Servern (insbesondere deinem Internetzugangsanbieter) bekannt gemacht wird.
 

hokkabaz81

New Member
Erstmal danke für die Antworten. Wir wollten den ET-Chat einbinden. Darum würde so ein Baukasten HP nicht ganz funktionieren.

@GwenDragon

Deine Frage verwirrt mich ein wenig. Ich habe neben dem Server, bei Strato auch die entsprechende Domain bei Strato gesichert.
Wo genau gebe ich denn die IP an? A Record, AAAa record... ?


Edit: ich habe die IP nun bei A Record eingegeben und konnte den Chat installieren.

Der Chat wird jedoch nicht auf der Hauptseite "eigene-Seite-de" sondern "eigene-Seite-de/et_Chat" ausgegeben.
Habe den Installordner nun direkt auf den Rootverzeichnet kopiert, jedoch steht, dass die Seite "not avalible" ist.

Hat da jemand eine Lösung?
 
Last edited by a moderator:

hokkabaz81

New Member
Nun ist es ja fast so, wie ich es wollte.

Ausser, dass es nicht auf der Hauptseite ist.

Wenn ich den Chatordner in den Rootverzeichnes schiebe, dann installiert er den Chat leider nicht. Wollte eben per Umleitung von der Hauptseite auf die Unterseite leiten, jedoch ist das wohl wegen der Einstellung, dass der "Domain entweder ein eigener A-Record oder ein DynDNS-Account zugewiesen wurde."

Hat jemand eine Ahnung, wie ich das lösen kann?



der Chat ist ausschließlich unter http://****.de/et_chat_v307 erreichbar. Das ist ein wenig "doof".
 
Last edited by a moderator:

ThomasChr

Member
Hallo hokkabaz81,

ich würde dir ja gerne helfen aber ich administriere meine Server ohne Plesk und weiß deshalb nicht wo du hinklicken musst.

Sei dir aber bitte auch der Tatsache bewusst dass gerade während du hier liest auf deinem Server pro Sekunde dutzende Verbindungsversuche einprasseln. Das sind Bots die vollautomatisch Sicherheitslücken und schlechte Passwörter ausprobieren.

Hast du einmal ein schlechtes Passwort gewählt oder den Server zu lange nicht aktualisiert wird er von denen Ruck-Zuck übernommen.

Thomas
 

hokkabaz81

New Member
Mal geraten: Entpacke den Inhalt des Ordners et_chat_v307 ins Webrootverzeichnis deiner Domain.
Ja das hatte ich auch vor.

Aber von dort aus lässt er den Chat nicht installieren.

Die Daten liegen aktuell so:



Und in den Hosting-Einstellungen ist folgendes drin

https://picload.org/image/dlroalwa/hostung.jpg

Damit kann ich die Seite xxxxx.de/et_chat_v307/installation aufrufen

Wenn ich den et_chat_v307r3 auslasse, und in den Hosting-Einstellungen ebenfalls die r3 Endung weglasse, müsste ich den Chat direkt über xxxx.de/installation erreichen. Jedoch macht er das nicht.

Und im Dokumentenstamm kann ich nicht weiter zurück, oder?

@ThomasChr Danke für den Hinweis. Das PW ist denk ich mal mir Groß- und Kleinbuchstaben, Sonderzeichen und Ziffern hoffentlich stark genug. Wird aber von mir alle 4 Wochen geändert.

Ich werde mal einen "Mitbewerber" fragen, wie er es mit den Verzeichnes gelöst hat. Er arbeitet auch mit Plesk (1+1)
 
Last edited by a moderator:

ThomasChr

Member
hokkabaz81 said:
@ThomasChr Danke für den Hinweis. Das PW ist denk ich mal mir Groß- und Kleinbuchstaben, Sonderzeichen und Ziffern hoffentlich stark genug. Wird aber von mir alle 4 Wochen geändert.
Du hast den von Gwen geposteten Exploit gesehen?
Wenn ich das richtig deute kann jeder der bei deinem Chat ein User ist sich zu einem Admin machen und Dateien auf deinen Server spielen und ausführen.

Sonst hast du -imho- Recht, wenn du '/et_chat_v307' als Dokumentenstamm einstellst sollte er in diesen Ordner gehen. Evtl. ist noch ein neu laden der Apache Config nötig, wie das aber Plesk macht weiß ich nicht.
 

hokkabaz81

New Member
Du hast den von Gwen geposteten Exploit gesehen?
Wenn ich das richtig deute kann jeder der bei deinem Chat ein User ist sich zu einem Admin machen und Dateien auf deinen Server spielen und ausführen.

Sonst hast du -imho- Recht, wenn du '/et_chat_v307' als Dokumentenstamm einstellst sollte er in diesen Ordner gehen. Evtl. ist noch ein neu laden der Apache Config nötig, wie das aber Plesk macht weiß ich nicht.
Nein den Edit hatte ich erst eben gelesen.

Ich werde mir das mal anschauen. Danke euch soweit
 

GwenDragon

Registered User
Hast du das Zip falsch entpackt?
Wieso hast du als Docroot nicht et_chat_v307 genommen? Dann wäre doch wohl alles ok.

Was den Exploit anbelangt würde ich mal den Hersteller des Chats fragen.
 

hokkabaz81

New Member
Hast du das Zip falsch entpackt?
Wieso hast du als Docroot nicht et_chat_v307 genommen? Dann wäre doch wohl alles ok.

Was den Exploit anbelangt würde ich mal den Hersteller des Chats fragen.
Ich habe mich direkt an die Anweisung gehalten.

Installation
-------------

* Entpacken Sie die et_chat_v3xx.zip auf Ihrem PC

* Öffnen Sie mit einem Editor (Notepad, Wordpad, etc.) die Datei config.php im Chatverzeichnis

* Geben Sie die Parameter Ihrer Datenbankverbindung in die Variablen ein und wählen Sie die Datenbank
(Die Parameter Ihrer Datenbankverbindung erfahren Sie oft bei Ihrem Webspaceprovider)

* Speichern Sie die config.php mit den von Ihnen gemachten Angaben

* Uploaden Sie die den gesamten Verzeichnis \et_chat_v3XX\ auf Ihren Webserver
(am besten in den Stammverzeichnis, sog. /root/)


* Im Browser geben Sie nun folgende URI ein: http://www.ihr_server.de/et_chat_v3XX/install/

* Dort folgen Sie den Anweisungen

* Ihre Datenbank sollte nun angelegt sein.

* WICHTIG!: Nach der erfolgreichen Installation löschen Sie den Verzeichnis /install/ vom Webserver!


Der et_chat_v307r3 Ordner beinhaltet wie oben im Screen nicht nur den et_chat_v307 Ordner, sondern auch 3-4 weitere Textdaten.
 

GwenDragon

Registered User
Wenn du wie beim Hersteller beschrieben installierst, musst du dich auch dran halten das so zu konfigurieren wie der Hersteller vorsieht.

Für einen Patch woanders hin musst du den Support des ET-Chat fragen.
Wir dürfen auch gar nicht die software ändern laut Lizenz.

Damit sehe ich keinen Nutzen mehr weiter Vorschläge zu machen, da du wirklich ein Anfänger ohne Hintergrundwissen bist.
Bitte such dir jemand mit Fachwissen und Programmiererfahrung, der dir die Software installiert und konfiguriert.
 
Top