Strato Hostnamen bei V Serven / DNS Reverse

asche71

New Member
Hallo zusammen,
ich hoffe die Frage wurde nicht bereits irgendwo beantwortet , die Suche ergab nichts. Kurz zur Frage.
Strato vergibt für ihre V Server nach folgendem Schema Hostname : hl123456789.stratoserver.net. Laut Strato sind diese unveränderbar. In der Standard Einstellung
zeit das DNS Reverse auf diesen Hostnamen. Es handelt sich um einen Linux Server mit Ubuntu 18.03 mit Onxy 17.8 und zwei aktiven Domains.
Wen man diese Einstellung belässt und Let's encrypt Zertifikate einbindet und verwendet funktioniert somit alles. Wenn man allerdings einen Mail Client verwendet wird das Zertifikat moniert ( da ausgestellt auf hl.123 usw.). Ich bin jetzt kein DNS Spezialist, aber liegt das am "falschen DNS Reverse" ? Sollte hier der Eintag geändert werden ? Falls ja, nach welchem Schema ( FQDN?), also konkret : hl123456.meine-domain.tld ? oder einfach nur www.meine-domain.tld ? Oder muss gar der Hostname angepasst bzw. in der Dovecot config der Eintrag geändert werden ?
Besten Dank !
 

GwenDragon

Registered User
Generische Hostnamen wie ....stratoserver..... führen dazu, dass der Server bei Mailversand öfters als Spammer angesehen wird als dir lieb ist.

Warum nutzt du nicht deine Domain example.org, setzt den Hostnamen des Servers auf bspw. srv1234.example.org.
Im DNS fügst für srv1234 einen A-Record hinzu, für mail.example.org einen weiteren A-Record, für MX den Eintrag mail.example.org.

Und nutzt die als mail.... als Maildomain für alle Nutzer.
 

asche71

New Member
den Gedanken hatte ich ja schon, was mich allerdings irritiert ist das folgende : "
Der Hostname für Ihren STRATO Server wird automatisch generiert.
Der Hostname ist unveränderbar festgelegt.

Desweiteren ist die Änderung des Hostnamens nicht notwendig, da Dienste auf einem Server i. d. R. über einen gesonderten Domainnamen angeboten werden (z. B. über www.mein-webserver.de).

Letztendlich wird der Server über die entsprechenden IP-Adresse im Internet angesprochen und nicht über den Hostnamen bzw. über die entsprechende Domain."

Wenn ich diesen ändere wird er beim nächsten Neustart einfach überschrieben, ok, so oft startet der jetzt nicht, aber dennoch.
Der Pan war ja, den eigentlichen Hostnamen zu lassen, einfach abändern auf hl123456.meine.domain.tld und den Revese DNS auflösen.
Die MX Einträge passen, der A Record löst auf die primäre ip auf. Ich denke das Problem liegt noch am Reverse, zumal der SMTP Banner dann nicht stimmt.
 

d4f

Kaffee? Wo?
Achtung, du vermischst hier scheinbar 2 Probleme.

Wenn man allerdings einen Mail Client verwendet wird das Zertifikat moniert ( da ausgestellt auf hl.123 usw.).
Das hat nichts mit dem rDNS zu tun da ein Mailclient sich daran nicht stört. Was du hier siehst ist fehlendes/falsch eingestelltes SNI oder eine falsche Client-Konfiguration. Überprüfe ob Client und Server SNI-tauglich sind, im Zweifelsfall den Client mit STARTTLS (explizite Verschlüsselung) konfigurieren um einen Hostname-Abgleich zu forcieren.
Der Server braucht für jeden gewünschten Hostnamen ein SSL-Zertifikat, nicht nur für seinen Haupt-Hostnamen.


Letztendlich wird der Server über die entsprechenden IP-Adresse im Internet angesprochen und nicht über den Hostnamen bzw. über die entsprechende Domain.
Technisch ja, spamtechnisch nein. Wenn reverse lookup (ip -> hostname) mit forward lookup (hostname -> ip) nicht übereinstimmt oder der im EHLO genannte Hostname nicht dem rdns entspricht, dann sind Fehler in der Zustellung vorprogrammiert.
Ich empfehle zum Überprüfen der korrekten Konfiguration folgenden Dienst: https://www.mail-tester.com/


Frohes Neues!
 

asche71

New Member
Danke für die Antworten, den Mail Server habe ich bereits mit diversen Mail tools getestet, soweit ist alles ok, bis auf dem SMTP Banner.
@d4f, Deine zweite Aussage bezieht sich auf eine Antwort von Strato ( FAQ) die kam nicht von mir.
Ich wollte ja weg von generischen Hostnamen...
 

GwenDragon

Registered User
Wenn ich diesen ändere wird er beim nächsten Neustart einfach überschrieben, ok, so oft startet der jetzt nicht, aber dennoch.
Au weh! Da ist dann aber ein verbuggtes DHCP an der Arbeit.

Nicht vergessen in Plesk den Hostname zu setzen!
Und früher hat in solchen Fällen folgendes gegen Änderungen nach Boot geholfen
Hostanem setzen mit hostname -b sv1234.example.org
Rechte auf Unveränderbar setzen chattr +i /etc/hostname
Ob nach chattr dann der vServer noch startet weiß ich nicht, manche Hosts mögen das nicht.

Thread erinnert mich an https://serversupportforum.de/threads/resolv-conf-ohne-usereinwirkung-geaendert.23388/ und frühere Problemen bei Strato- und 1&1-VServern, nicht nur beim Resolver.
 
Last edited:

danton

Debian User
Wenn es am DHCP liegen sollte, dann sollte es ausreichen, die IP manuell zu konfigurieren.
Bei den Hardware-Servern von Strato war es (zumindest, als ich noch dort war) kein Problem, den Hostnamen zu ändern, auch wenn man weiter die IP-Konfiguration per DHCP hat vornehmen lassen. Ich könnte mir daher eher vorstellen, dass der Hostname durch die VIrtualisierungslösung beim Booten immer wieder zurückgesetzt wird.
 

michaelh

New Member
Bei Strato die DHCP Config überarbeiten. Wichtig ist hierbei der Wert get-hostname ! Falls der Strato Hostname geändert wird, dieses entfernen!
 
Top