SSL-Problem nach Update

haegar

New Member
Hallo zusammen,

ich kämpfe seit Monaten mit dem dringend notwendigen Update eines Strato V-Servers von UBUNTU 14.4 auf 18.4. Nachdem ich nun den Server erneut neu aufgesetzt und ein Restore eines Plesk-Backups durchgeführt habe, erhalte ich bei allen Seiten (mit einer Ausnahme) folgende Fehlermeldung:
Fehler: Gesicherte Verbindung fehlgeschlagen

Beim Verbinden mit www.glodek-edv.de trat ein Fehler auf. SSL hat einen Eintrag erhalten, der die maximal erlaubte Länge überschritten hat. Fehlercode: SSL_ERROR_RX_RECORD_TOO_LONG
Beispiel: https://www.glodek-edv.de

Wenn ich die URL über einen SSL-Checker prüfe (https://www.sslshopper.com oder https://www.ssllabs.com/ssltest) bekomme ich aber nur positive Ergebnisse - laut diesen Tools iat alles OK.

Woran kann es noch liegen, dass die SSL-Check-Tools glauben, es sei alles OK, die Anzeige im Browser aber trotzdem zur Fehlermeldung führt, dass der Server angeblich kein Zertifikat ausliefert?

Ich weiß nicht ob es hilft, aber auf dem selben Server läuft auch die URL https://olm.glodek-edv.de/olm4/s4cp.php. Diese funktioiert einwandfrei.

Ich bin leider etwas ratlos und hoffe auf Hilfe

Vorab schon mal vielen Dank...
 

Thorsten

SSF Facilitymanagement
Staff member
Wenn ich die Seite aufrufe, bekomme ich einen Server Error:
Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator at [no address given] to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log.

Apache Server at www.glodek-edv.de Port 443
 

Lord Gurke

Nur echt mit 32 Zähnen
Dein Problem ist, dass Apache auf dem HTTPS-Port 443 kein HTTPS sondern nur unverschlüsseltes HTTP spricht - daher kommt auch die eher diffuse Fehlermeldung des Browsers, der am TLS-Handshake scheitert und die Daten, die er bekommen hat, nicht interpretieren kann.

Code:
~: telnet www.glodek-edv.de. 443
Trying 2a01:238:4295:200:953f:16ea:3cb5:f0a9...
Connected to glodek-edv.de.
Escape character is '^]'.
HEAD / HTTP/1.1
Host: glodek-edv.de

HTTP/1.1 200 OK
Date: Sat, 19 Oct 2019 11:19:16 GMT
Server: Apache
Last-Modified: Sat, 19 Oct 2019 05:01:53 GMT
ETag: "e96-5953c595e6096"
Accept-Ranges: bytes
Content-Length: 3734
Vary: Accept-Encoding
X-Powered-By: PleskLin
Content-Type: text/html
Das ganze passiert aber nur auf der IPv6-Adresse! Wenn ich mich per IPv4 verbinde, bekomme ich einen TLS-Handshake zustande.
Die Tatsache, dass ich auf Port 443 unverschlüsselt mit dem Server reden kann, zeigt die Fehlkonfiguration des Servers. Ich kenne mich mit Plesk überhaupt nicht aus (und bin stolz darauf), bei einer normalen Konfiguration des Apache ohne Plesk muss man aber auf jeden Fall auf HTTPS-Sites explizit "SSLEngine On" im VHost gesetzt haben.
Eventuell ist auch einfach nur die im DNS angegebene IPv6-Adresse falsch resp. eine andere, von der Plesk nichts weiß und deshalb auch nicht konfiguriert?
 

haegar

New Member
Danke für die Antworten. Da ich im apache2/error.log nichts gefunden habe, habe ich im log des vhosts nachgesehen und einen Hinwesi auf ein fehlendes expires Modul gefunden. Nachdem das nachinstalliert war, läuft es jetzt scheinbar.
Code:
ln -s /etc/apache2/mods-available/expires.load /etc/apache2/mods-enabled/
Vermutlich hat das fehlende Modul irgendwie verhindert, dass der Rest der conf-Datei gelesen wurde. Apache ist dann zwar ohne Fehlermeldung gestartet, war aber falsch konfiguriert. Die Fehlermeldung zur SSL-Konfiguartzion war insofern leider etwas irreführend :-(.

Ich kämpfe jetzt mal mit den näcchsten Problemen.
 
Top